2016.01 RC1 ISO ready for testing

[size=large]The Netrunner team is proud to announce the immediate availability of the first release candidate ISO for Netrunner Rolling 2016.01.
[/size]

Changes since 2015.11:
Linux Kernel 4.4
Calamares 2.0 Beta 7
Plasma 5.5.3
Frameworks 5.18
KDE Applications 15.12.1
QT 4.8.7 & 5.5.1

For a full list of applications included on the ISO:
http://arch.netrunner.com/ISO/netrunner-rolling-2016.01-RC1-x86_64-pkgs.txt

Download:
ISO: http://arch.netrunner.com/ISO/netrunner-rolling-2016.01-RC1-x86_64.iso
MD5Sum: http://arch.netrunner.com/ISO/netrunner-rolling-2016.01-RC1-x86_64.iso.md5

NOTE: This ISO is provided for testing and feedback purposes only, please do not use this ISO to re-install an existing system or on new installations.

Thank you and Enjoy.

Hello I tried RC2, although it wasn’t announced, can I post here my findings?

Sure, but did you download the ISO before or after Friday the 12th?
The ISO wasn’t announced yet because we had not finished testing it.
We did find a couple of issues with the ISO, so we fixed these and then updated it on the server, Friday.

It matches the md5sum of the .iso.md5 file so yes.

Live session:
During the first test, I moved the pointer while loading the desktop (right after login) which resulted in the pointer staying unresponsible for the rest of the session in the center. Also happenes in my normal install.

Installation in bare metal:
Next reboot I tried installing it using calamares. The installation failed with this message:

However I couldn’t find any log file for calamares. I searched in /var/log and /tmp

Next reboot I tried again. Manual partitioning, BIOS, MBR next to a Windows 7 partition. Finished without errors.
There where two Grub entries, one simply named 'Netrunner Rolling" and another “Netrunner Rolling 4.4.1-MANJARO” First goes till the login screen, where I type my password, the screen goes black and then login screen comes up again.
Second gives this mesage:

As always thanks for your hard work and dedication making netrunner possible!

I just tested this ISO again in both virtual box, and on bare metal (two separate systems) with no issues.
May I ask how did you create your live media?

This ISO uses a hybrid multilayered file system and needs to be burnt to the USB in raw mode, unetbootin and similar utilities that extract the ISO files contents onto an already partitioned file system is not supported.

If being written to a DVD, then using the slowest possible speed is recommended.

Please read and follow this guide to avoid random issues like the ones you’ve mentioned:
https://wiki.manjaro.org/index.php?title=Burn_an_ISO_File

I used windows with Win32 Disk Imager https://sourceforge.net/projects/win32diskimager/ Let me try again this afternoon.

I’ve had my best experience using ImageUSB under windows: http://www.osforensics.com/tools/write-usb-images.html

Under Linux I prefer to use Suse Image Writer or Manjaro’s own isousb tool.

Update: I just updated the RC2 ISO again Sunday evening to include Saturdays update-pack. I would suggest a fresh download before trying again.

Downloaded the RC2 ISO 2016-02-16. Installed it from LiveUSB, made with dd. Running it for the 2nd day. It’s hard to believe, but don’t find any problem at all in the installed system. Everything works as it should. Very nice!

Just a quck tip. Open KSysGuard before launching the installer. Select the System Load tab and monitor CPU History graph (at the top). The installer, once double-clicked (launched) takes a long time to open its window. In my case it was 1 min 46 sec. Seems like nothing happens in the system during that time. But KSysGuard shows the ongoing CPU activity after launching the installer. So the user can see that the system is working, and avoid doing other double-clicks on the installer’s icon.

Another thing. Even though the installer permits to avoid placing the boot loader somewhere on the disk (“do not install any bootloader”), Grub 2 packages are installed nevertheless. Even worse, the grub.cfg generation is launched. Various os-prober and grub-mount are executed. On a computer with 12 Linuxes installed it took almost 4 hours to complete grub.cfg generation.

I do not use and do not need Grub 2. And uninstall all its packages, if they were installed. Those 4 hours is a wasted time. KSysGuard helps to see, that the system is working, so the user should patiently wait until all CPU activities are ceased. And do not interrupt the installer or reboot a computer.

As I can’t find any bug in the installed system, for now, my very personal score for Netrunner Rolling 2016.01 RC2 is 10/10.

Regards

With that many Linux installs on one system, it could just be the initial scanning of the devices and partitions that is taking Calamares so long to load. The issue with grub2 still installing and generating a configuration file after selecting “do not install any bootloader” would definitely be a bug.

Update: The bug where grub-update is run even if “do not install any bootloader” is selected has been found, fixed and an updated calamares-dev (2.0 beta 8) package has been uploaded to the repository. An updated RC2 ISO will soon be available for testing.

Highly appreciated. Thanks a lot.

The current Netrunner Rolling 2016.01 RC2 of 2016-02-18 18:58 (yesterday) has a more recent timestamp then previously available RC2, which was uploaded two or three days ago. And continues to run without a problem here.

Seems like the current RC2 is already an updated version. Will download and install it (in another partition).

Thanks again.

Wow. It took 10 min to do everything, from power on to shut down:
[list]
[]installer startup = 1 min 30 sec
[
]system config, 5 used partitions, none formatted = 4 min
[]“do not install a boot loader”
[
]unsquashing the image = 4 min
[*]done
[/list]
The fastest installer ever :slight_smile: . Other than 4 hours with the previous RC2. Good job.

Thank you for you kind words. I’m glad to hear that the installer is now faster after it was patched, recompiled and repackaged. Indeed, the ISO was also rebuilt and updated on the server soon after uploading the updated calamares-dev packages to the repositories.

NOTE: The RC2 ISO is still being internally tested and has yet received an official status, for now the RC1 ISO is still the official public testing ISO.

Got it.

But unofficial RC2 is so good, even in its current state, that can’t resist to not use it :slight_smile: .

Well, Calamares RC1 was just released today, so another rebuild of both are on their way. :wink:

The 2016.01 RC2 snapshot ISO is now officially released: http://forums.netrunner.com/showthread.php?tid=23360