404 Error apt-get update

Thought I’d let you know that I am getting a 404 Error, failed to fetch when I do apt-get update. It is coming from the netrunner ppa. I haven’t changed anything.

W: Failed to fetch http://packages.netrunner-os.com/dists/trusty/main/binary-amd64/Packages 404 Not Found

W: Failed to fetch http://packages.netrunner-os.com/dists/trusty/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

You will need to update your /etc/apt/sources.list like this:



Go well,

This is a bit confusing. Did the RC ship with incorrect sources?

My install is brand new. I saw the 404’s on the first update. That eventually stalled out with a “waiting for configuration file” message displayed for several minutes. I killed the process because the app would not close.

Sources.list is empty except for this: “# Please use a seperate file in /etc/apt/sources.list.d directory”.

In “sources.list.d”, the Netrunner repos are in “official-packages-repositories.list”, which is prefaced by a warning to avoid editing the file and use Software Sources instead.

“Software Sources” does not launch, returning this in a terminal:

"Error: “/var/tmp/kdecache-joncr” is owned by uid 1000 instead of uid 0.
Traceback (most recent call last):
File “/usr/lib/linuxmint/mintSources/mintSources.py”, line 1215, in
File “/usr/lib/linuxmint/mintSources/mintSources.py”, line 537, in init
if self.config[“general”][“use_ppas”] == “false”:
KeyError: ‘general’

And, in any case, I’m not sure those raw URL’s are something sources.list would accept.

I didn’t mean to use the lines exactly like that, all I was trying to convey was the change from trusty to fronteir-14 in those lines you posted, However, I feel that either you got messed up by the way you closed the update, or you have a corrupt ISO file. Could you confirm that the checksum matches the ISO file?

Sorry, can’t confirm the checksum at this point. The ISO was on one of the install drives, which were repartioned and formatted. The install was normal; no other problems apparent.

When the initial update failed, reporting the 404’s, after a reboot, I tried a manual update (sudo apt-get update). That failed, displaying a message that dpkg had been interrupted (when I killed the updater, no doubt) and that I needed to run “dpkg --reconfigure -a”. I did that. A few packages finished installing and a new initramfs image was built.

I reinstalled mintsource and software-properties-common/kde/gtk. No change.

After editing that sources line, I can update/upgrade manually.

software-properites-kde/gtk launch successfully, but also report that same UID error: “Error: “/var/tmp/kdecache-joncr” is owned by uid 1000 instead of uid 0.” That directory is recreated with the same ownership when I delete it.

Hmm, you’ve got some strange things going on there, unfortunately it’s been a while since I ran a Debian based distribution, hopefully someone with more knowledge of the current Ubuntu base can chime in to help you out.

Go well my friend,

I am trying to reproduce this problem. But failed so far.
What did you do initially before the 404 error started ? Did you start or modify the sources list by hand or software-properties-kde ?
My guess is that it modified the sourceslist and produced the initial 404 error.

The dpkg message is another error which comes from not running successfully or a package failed during installation and interrupted the configuration process.
A sudo apt-get install -f in a terminal might help here to fix it or to get the culprit :wink:

This is indeed strange the kdecache-<username> folder needs to have the uid 1000 owner. Maybe /var/tmp is not owned by root (uid 0) but the user (uid 1000). If thats the case you can change the owner and group by executing

sudo chown root:root /var/tmp

I could not repoduce this problem so far. Maybe it has todo with the not successful upgrade performed earlier.

I went back and checked the live disc. It had the correct addresses for apt. Somehow the file either got corrupted or copied wrong. If you copy the file over from the live disc you should be okay. That’s what I ended up having to do.

I installed, rebooted, ran Software Sources to select a new Ubuntu mirror (Liquidweb, always reliable here), let it update the cache, ran the updates with the GUI tool, which stalled as mentioned. I ended the process in KSysguard, rebooted, ran “sudo apt-get update” and saw the 404’s.

[quote] This is indeed strange the kdecache-<username> folder needs to have the uid 1000 owner. Maybe /var/tmp is not owned by root (uid 0) but the user (uid 1000). If thats the case you can change the owner and group by executing

sudo chown root:root /var/tmp


Other folders in /var/tmp were root:root. Only kdecache- was username:username.

Maybe the install quietly glitched. Maybe the mirror hadn’t fully updated. I dunno. Will try it again and see. Thanks.