A cascade of breakage [solved]

My son installed the game Faster Than Light (FTL) from Steam earlier today.
After playing the game briefly he quit the game and then tried to quit Steam but kept getting a message that FTL was still running. (It turns out this is a known bug with the game on Linux which can be fixed by turning off the in game Steam community option)
I impatiently opened a terminal and issued a ‘shutdown now’ as a way to get him out of it.
Big mistake…
Upon restart couldnt open Firefox which would crash immediately, same for Dolphin, same for Kate… could’nt use apt-get because of errors…
Launching from a terminal I saw errors about fonts so after a bit of research I found that there was a known bug with pango-graphite in Ubuntu 13.04+
After rebooting in safe mode and removing pango-graphite I was able to boot normally. FF & Dolphin were back to normal.
Apt needed a bit of surgery to get it happy again but Kate & Kwrite stubbornly would crash on launch no matter what I did.
Launching them from terminal I saw errors about missing files in kdepart.
Due to the huge number of KDE dependencies the only way I could get kdepart ‘refreshed’ was :

sudo apt-get install --reinstall kdepart

Now Kate is working again.
What a rigamorole…
I thought Linux was more robust than this?

Thats the first time hearing about that. I guess the game is doing very nasty stuff to the system libraries so I would recommend waiting for a fix of the game before starting it again.

I shouldn’t have forced a shutdown.

What I should have done was open top, found FTL eating CPU & done a ‘killall -9 FTL’.
The fix is to turn off the in game steam community for that game until it is patched as it quits fine now.
All great in hind sight.

I wonder if running from an SSD & forcing a shutdown was the culprit?

As for the known pango-graphite bug, I observed no problem until this event.
After removal of pango-graphite the system performs totally normally so I wonder why it’s installed at all?