About Fcitx setting

I installed the input system of the Japanese.

Sudo pacman -S fcitx-mozc fcitx-configtool fcitx-im

Open the file in sudo emacs ~ / .xprofile, to add the following.

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx

Application menu> Settings> Fcitx the following error message in the set comes out.
I can not find the shared library.
Possible Causes
If an error occurs when you update the previous KDE, it had remained unknown module.
There is a third party of the old module.
These points verified carefully, please try to remove the modules that are listed in the error message.
If this does not solve the problem, please contact the distributor or package author.

Will there any way to solve.
Thank you for your professor.
Thank you.
● It should be noted that, for the input of Japanese are, we can without any problems.

That’s because you need the Qt5 and KCM for plasma 5 installed as well:

sodo pacman -S fcitx fcitx-qt5 kcm-fcitx

I received your reply, Thank you very much.
Installation of the Japanese input system What was wrong.
In addition, we will pleased to report again at a later date.
Thank you in the future.

We received your professor, I’ve looked at the steps of the operation below, Fcitx setting has started.

sudo pacman -S fcitx fcitx-qt5 kcm-fcitx

I’m really thank you.
Thank you very much.

The problem has been resolved.
Thank you very much.