Audio not working properly

I just installed Netrunner 14, and so far everything is great except for the sound. The main issue is the volume setting can’t be adjusted directly on the computer except when using USB headphones in Chromium. Volume works fine when I adjust it on the mixer, but it’s not very convenient to do it that way. It must be registering something, though, as it makes a high pitched beep every time I try adjusting volume on the computer.

I also haven’t been able to get Firefox to play sound on YouTube, SoundCloud, etc., out of the Logitech USB headset – it continues to come out of the computer’s tinny built-in speakers. Changing the headset to be the master channel in KMix and making it the preferred device in KDE Control module successfully changed device for everything outside of Firefox (which is the only browser besides Chromium I’ve tried). So, basically Chromium is the only place where audio operates as it should. I actually use Linux primarily because I prefer their multimedia players to the bloated Windows ones, so this is a make-or-break issue. I’ve also tried rebooting after troubleshooting and still no dice.

Also, don’t know if this helps, but the only Linux distro where sound worked out of the box on this machine was Mageia (though I disliked everything else about it).

Computer is a Toshiba Tecra A10, which uses a Intel audio controller with 82801I chipset. Thanks in advance.

On edit: sudo lshw -C multimedia output if it helps:

description: Audio device
product: 82801I (ICH9 Family) HD Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:49 memory:ca000000-ca003fff

This might get the buttons to work:
open up /etc/modprobe.d/alsa-base as root and add this to the end of the file

options snd-hda-intel model=toshiba

To change the default sound card you would need to do that here:

Cool, thanks, the first suggestion worked. (I did change the default sound card pretty early in troubleshooting and it somehow didn’t help.) Looks like I’ll be keeping Netrunner for a while now.

Just out of curiosity, is there any way to set it so I don’t have to tell each program to use the USB headphones the first time I use it? Also, each time I log in I have to re-set the headphones to be the default in system settings audio. It keeps them as the preferred device under the Device Preference tab but not under Audio Hardware setup. I would just use normal headphones but managed to hose the jack a year or two ago. :confused:

Anyhow, thanks again. Fantastic distro and just what I was looking for.

It should remember and use the last device setting by default, if not then check the settings in this file: