automatic login not happening

Hello when I was installing this I chose the automatic login option but when I boot up it prompts me for my password. Also every so often it boots me into like a terminal whiich only typing shutdown seems to work. A bit lost on this one thanks.

I am dual booting with Win 7. Just in case this info is useful.

Check the MD5 of the ISO you downloaded.
Also more information is needed, what kind of graphics card or cards do you have installed, do you have a UEFI or Bios system, is your system Intel or AMD based, do you see any errors on boot up, etc.?

I had a simular issue with the log in manager, but pro tip dont automatically log in.
Passwords are essential for a systems security and auto login is not the way a OS should operate.
I know auto login is more convenient, but if you cant spend an extra few seconds to type in a password at login may I suggest going back to windows which by the way nowadays also does not auto login.
Anyhow I fixed my login issue by updating to the latest login manager via the arch user repositories, if you are not affraid of a little command line I can assist you getting it.

Auto login problem is happening because in teh installation process autologin is set for KDM while Netrunner is using SDDM. There are two options that you can chose from:

  1. disable SDDM and use KDM
sudo systemctl disable sddm.service -f
sudo systemctl enable kdm.service -f

2) go to System Settings -> Startup and Shutdown -> Login Screen (SDDM) -> Advanced and enable autologin and choose user

I tried the line of code suggested by emptybb and it seems to have solved the problem.Thanks for your help and I appreciate everone elses input. I am glad to be part of the Netrunner/Manjaro community.:slight_smile:

OK, so it was just an over-site in the installer’s scripting, good to know.

Thanks for this as SDDM isn’t auto logging in for me ether.

Option 2 is enabled but doesn’t respond to auto-logon which is set in sddm.conf

HaltCommand=/usr/bin/systemctl poweroff
RebootCommand=/usr/bin/systemctl reboot



Also the SDDM setup in settings there are no other theme’s listed and no way to install other theme’s?
Seems released to early before prime time use?


Your sddm.conf looks a little bit weird.
I guess this two lines also need to be in the [General] section for it to work.


SDDM is under heavy development right know which might introduce some changes here and there and old configs or configuration tools not to work as expected.

I figured as much as doesn’t appear to be ready for prime-time. And no biggie will just use KDM. Tho the weird thing is Get More Themes. Click on install and they showed downed and installed but don’t appear in the KDM theme list. Don’t know what that is about.

Thanks for the heads Up!

KDM is a discontinued project and will receive no more updates, it has already been removed from the Plasma 5 packages upstream and is the successor of KDE SC 4 and will soon replace it as the KDE Projects default desktop environment.

Yep was aware it’s on it’s way out. Doesn’t help discontinuing it before SDDM has had time to mature and reach the feature state that KDM is already at. As seems problematic for a lot of users.

I believe that I have found what has caused your auto log in issue, as well as a few others that have been reported to me and a few more that I have noticed myself after SDDM was updated, and it was so obvious I could smack myself.

Here is a post I just made about the changes between the old version of SDDM 0.1.0 that shipped with Netrunner Rolling, and SDDM version 0.9.0 that we just updated to. I also explain how to restore it to full working order, and you won’t believe just how easy it is.