back to Netrunner | back to Blue Systems

Cannot reboot-shutdown..inxi does not work


#1

Lenovo legion y530 15h intel i5h.
Not able to reboot or shutdown using desktop app.
Problem with terminal cmd inxi.
Only inxi works, it does not with parameters.

stefano@stefano-legion-y530:~$ inxi
CPU: Quad Core Intel Core i5-8300H (-MT MCP-) 
speed/min/max: 1670/800/4000 MHz Kernel: 4.19.0-8-amd64 x86_64 Up: 49m 
Mem: 1547.7/7852.2 MiB (19.7%) Storage: 1.03 TiB (0.7% used) Procs: 205 
Shell: bash 5.0.3 inxi: 3.0.32

#2

What is the error message you get when executing inxi with parameters?

When you cannot reboot or shutdown what exactly did you do and what exactly happens?
So you go to your menu choose shutdown and it does not do anything? Or it does turn off the graphical user interface and you get stuck somewhere else?


#3

Inxi responds only typing:
inxi (that’s all)
if i add parameters like inxi -F or -G or others it get stuck then i must close terminal window.
About reboot or shutdown i do nothing but after booting.
It stuck with keyboard dead. Must force shutdown laptop.
Thank you.


#4

That is weird indeed. I can only imagine inxi trying to get some information about your hardware and cannot get it to the point it crashes.

That reboot and shutdown leaves you without a working keyboard when you turn on the device again is pretty weird. Or did you mean it does nothing and does not react on key presses after you press shutdown or reboot?

All in all I assume the system has problems with your hardware. Can you tell us which hardware you have?
Maybe installing a new kernel from debian backports can help you as it usually supports a bit more modern hardware.
To do so you need to go to synaptic and software sources and make sure that the debian buster backports repo is marked active. Reload the package list in synaptic and install the linux-image-5.4.0-0.bpo.2-amd64 package.
After that try rebooting and see if it works better with the new kernel.


#5

Thank you Leszek,
i mean keyboard does not react at all and i must do a hard shutdown.
I’ll post the inxi -F report using another distro but later on.
Good idea to install a new kernel, will try later.
I’ll let you know, good day.


#6

Here inxi output:

stefano@stefano-Lenovo-Legion-Y530-15ICH:~$ inxi -F
System: Host: stefano-Lenovo-Legion-Y530-15ICH Kernel: 5.3.0-40-generic x86_64 bits: 64
Desktop: KDE Plasma 5.12.9 Distro: Zorin OS 15.2
Machine: Device: laptop System: LENOVO product: 81FV v: Lenovo Legion Y530-15ICH serial: N/A
Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: N/A
UEFI: LENOVO v: 8JCN52WW date: 06/14/2019
Battery BAT0: charge: 47.0 Wh 95.0% condition: 49.5/52.5 Wh (94%)
CPU: Quad core Intel Core i5-8300H (-MT-MCP-) cache: 8192 KB
clock speeds: max: 4000 MHz 1: 1387 MHz 2: 3436 MHz 3: 3439 MHz 4: 3381 MHz 5: 3360 MHz 6: 3397 MHz
7: 2951 MHz 8: 3382 MHz
Graphics: Card-1: Intel Device 3e9b
Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
Display Server: x11 (X.Org 1.20.5 ) drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: 1600x900@59.99hz
OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 version: 4.6.0 NVIDIA 440.59
Audio: Card-1 NVIDIA GP107GL High Definition Audio Controller driver: snd_hda_intel
Card-2 Intel Cannon Lake PCH cAVS driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k5.3.0-40-generic
Network: Card-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi
IF: wlp7s0 state: up mac: 04:d3:b0:9e:1b:00
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
IF: enp8s0 state: down mac: e8:6a:64:16:09:10
Drives: HDD Total Size: 1128.2GB (1.1% used)
ID-1: /dev/nvme0n1 model: RPFTJ128PDD2EWX size: 128.0GB
ID-2: /dev/sda model: WDC_WD10SPZX size: 1000.2GB
Partition: ID-1: / size: 181G used: 12G (7%) fs: ext4 dev: /dev/sda3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 49.0C mobo: N/A gpu: 38C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 253 Uptime: 4 min Memory: 758.3/7835.4MB Client: Shell (bash) inxi: 2.3.56
stefano@stefano-Lenovo-Legion-Y530-15ICH:


#7

I’ve installed linux-image-5.4.0-0.bpo.2-amd64 but same problem.


#8

Reading the official lenovo forum here: https://forums.lenovo.com/t5/Linux-Discussion/Legion-Y520-Freeze-when-try-to-shutdown-or-restart-after-fresh/td-p/4162896

I think the main issue is coming from the implementation Lenovo uses for its hybrid Intel + Nvidia chip combination.
It seems you really need to either use the one or the other to avoid issues.
According to the post setting the graphics option in BIOS to UMA will solve the reboot/shutdown issues.
However you will then loose the ability to use the Nvidia catrd.

Another thing you could try is setting the graphics to Discrete and installing the official nvidia driver.
See Debians Wiki for how to do that: https://wiki.debian.org/NvidiaGraphicsDrivers

If you don’t need the Nvidia card and can life with the Intel card I would recommend only using it for now.


#9

Well the bios of my lenovo legion y530 does not support graphics option.
I mean cannot change settings at all.
Can try installing the debian official nvidia driver.
Thank you.