cannot update system

starting full system upgrade…

resolving dependencies…
looking for inter-conflicts…
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

Command finished with errors!


The latest update can not be done with the GUI or with a simple sudo pacman -Syu.
Here is what needs to be done:
First open a terminal and use these commands:

sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S manjaro-keyring
sudo pacman -Suu

Go well,

[Tnx, AJ. Had the same problem. Following your advice system is now updating. :smiley:


You are most welcome,

I also followed this procedure twice and, after an hour or so during which it seemed to be updating normally with lots of “out of byte range errors” it finally ended with the message that “no packages were updated”. I don’t want to do this a third time. What went wrong please?

This sounds like the updated Key’s issue, please try these:

Rob McCathies (korrode) signature:

sudo pacman-key -r 5C0102A6 sudo pacman-key --lsign-key 5C0102A6

Joshuas Strots (dcell) signature:

sudo pacman-key -r CB6CDD17 sudo pacman-key --lsign-key CB6CDD17

then sudo pacman -Syyuu

Thanks for a very fast reply but – which one do I use?

Just do both, It can’t hurt, :slight_smile:

Done. Didn’t take so long this time but got the same negative result -

[color=#FF0000]Errors occurred. No packages were upgraded[/color]"

sudo pacman -Scc
sudo pacman -Syu --force $python

PS. If this Is this a new install:
sudo pacman -Syy
sudo pacman -S manjaro-system
sudo pacman -Suu

I have done these three commands before but I did them again with the same result. The commands are apparently executing but there is no flashing light on the router.

I have just checked /var/cache/pacman/pkg and it looks as if all the update files are there - there are some hundreds of them.
What do I do next?

Could you please post the last few lines of the exact errors your getting?

[color=#4B0082][maurice@Felix ~]$ sudo pacman -Suu
:: Starting full system upgrade…
there is nothing to do[/color]

But this is not, of cpurse, the error message I got in the previous attempts. Perhaps because all the files are now in /var/cache/pacman/pkg

This command Cleared out that cache so that the downloads would be newly downloaded:
sudo pacman -Scc

The next command ran as a normal Syu except it forced all of python to be updated:
sudo pacman -Syu --force $python

It looks like the update ran as expected. Your system should now be up to date, please verify this by showing your release version with this command: lsb_release -a

This is what you should get:
LSB Version: n/a
Distributor ID: ManjaroLinux
Description: Manjaro Linux
Release: 0.8.10
Codename: Ascella

Note: for more info on pacman:


And that’s exactly what I got,

Many thanks AJ for your prompt replies that enabled a fast resolution of the problem. And - yes - I’ll read the wiki.


You are very welcome, I’m glad I could help. I wasn’t suggesting that you NEED to read the wiki, I just posted that as a reference.

PS. Could you please mark this thread (Solved) in the original subject line, that would be much appreciated, thanks.

The original subject line is not clickable. Maybe because I hijacked the thread?

And so you did, my bad, never mind then. lol :slight_smile:

Thanks mate. THat helped me too :cool: