Cannot view or add HP printer

I have a networked HP LaserJet 2200 printer that uses JetDirect and a wired Ethernet connection to my D Link DIR-615 router, set up in DHCP mode to assign LAN addresses in the 192.168.0.n range. I have set the router up to assign the static address to this printer.

For some reason, the printer does not show up on the list of active clients on my router and that address in unreachable by browser. I am unsure whether this is because of a firmware problem on my router or whether it has to do with cups etc., on my system, or whether it is related to the printer hardware.

Using the KDE printer setup dialog leads to an undiscovered printer. So does running hp-setup.

I tried the workarounds in this somewhat dated thread:

but did that did not resolve the issue either.

Because I do not know if it is a problem with my router and its settings not recognizing the JetDirect or whether it is cups-related, or whether it is printer-hardware-related, I am stuck without any ability to print. Any help is most appreciated.

I’ve never used JetDirect before, but I’m sure it should still show up in the routers client list.
It could be a bad cable between the printer and the router, or the networking configuration on the printer.

Thank you for stimulating my thinking to troubleshoot, AJSlye.

When the Ethernet cable is connected to a laptop, it shows up on the router: so the Ethernet cable is fine.

While troubleshooting, I came to realize that the printer supports printing via a USB cable as well. When connected by USB, the printer shows up with both KDE settings and hp-setup, and prints OK. So, I think that cups is working fine on my system.

That leaves the JetDirect card as the faulty component: and this is the second one that has failed. Ouch!

I’m glad to see you figured this out.
However, It might not be a faulty card, it might just be the networking settings in the printer are wrong. :wink:

Thanks for egging me on.

I tried a cold reset of the printer to revert to factory settings by powering the printer on with the GO button depressed. Then I pressed the GO and JOB CANCEL buttons simultaneously to get the configuration printed out as suggested here:

Interestingly, the configuration under TCP/IP shows the IP address I am trying to assign to the printer: and the gateway and subnet mask are correct as is the DNS server.The network statistics are unremarkable save for Unicast packets received, which is only one.

The only setting that seems flaky is the IPX/SPX; its “Status” is “Initializing”. The overall I/O Card and TCP/IP both report that they are ready.

But, I cannot telnet or ping the address They fail with messages like “no route to host”.

I am unsure whether the D Link DIR-615 needs port forwarding to be set, or whether the JetDirect card is not “auto-negotiating,” or whatever. In any case the printer does not show up on the router as an “active client” even after both were power-cycled.

So, it appears to be USB rather than Ethernet for the printer for the time being while I iron this out.

[By the way, is there a way to turn off quoting when replying?]

To turn off quoting, click the “New Reply” button instead of the “Reply” button :wink:

OK, I did a bit of research and jetdirect is nothing more than the name HP uses for it’s print servers, even the ones built into the printers. You should only be using tcp/ip with your router, you’ll need to find a way to turn off ipx/spx on the printer. Unfortunately, I was unable to look this up for you. It seems that the HP support servers for manuals and drivers, is currently down for scheduled maintenance until 12:00 AM PDT tomorrow.