Can't init SDL No available video device

Hey folks!

I have a rather peculiar problem, which I fail to understand. I was trying to install latest NVIDIA driver 340.93, and something went wrong, I couldn’t boot, so I went recovery and removed all NVIDIA drivers, reinstalled 340.76. Now everything works, except SDL applications (Dosbox, etracer, etc…). They all give:

or something similar. Now I’ve tried reinstalling libsdl1.2-dev as some advised, couldn’t met dependencies (The following packages have unmet dependencies: libxext-dev : Depends: libxext6 (= 2:1.3.3-1) but 2:1.3.3-1netrunner1 is to be installed).

So, what I’ve tried, I went sudo and run DosBox from there - how amazed I was when whole screen went DosBox! So, to my understanding, if I run it as root, it considers main X window as default for output, but if I don’t, it fails finding X screen.

Any suggestions on fixing it?

Much obliged!

Ah strange problem indeed.
Did you tried reinstalling the sdl libraries in particular the libsdl1.2debian package ?

If not try this

sudo apt-get purge libsdl1.2debian sudo apt-get install libsdl1.2debian
Removing might remove all sdl based games aswell. So make sure to make a list on all packages that get removed and reinstall them afterwards.

Reinstalling seems to be an overkill for misconfiguration issue, still, I’ve just did it exactly as you proposed - the same, apps give:



Once again, if I run it as root, the app actually works but takes away X screen. So, I don’t believe the problem is in libsdl1.2 library per say, it seems like SDL fails to create window. Also seems like its somewhat permission issues, but I cannot understand where. In configuration, or libsdl library files, or elsewhere… :huh:

Okay, tried this one:

Now I got new error (in all SDL apps):

Seems to me like my normal user got its permission screwed. But I don’t really want to chmod a+rw /dev/*. Suggestions?

SDL should use x11 not fbdev /dev/fb when you have Xorg running.
I did not manage to find a similar problem anywhere where there is a different fix besides removing and reinstalling SDL.

Maybe you can try specifying the output for the SDL apps somehow and try another to see if that works.

I’m walking just behind you :rolleyes:



Setting to anything other than fbcon, produce the same error. While setting SDL_VIDEODRIVER to fbcon, makes screen black, Ctrl+Alt+2 + Ctrl+Alt+1 returns back to X session with:

That’s all under root. Under normal user, with SDL_VIDEODRIVER=fbcon, it returns:

Side Note: when setting export SDL_VIDEODRIVER=fbcon, set |grep SDL gives SDL_VIDEODRIVER=fbcon, while export SDL_VIDEODRIVER=x11, gives set |grep SDL:

Which is strange, but I guess besides the point here.

strace of dosbox:

Trying to install libxext-dev:

It seems to me I must somehow disable netrunner repository for this to work. Or maybe upload libxext-dev to netrunner repo? It seems it was there in 15-updates version?

I don’t know why you want to install libxext-dev?
In any case the netrunner version of libxext6 is installed. So if you want to install the -dev package you need the one version from the netrunner repo. Take a look with muon which versions are available and install the netrunner one.

In order to try and compile SDL from sources. In muon I cannot find libxext-dev, but I do find it in Synaptic, and unlike some other software, there is only version shown - 2:1.3.3-1 ,not netrunner edition. Force Version also doesn’t allow to choose alternative, which leads me to a conclusion: either Netrunner doesn’t ships with one, or I miss some repo with it.

My repos for Netrunner are:

Note, also enabled all deb-src with the same data as above and made update. Still, no libxext-dev netrunner edition.

Then replace the libxext6 version with the non netrunner in name version and install libxext-dev after that (that should work then)