Can't logoff

Since upgrading to kernel 3.16 and then doing a system upgrade a few of days ago, sometimes I can’t logoff. Sometimes I can though. I haven’t figured the pattern as to when it works and when it doesn’t.

When I can’t logoff, nothing in session or system will work, except Lock. I can’t shutdown, restart, hibernate, sleep, switch user, or log off. I can lock the system though. These won’t work in krunner either. I execute the command (or click) and nothing happens at all.

After a power button shutdown or two, they all start working again.

Any ideas what’s going on and how to fix it?

Thanks,
Clyde

PS - System is up-to-date.

Now I’m not exactly sure what might be stopping you from logging off, but on occasion a large update will prevent me from doing so (sometimes it’s not limited to distro either, and I’ve had it occur on others). Try to avoid, if at all possible, a power-cycle though (power button shutdown).

Here’s some alternatives which could help you reboot safely at the very least:
“reboot” in terminal, may need sudo
“shutdown -r now” in terminal, may need sudo

And, in absolute worse case of a freezeup,
Alt + SysRq (usually PrtScr or near it) and R, E, I, S, U, B slowly, in order, while holding Alt + SysRq (wait 30 seconds between presses if you want to be really safe, but usually I wait maybe 2-5 seconds). This sends commands directly to the kernel to emergency sync to disks, unmount, yada yada, and reboot. Good way to remember it is “Busier” backwards. It’s a last-ditch, though, so try to use the other methods first.

As for trying to diagnose the issue, do you get any visible errors when trying to log out? Or do you get any errors while trying to do the reboot methods I pasted above? (Again avoid “Busier” unless you get like…a complete system freeze. That’s there for your reference if ever needed in the future.)

As for logging out via command line, this is the most common command I’ve found:
qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout -1 -1 -1

Reference: http://askubuntu.com/questions/1871/how-can-i-safely-shutdown-reboot-logout-kde-from-the-command-line

I have not tested it yet, be aware. I will try it in a moment on my install and will edit this post in response.

EDIT:
The above command does appear to work, but it may drop you to terminal if your video drivers do not reload (in my case I had just changed them when I attempted the command). You can still reboot from there or another TTY, though.

Also another way to “log out” is to kill the xserver. Depending on setup there are different ways to do this, but traditionally it has been Ctrl+Alt+Backspace or Ctrl+Alt+K or similar. You may have to check your keyboard shortcuts.

Also checking out the hidden .xsession-errors file in home migbt help to see if there is a particular error message printed whenever your are not able to logout.

Thanks for the reply and some very good suggestions.

It seems to have settled down now and all the logoff/reboot/shutdown options are working fine now. It seems that it fixed itself, but I don’t know how or why. I’m happy though.

Thanks,
Clyde

Was probably a kernel issue, all the kernels received needed fixes and enhancements in the Christmas Day update-pack:. This update-pack also included a modification in grub2 to load early the microcode for your CPUs (currently working with linux310, 317 & 318 only).
However, the Manjaro 3.14 kernel series should also be loading the microcode, to check this enter this into a terminal window:

dmesg|grep microcode

https://forum.manjaro.org/index.php?topic=19072.0;topicseen

Thanks for that info.

I’m on 3.16 now, but giving some thought to trying 3.17.

Clyde

The kernels not listed in the grub2 modification we’re previously set to compile with the microcode, the ones listed we’re compiled with them set to compile as modules, either way the microcode should now be load with any Kernel series.

More good information to know.

Thanks,
Clyde

OK, some more information, I was mistaken earlier. The latest update to the 3.14 kernel series does not receive the early microcode anymore, This was an upstream change: https://wiki.archlinux.org/index.php/Microcode#Enabling_Intel_Microcode_Updates

Manjaro fixed this issue for us with the kernel series linux310, 317 & 318 only, I would recommend upgrading to the 3.18 kernel for now.

I hope this information is helpful.

It was very helpful. I’ll look at 3.18 then.

Thanks,
Clyde

The upgrade to 3.18 seems to have been flawless. I’ve found no issues at all. Love it.

Thanks,
Clyde