Can't Update? (kdebase-lib and kde-templates are in conflict) [SOLVED]

Newly installed Netrunner Rolling. Several packages needed replaced, I clicked “Y” for each. Then get “kdebase-lib and kde-templates are in conflict”…

[unclespellbinder@netrunner ~]$ sudo pacman -Syyu [sudo] password for unclespellbinder: :: Synchronizing package databases... netrunner 13.0 KiB 1862K/s 00:00 [##############################] 100% core 138.2 KiB 987K/s 00:00 [##############################] 100% extra 1934.8 KiB 3.00M/s 00:01 [##############################] 100% community 3.6 MiB 6.77M/s 00:01 [##############################] 100% multilib 188.6 KiB 11.5M/s 00:00 [##############################] 100% :: Starting full system upgrade... :: Replace kactivities-frameworks with extra/kactivities? [Y/n] :: Replace kdegraphics-ksnapshot with extra/spectacle? [Y/n] :: Replace kdemultimedia-ffmpegthumbs with extra/ffmpegthumbs? [Y/n] :: Replace lib32-gnutls28 with multilib/lib32-libgnutls28? [Y/n] :: Replace libkdcraw with extra/libkdcraw4? [Y/n] :: Replace libkexiv2 with extra/libkexiv2_4? [Y/n] :: Replace libkipi with extra/libkipi4? [Y/n] :: Replace libksane with extra/libksane4? [Y/n] :: Replace muon with community/discover? [Y/n] :: Replace signon with extra/signond? [Y/n] resolving dependencies... looking for conflicting packages... :: kdebase-lib and kde-templates are in conflict. Remove kde-templates? [y/N] error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: kdebase-lib and kde-templates are in conflict [unclespellbinder@netrunner ~]$

What happens if you say y when it asks to remove kde-templates ?
Normally it should then work.

Didn’t know if that was safe. I should use sudo pacman -R kde-templates ?

Getting ready to leave for work, I’ll try when I get home this afternoon. Thanks for the quick response.

During the update process it’s almost always best to hit yes when prompted, there are only rare instances where this would not be recommended. Using pacman -R kde-templates might be OK as well, however this command will also remove it’s dependencies with it, letting the update process remove it wouldn’t since it is also installing it’s replacement (kdebase-lib) at the same time.

[size=small][font=Monaco, Consolas, Courier, monospace]Just hit -y it will remove kde-templates, but don’t worry, it’s safe to do it. kde-templates are being replaced by kdebase-lib now.[/font][/size]

Thanks. But now I get the following…

code checking keys in keyring [##############################] 100%

downloading required keys…
error: key “9BDCF497A4BBCC7F” could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
[unclespellbinder@netrunner ~]$[/code]

sudo pacman -S archlinux-keyring manjaro-keyring

As AJSlye says
[color=#333333][size=xx-large][font=‘Open Sans’, Helvetica, Verdana, Arial, sans-serif]sudo pacman -S archlinux-keyring manjaro-keyring[/font][/size][/color]
[color=#333333][size=xx-large][font=Open Sans, Helvetica, Verdana, Arial, sans-serif]And then go with [/font][/size][/color]
[color=#333333][size=xx-large][font=Open Sans, Helvetica, Verdana, Arial, sans-serif]sudo pacman -Syyu
[/font][/size][/color]

MANY THANKS!!!