Cleanly Removing PulseAudio [SOLVED]

Hi guys,

As always PulseAudio does not work and trying to fix it only makes it worse. I tried to set it up as I do in other distros but there is no result - most apps have no sound. I reverted to the default settings but now there is no sound at all. When I kill the server everything works perfectly. When I was using Ubuntu a few years back, removing PulseAudio was one of the first things I did. What is the cleanest way to completely purge it from the system? When I try to remove it from Octopi, it requests to uninstall many other packages, most of them seemingly unrelated.

To remove pulse audio:
sudo pacman -R pulseaudio pulseaudio-alsa manjaro-pulse pulseaudio-ctl kdeplasma-applets-veromix-git-blueshell netrunnerarch-default-settings

ignore the optionally depends errors, they mean what they say optional…

Thanks! That fixed the sound problem but created a host of other problems. On boot up I get an error message that kdeinit can’t load From what I can see, the preloading is managed by netrunnerarch-default-settings but it, on the other hand, requires pulseaudio. I went through /usr/bin/startkde but couldn’t find the line for the preloading script. How can I stop it from executing? I don’t know if it’s related but as of this morning Firefox gives a Glibc segfault error and won’t start.

The preloading can be removed from autostart. In ~/.kde4/autostart or ~/.kde4/share/autostart

Thanks, now everything works OK.