Digikam crashes on startup [SOLVED]

Has anyone else had this?

Any ideas what is causing it?

I don’t use digikam but, this bug seems to have been reported:

Not sure if this is your issue but using phonon-qt4-vlc might solve your issue.
source: https://bbs.archlinux.org/viewtopic.php?pid=1457155

I was trying to track down the cause of this yesterday and I came across lots of posts on the digiKam mailing list about this. According to the digiKam author, it’s not digiKam itself that’s the problem, it’s other stuff such as outdated versions of exiv2 and the phonon backend. Try changing the phonon backend as @AJSlye has suggested and see if that fixes it. I haven’t tried it yet myself but I’ll be trying it later on this morning.

IT WORKS!!! I installed phonon-qt4-vlc and it worked first go. You guys are the best. Thank you all x

I’ve just got around to installing this myself and … it works for me too :smiley:
It also partially fixes a problem I was having here: http://forums.netrunner-os.com/showthread.php?tid=16364


The issue seems to be that phonon-qt4-gstreamer and/or phonon-qt5-gstreamer uses the new gstreamer 1.4.1 and not 0.10 anymore, so you’ll need gst-plugins-ugly and gst-libav to be installed.