Dolphin No Longer remember Devices List

Since update now Dolphin doesn’t remember devices show/hidden.
Always worked fine and my devices setup.

Now when I close and open Dolphin again I’m greeted with full blown list.

I manually set them multiple times but each time Dolphin is run it defaults to full list.
I even ran sudo dolphin and after three tries got dolphin to remember devices state. But didn’t help.

No issues before the update. And just remember and checked and still no fix for showing Image resolution or other image data in thumb popup. Which been an ongoing issue lost back in Jan.? Feb? update.


Yes, I have the same issue.

That’s strange, after the update my devices were back, but all i did was right click, hide and they are gone. I would take a good look at your config files, it might be using the new locations, or the permissions might have changed.

Don’t know where to look as don’t know where Dolphin maintains the show/hidden devices lists. As I haven’t changed anything on my end. And reading the link to Manjaro forums shows others as well seeing this issue. I suspect something manjaro as google search recent on the issue doesn’t show any other distro’s chiming in with issue.

So don’t know if this is specific Application or KDE issue or a Manjaro specific issue?

I think those are located @


Took a look So yep I’m suppose to figure out which lines that pertain to which devices in a 5,468 lines of code in a xml file? Not knowing if there are multiple places I have to change? Or multiple devices pertain sda5 as well as / root or sda6 /home. Not accounting for the 2 internal Ntfs Windows partitions as well as 2 external ntfs usb drives,E-reader,Nikon camera etc…

Hoping for a easier fix as don’t want to invest hours or two trying to figure out.
As am a production user not under the hood mechanic. Easy fixes no problem can live with a little tweaking when shown where and how. But to analyze a huge config file trying to figure it all out Nada not for me.

Thanks for the help tho. Just see that file as very daunting and time consuming and confusing.

I wouldn’t bother too much, someone replied it would be (hopefully) fixed in kdebase-dolphin v15.04.1, to be released tomorrow. And then we have to wait for it to be published in unstable and testing, and after a week or so in stable.

You might check and see if you might need to do some symbolic linking from the new location to the old one.


This will need to be done with more and more applications as they get modified to work with Plasma 5 and/or ported to KDE Frameworks. I don’t need to worry about this too much as I already upgraded to plasma 5, but users of KDE SC 4 will:

It was worth a try, but no changes.

Did you just symbolically link /.local/share/kfileplaces/ to /.kde4/share/apps/kfileplaces or did you read and follow the guide I linked to for KDE SC 4?

Here is what I did when I was still using KDE SC 4 to keep from having issues:
I first moved the contents of the KDE 4 folders to their new locations:
.kde4/share/apps/ to .local/share/
.kde4/share/config to .config/
.kde4/autostart and .kde4/share/autostart to .config/autostart/
I then removed the empty KDE 4 folders and symbolically linked to the new plasma 5 folder back to the old locations.

Note: This is kind of the same symbolic linking concept that is used for the placement of all binaries and libraries in /usr/bin and usr/lib.

Just noticed a deeper bug than I originally thought.

As applies to places also. All I have to do is right-click hide any place or device and hide and I lose Root and Home folders also. With no way to get them back. As selecting show all entries doesn’t bring back Root,Home,Trashcan,Networks,etc… they are gone no where to be found. Unless I close Dolphin and re-open.

So now more of an issue not having a places folders for Home & Root. When I try to hide unneeded devices.

OK, I just found that this IS a bug that was fixed in KDE Applications 15.04.1.
From the change logs:
kde-baseapps – Use user-places.xbel instead of bookmarks.xml in places model. Commit. See bug #345174

Luckily, KDE Applications 15.04.1 is currently in the Manjaro unstable branch.

Good to hear and thought it might be resolved quickly.
Hope it’s a bug that fixed will fix the devices issue also.

It should since that is part of places. :wink:

Was confused as well about some strange behavior of places. They are rearranged compared to what they used to be and if you drag and drop to rearrange, a bunch of them disappear from the list but they are back if you relaunch dolphin…

leledumbo on the Manjro forums seems to have solved this issue:

Well did a

rm *` in ~/.local/share/kfileplaces

And now have a > for a prompt. Anything else I need to do?
As still have the old places/devices issue when restarting Dolphin.

I’d ask leledumbo, I was only conveying the post.

OK, try this:

rm -rf ~/.local/share/kactivitymanagerd

Also make sure that baloo and akonadi are installed and working properly.

Yep looks good

Tried the command

rm -rf ~/.local/share/kactivitymanagerd

But still get this on starting Dolphin.

Setup back to my setup and close then open Dolphin and back to square 1.
As right clicking any device or places and selecting hide then Root,Network,Trash disappears also with 1st device I chose hide.