DRM_Radeon_Init Error on Boot

Hi all,

First off, I’d like to admit I’m a relative noob when it comes to linux, and that I’ve ran into this same issue with Manjaro before. I attempted to boot a live image, but whenever I do, I get a “DRM:Radeon_Init” error; “No UMS support in radeon module”. I looked into this, and it appears I need to use KMS. I quickly Googled the issue and I can’t figure out what I need to do to live boot. I’d rather try the distro out before switching.

KInfoCenter says I have a “AMD Heathrow PRO [HD 7850/8850M]”

Any and all help is greatly appreciated. Thanks!

Did you try the non-free drivers boot option ?

Yes, I tried all of the boot options. I get the same error.

Can you boot to the command line and manually remove the radeon module ?

sudo rmmod radeon

Then a sudo systemctl restart sddm should start the graphical user interface.

The first command did not work. “Error: Radeon module not loaded.”

The second command flickered the terminal, and I could not tell a difference.