error: no spezified device for Hipernation


i made a fresh install of Netrunner Rolling and now I got this message during boot.

What shall i do to fix this error ?

PS i use 8gb Ram and swap is a 8Gb partition .fstab shows it correct.


What does your GRUB_CMDLINE_LINUX_DEFAULT= line in /etc/default/grub file look like?

Did you run a system update after install?
If yes, did you use the update manager, Octopi or the command line?

If everything looks OK, then you might just need to rebuild your initramfs:

sudo mkinitcpio -p linux42

This should also be helpful:

Did you have your swap partition active when you installed the system?
Calamares should have amended that line on in /etc/default/grub on the installed system after it was copied over.

Here is what that line looks like on my system:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash resume=UUID=9807354a-9d27-4b00-8bca-b9e12d03557b"

Since it doesn’t seem to have seen your swap partition on install, you’ll need to find the UUID of your swap partition, edit that line yourself, and then run update-grub.


because of my multiple bootsystem i installed Netrunner via thus (calamares doesnt work for me) and no bootlader. thus will install grub into the mbr and not in system bootlader from acronis however is configured to install grub in partition.

so i installed grub in sdaxx partition,later. this install make no sense about swap and this was the error.

i put my swap partition in /etc/default/grub and now all works fine.

GRUB_DISTRIBUTOR=“Netrunner Rolling”
GRUB_CMDLINE_LINUX_DEFAULT=“resume=UUID=3f0beacc-9e4b-427e-a66b-e5333bf32924 quiet splash”

If you want to enable the save default function, uncomment the following

line, and set GRUB_DEFAULT to saved.


Preload both GPT and MBR modules so that they are not missed

GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

Uncomment to enable Hidden Menu, and optionally hide the timeout count



Well, now that makes sense.
I’m glad you were able to fix the issue. :wink: