Firefox auto startup

Simple question, when the desktop is loaded Firefox runs automaticly how to disable this or prevent this.

System Settings > Startup And Shutdown > Autostart

This may have worked for the OP, but it did not for me. I had to uninstall Firefox and rename .mozilla/firefox before reinstalling to make it go away.
I suspect I caused the problem by returning to a running Firefox while a post OS install update was in progress. My Firefox session vanished, and it was only after a reboot that I became aware of a phantom Firefox as well as the one I started, and a warning telling me I needed to shut a running Firefox down before starting another one.

Only that didn’t work either next time I logged on. More tomorrow.

The original poster was referring to the preloading script in the Autostart dialog here:
[attachment=552]

Surely one would have to put Firefox in there in the first place, and so know about it. Or can it creep in by stealth?

Look at the picture I posted, the preloading script loads up Firefox minimized on startup, this script is installed and enabled in Netrunner by default.

Ah, thanks, I had not realised that script affected Firefox. It looks like it does a pre-load without an actual instance. But for me it caused problems, fixed by disabling the script. In case anyone else has similar problems, here is my set-up and experience:

I have two installs, an old 32 bit updated to 14 via script, and a freshly installed 64 bit 14 on another drive.

The old one does not have the preloading script, and with session management set to restore previous session everything comes up as it should.

The new install does have the preloading script, and if it is enabled strange things happen (again set to restore previous session):

  • If I have a Firefox window up when I closed, on restarting I get

        "Close Firefox 
    

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

This appears over the restored window.

  • I then restart after a session that had two Firefox windows going, and I just get the message.
    I then manually start Firefox and get the home page.

  • If I again set up two Firefox windows and restart, I have one of two results:

    a) The “Close Firefox” appears briefly and vanishes,
    the second Firefox comes up
    The first Firefox window also comes up, but with no taskbar icon.
    System Monitor shows 2 Firefox instances, one with no icon.

    b) The “Close Firefox” message, hit “OK” on the message.
    System Monitor shows icon-less FF. No active instance.
    Manual Firefox gives home page.

After disabling the script, the first restart after a session with two Firefox windows wants to restore three windows, one being the restore itself. But after that it settles down and behaves.

I found that the re-installed Firefox had a much more comprehensive set of plugins than the original installed version.