Firefox issue

Hi, When I open an external link it opens a new window instead of a new tab. I never had this issue before even with this Firefox 30 version in other distros. I have set it up as usual and don’t find what’s different here. I don’t like having more than one instance open. How to change this behavior? Thanks.

I just checked on my test system & external links from Octopi, Manjaro System Manager & KDE System Settings all open in a new tab within the already open firefox.

Try removing firefox-kde & netrunnerarch-firefox-profile and re-installing them.

sudo pacman -Rn firefox-kde netrunnerarch-firefox-profile


sudo pacman -S firefox-kde netrunnerarch-firefox-profile --force

No luck. It doesn’t work. And it seems it doesn’t keep the last session either. I cannot restore it.

Same with my system since I installed it. I thought that was the default setting for some reason. Links from Skype conversations don’t open at all.

Try deleteing your ~.mozilla file or mv it to ~.mozilla.old this may not work but it worth a try.

The nearly same problem here. If I will open a link from Thunderbird for example Firefox will not open. I have check my system preferences and there is Firefox set as standard and is also set to catch clicks from http and https.

Now I have also the Maxthon Browser running at my system. If I click at a link from Thunderbird, Maxthon will open up and show me the site. :huh:

@ playforvoices
That’s because you have Maxthon set as default… Also make sure you have run all Upgrades/Dowwngrades and removed all of nepomuk, etc…

sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S manjaro-keyring
sudo pacman -Suu
sudo pacman -Rs nepomuk nepomuk-widgets virtuoso soprano

Thanks for the answer. But I haven’t set Maxthon as default. I have take a look at the settings inside of Maxthon and they show me that Maxthon isn’t set as default browser because its Firefox! :s I have execute the commands you have suggested to me. All done! But Firefox isn’t working as default for clicking external links.

Have you looked in System Settings > Default Applications > Web Browser

Yes, there is Firefox the default browser. I have set it again to Firefox but nothing changed. All external links will open with Maxthon.

What is the output of this: xdg-mime query default text/html
If it outputs: maxthon.desktop
then set the mime type to firefox: xdg-mime default firefox.desktop text/html

You can also go into System Settings > File Associations
scroll down to txt and expand it, click on html and make sure firefox is at the top of the list.

Tried this once again, just in case:

[Quote]Try removing firefox-kde & netrunnerarch-firefox-profile and re-installing them.

sudo pacman -Rn firefox-kde netrunnerarch-firefox-profile


sudo pacman -S firefox-kde netrunnerarch-firefox-profile --force[/Quote]

And got this:

sudo pacman -Rn firefox-kde netrunnerarch-firefox-profile
error: target not found: netrunnerarch-firefox-profile

Checked the installed packages (with octopi) and I don’t have it installed either. It seems it’s not in blueshell at this point.

“error: target not found: netrunnerarch-firefox-profile”

This just means you don’t have it installed.

Go ahead and run: sudo pacman -S firefox-kde netrunnerarch-firefox-profile --force

I just checked and it’s still in the repository.

Ok, thanks. It’s installed now. But again no luck with session restore.

session restore is fixed by removing or disableing from System Settings > Start Up Shut Down > Autostart.

I have set all as you mentioned here. But nothing has chanced. If I remove the Maxthon; Firefox will not startup if I click on a external link.

Edit .kde4/share/config/kdeglobals: kate .kde4/share/config/kdeglobals
scroll down to [General] and change this line: BrowserApplication[$e]=!maxthon.desktop to read: BrowserApplication[$e]=!firefox

If this doesn’t work then Maxthon must have changed something, somewhere that i’m not aware of.

Nothing changed with that. The problem was already there BEFORE I install the Maxthon browser. With the installation of the Maxthon browser I was able to open external links. :huh:

Try this open and edit this hidden file ~/.local/share/applications/mimeapps.list
here is mine:

[code][Added Associations]

[Default Applications]

Here comes my list, currently unchanged:

[code] [Added Associations]

[Default Applications]