firefox on startup

I don’t like any start of applications on boot time. Including firefox. Because the home page of the browser is the router login window where I can control my internet connection. I am not amused about the fact if the package ‘netrunner-default-settings’ will be updated my configuarion is lost.
This is what I have done.

# nano /usr/share/netrunner-default-settings/

Changing the line

  kstart --skiptaskbar --window "(.*)Firefox(.*)" ksystraycmd --window "(.*)Firefox(.*)" --hidden firefox &


  #kstart --skiptaskbar --window "(.*)Firefox(.*)" ksystraycmd --window "(.*)Firefox(.*)" --hidden firefox &

So firefox is disabled for systray including the automatic upstart in background. This is what I want. This feature is unusuable because the main window is in background and a subwindow appears asking for login.

Is there any other way to do this? Because every update of the package ‘netrunner-default-settings’ renews the file.

Remove preloading from your autostart configuration in systemsettings.

Okay. Systemsettings, Starting&Closing, Autostart, “Preloading” deselected.
Creating a new preload option. Going to /usr/share/netrunner-default-settings/ and copying to This is a new script, with other initials which you can edit. For calling this you have to dive into /usr/share/netrunner-default-settings/kde4-profile/default/Autostart/ and copying preload.desktop to preload-firefox.desktop . This you can edit by own wishes especially the correct script as above. After that copying preload-firefox.desktop to /user/.kde/Autostart/ selecting it in Systemsettings, Starting&Closing, Autostart. Works fine.
Editing and copying it is easy to do with mc in terminal with administrator rights.

I would like to point out another annoyance on this preload script “netrunner-default-settings”.
I do use Firefox and also take advantage of the possibility to create & manage different profiles. It was impossible to launch the Firefox profile manager, before I disabled that script… and it was not easy to understand that there was a script preventing the profile manager to start. When I typed firefox -P in terminal, the output was an error about locale and the default Firefox profile was launched.
My question is, does anybody know what’s the use of this script? Is it safe to disable it permanently?