First attempt with rolling.

For a daily use i work with netrunner 14 LTS.

I installed Netrunner rolling 15.09 on a dedicated partition of my laptop.
The installation ran perfectly, and i think that Calamares is better than the ubuntu installer.
Update process after installation was rather long (as compared to the LTS behaviour).
The boot process is also long, and i observed a delay in the display of boot screen as well as plasma (from 0.5 s to a few seconds) with sometimes unstability of the screen. I was obliged to reboot once time to stabilized plasma. The menu when open the first time also exhibit a very small delay (it appeared after dispalying a grid) same for the sub-menu. The following session are perfect. Applications do not exhibit this behaviour (Firefox, Thunderbird, libreofiice, vlc, kdenlive, system configuration)
Once plasma is open all seem ok and work as expected.
Of course netrunner LTS on this laptop is a very stable and confortable system.
I hope this could help.
Serge Moreau

Thanks, this is greatly appreciated.

Mooving nouveau driver to nvidia 340, largely improve graphical issues.


I want a solid rolling release so bad!

I tried and quickly gave up on Manjero last summer, even if it hadn’t self-destructed twice when the screen blanker kicked it (the second time I’d disabled it, but it re-enabled itself and broke again on the next update cycle) the constant password nagging was giving me carpal tunnel. The 14.xx Netrunner got off to a decent start but eventually some update went bad and it wouldn’t boot so I gave up and tried Ubuntu Mate 14.04, which was ok, but had many annoying issues, the worst was after a reboot Caja was in an infinite loop of launching processes making the system useless until I manually opened a termanal and did a killall command.

So now I’m trying Netrunner again and so far its been pretty good, on two systems: an i5 laptop with NVidia graphics and a quad core AMD with Nvidia graphics. I too had to move from the Nouveau driver to Nvidia 340 on the laptop and thus went straight for the non-free install on the quad core.

I’m not a fan of KDE/plasma so far. I had the problem with installed software not populating the menu, but the update and cp -r …/…/etc/skel/. . as found on the forum here seems to have fixed things. My main issus is things seem to appear and disappear – for example the opposite-click on the desltop popup menu Desktop Settings entry has come and gone multiple times, the virtual desktop pager has disappeared a few time too :frowning:

The save session on logout seems much inferior to what I’ve been used to with Ubuntu 10.04 (still my main system, but its been a fight to get some needed updated software to compile and install (QT5 and Android Studio in particular).

I really liked that the Java SDK was current enough to allow Android Studio to install without hassle.

I don’t like that Kodi has crashed the system several times – connecting to a UPNP server on the quad core and trying to play a DVD disk on the laptop. Maybe the 15.2 update will be the cure, but so far “it crahses if I do that – so don’t do that!” has made it usable.

Does Muon Discover actually do anything? Seems to be nothing but GUI with no actual function.

I also like that the auto login option now works, although it failed once and needed a password on a laptop restart, but has been fine since I re-enabled it.

I understand things can change or break with a rolling release, but if it doesn’t make what I need unusable for too long or happen too often, it’ll be worth it to finally get off the installation treadmill.

The compositor in plasma 5 in conjunction with mesa seems to cause most of the issues with the desktop, virtual work spaces, etc. disappearing, you can play with the settings a bit and get it stable enough. However, in the end I just disabled it on my system. I’ve not tried Kodi yet, I did play with xbmc back in the day but never really got into using it on a daily basis. Have you tried playing with plasma Media Center yet?

Next you need to install the 2015.09 ISO, just copy …/etc/skel/.config/menus to your home directory after your first update, this way you won’t loose any of your personal customization. :wink:

Muon Discover under Arch is still currently under heavy development, and some features are planed for improved usability. This is why we also included Octopi on the ISO and installed system. However, Muon update manager is very good for managing the updates from the official repositories.

I think my crashing was that the fan on my GPU had died. I replaced it and so far so good.

But KDE just drives me nuts. Seems that almost every default action is not what I want to happen. This is the third or fourth time I’ve tried it, still think its more trouble than its worth. Don’t know if its version5 or Netrunner that fixed it but at least the single click behaviour much more reasonable than with past attempts, so I’ve lasted with it longer than the other attempts.

I didn’t have any customizations to worry about so overwriting all the config stuff caused no harm.

I don’t see any usability in Muon Discover at the moment, it seems just an empty shell of a application installation browser GUI – remanesent of Ubuntu Software Center which was crap. Octopi seems usable as a replacement for Synaptic and so far has worked well. The Muon Updater seems solid and I like that it doesn’t nag me for a password.

Any tips on how to switch Netrunner to Mate? I’ll play with this for a while longer, but KDE/Plasma doesn’t seem to be growing on me. Which is more “mature” Mate-Destop or Mate-Desktop-gtk3?

I’d appreciate some guidance on what you did with Plasma5/Mesa, maybe it’ll help tame things for me.

OK, well for the most part I disable the compositor, I don’t need or like effects and since I do a lot of compiling Packages and ISO’s, I need as many resources available for that as I can get.

However, these settings gave me the best results when it was active:
animation speed 0 -3 no higher.
scale method: smooth
Rendering backend: opengl 2.x or lower if available.
Opengl interface: Either works good for me, EGL is lighter than GLX
Vsync: automatic
The rest I leave alone (default)

If i understand your discussion, there is a lot of improvement to bring to plasma 5 in order to reach the efficiency of kde 4.14.2.
I hope that Netrunner will maintained Netrunner 14.2 as long as possible. The numerous friends of mine using it will not clearly understand that a new version will not improve things.