gui problems [SOLVED]

Yesterday I heeded a software update notification. It failed with the following message:

/var/cache/apt/archives/kdepim-runtime_4%3a4.11.0-0ubuntu1~ubuntu12.10~ppa1_amd64.deb trying to overwrite '/usr/lib/kde4/akonadi_serializer_socialnotification.so', which is also in package libkfacebook1 0.1-201210231322-3~211~quantal1

I shutdown then and powered up today.

After powering up, the system gives a wide range of gui problems. Windows lack the title bar and resize buttons; windows can’t be resized by grabbing a corner or edge with the mouse; all windows open in the upper left corner of my workspace, overlapping my system panel; alt-tab doesn’t call up the window switcher; my custom hotkeys for moving windows don’t work; clicking on Firefox’s main menubar, or using the alt- hotkeys to open Firefox’s menus don’t work; windows only get focus if the cursor is over them. Among other problems.

I tried to resolve it by restarting x server (no luck) and restarting the system (also no luck). I also tried running software update again and got the same failure notification shown above.

From “My Computer”
OS: Linux 3.5.0-37-generic x86_64
System: Netrunner 12.12
KDE: 4.11.00

The installation simply was not complete and so the window manager and other stuff was not properly installed/upgraded to 4.11.
What you could do is open up a terminal (or go to a tty by pressing CTRL+ALT+F1) and type in

sudo dpkg --force-overwrite -i /var/cache/apt/archives/kdepim-runtime_4%3a4.11.0-0ubuntu1~ubuntu12.10~ppa1_amd64.deb

This should force installing the package. After that try to reconfigure all other packages and install all updates.

sudo dpkg --configure -a
sudo apt-get install -f

I hope this will help

Thanks, It helped me too

I’m glad it helped Slimy. It didn’t help me, though. The gui problems remain, even after restarting both x server and the system.

I don’t know if this is related, but after following leszek’s directions, when I run Muon Update Manager, I receive a notification of an available update for qtcurve. Marking it for update pops up a window saying installing qtcurve-l10n and removing qtcurve-i18n are required. But when qtcurve is marked for update, “Install Updates” is grayed out.

Let me know if there’s any more information I could provide that would help you diagnose the problem.

What about running

sudo apt-get dist-upgrade

In a terminal?

leszek, that didn’t work.

Would it be wise to upgrade to 12.12.1, or install 13.06?

I thought you are running 13.06?

Hi

you might want to look at update problems first before taking on 13.06

Just something to think about

Zeb

I’m still running 12.12. I never got around to updating to 12.12.1 or installing 13.06.

I’m running 12.12 32-bit with almost the same issue as raymund - except my system fails immediately after the login screen and returns to the login screen. I’ve applied the above commands (with the i386 deb) in recovery mode and rechecked with apt-get dist-upgrade which reports the system as updated after applying the latest update. But netrunner remains dead.

make sure to have the following packages installed.

Thanks, leszek. kdm and kde-window-manager were missing. Things are running fine now. I’ll mark the thread solved.