How To Stop Firefox Opening External Links in New Window in Current Workspace?

External links are opening in Firefox in a way I’ve seen in no other KDE system.

When Firefox is open in one workspace, and I click on a link in an app in another workspace, a new Firefox window opens in the second workspace.

What I need to happen is that the link is opened in a new tab in the existing Firefox window in the other workspace, and that the Firefox window does not move to my current workspace.

This is very often default behavior in non-KDE systems. In Kubuntu and other KDE’s, I need to set “browser.tabs.loadDivertedInBackground” to True to get the desired behavior. That doesn’t work in Netrunner 14.

I’m guessing Firefox has been deliberately configured this way. How can I get it to behave as I wish? It’s close to being a deakbreaker for me.

Disable preloading for Firefox in systemsettings startup and try again.