Installation failed

Just grabbed the new 2015.09 ISO and the LiveDVD boots OK (non-free drivers) but I’m having problems installing to my HDD. See the attached screenshot for what happened:

Just tried this again but this time with the nouveau drivers and it’s installed OK :smiley:

That looks like the umount command couldn’t unmount the rolling-image file because it was busy.
Did you get this same error on more than one attempt booted using the non-free option?
If so I need to know so I can report the issue upstream.

Sorry but I only tried the non-free option once.

The reason I asked is that line in the file it referenced was one of the last minute changes made upstream. I’m just trying to ascertain if it’s a bug in Calamares itself, the way we load the nvidia driver keeping it from unmounting, or if during your live session the location where Calamares mounts the rolling-image file was being accessed externally by anther application (dolphin, kate, etc.). In other words, is this error reproducible?

OK, I’ll see if I can reproduce it but I haven’t time today, sorry.

Cool, If I had a system with a Nvidia or ATI card that can use the proprietary drivers I could try, but I don’t. The only nvidia system I have isn’t supported by any of the three nvidia drivers, way too old (GeForce4 go 440). :frowning:

Hmm… I thought that umount -l will always work hence the lazy umount will not check if it can unmount or not.
Though that looks very strange.

You are correct, lazy should in theory always work, and defer the umount operation to a later time if it cannot do it immediately, that’s why this is very suspicious.
If this issue can be reproduced consistently, it warrants further investigation. In order to learn if the device is indeed busy, and what’s making it busy, try to reproduce the issue, and when umount -l fails, try

# fuser -amvu path/to/device/that/fails/to/umount

If the output is not empty, it should spit out the PID of whatever process(es) still keeping handles on that device.

I am getting the same error when doing an install after having selected Netrunner rolling option when booting. If I select the "non-free’ option the installation went without a hitch. Every time I tried the other option it failed.

I am not using NVidia - I am using AMD / Radeon.

Happy to be onboard with Netrunner.


OK, I’ve finally found the time to see if I can reproduce the error but so far, I’ve been unable to reproduce it.

However, I have a few observations to make:

  • After selecting “Start (non-free drivers)” and eventually getting to the desktop, I noticed there were no icons on the desktop. That’s not a big deal really because I know where to find the “Install” option but for a new user, it might be an issue. The reason why there are no icons on the desktop is because the desktop is in “Desktop View” whereas it would be better if it were in “Folder View”.
  • The native resolution of my monitor(s) is 1440x900 but it wasn’t set to that, it was set to 1024x768 but that’s no big deal either but I thought I would just mention it.

Here’s what I’m seeing after doing the install and rebooting the PC:

  • The password prompt won’t accept input from the keyboard unless I click my mouse inside the password field
  • It takes a looooooooong time to get to the desktop
  • I have a dual monitor setup and the secondary monitor looks OK but the primary monitor doesn’t. The best way I can describe it is that the desktop occupies the full height of the screen but only three-quarters of the width.
  • After doing a “sudo nvidia-settings”, configuring everything and saving the config to “/etc/X11/mhwd.d/nvidia.conf” and then re-booting the PC, it made no difference!!??
  • The entire system is slow and unresponsive, in fact, it’s so unresponsive, it’s unusable

Please consider all the above comments as being constructive.

First of all, welcome to Netrunner :smiley:

A few days ago, I reported that the installation failed when selecting “Start (non-free drivers)” and that it installed OK when selecting “Start Netrunner Rolling”, which is the opposite of what you’ve reported.

Since then, you may have seen that I’ve managed to install when selecting “Start (non-free drivers)” but the install is unusable.

As a final test, I’ve tried yet another “Start Netrunner Rolling” install and guess what, that install failed!!??
This is getting crazy, see attached screenshot …

Don’t take this the wrong way guy’s, i’m just trying to figure out what’s going on.
There are just a few questions I need to ask.

1: Does your ISO match the md5sum?

2: What kind of media are you burning the ISO image to (DVD, USB Stick, etc.)?

3:What application are you using to burn the ISO?
Note: These are hybrid ISO’s and as such, unetbootin and similar utilities that extract the ISO to another files system are NOT recommended, this method will produce irregular results.

4: Are these issues occurring on a UEFI or BIOS based system?

5: Was the system connected to the internet before running Calamares?

6: When the error occurs, can someone please run fuser -amvu path/to/device/that/fails/to/umount and post the results as Teo requested?

The reason I ask is I’ve installed this on 3 different systems and in Virtual Box and have yet to reproduce these issues.

Here’s the info you asked for …

1: Yes
2: DVD
3: K3b
5: Yes
6: I’ll post this the next time the error occurs

Another strange thing is that during the boot process, my primary monitor’s Auto Config kicks in, which shouldn’t be happening. The only time I’ve ever seen this happen before is when I’ve pressed the Auto button on the front of the monitor.

That is strange indeed. I’ll look at the configs, but I don’t remember anything in there that would cause this.

Oddly enough, this also happens with Manjaro and it kicks in just before the login screen appears.

Something else I’ve just discovered is that the refresh rates in /etc/X11/mhwd.d/nvidia.conf are completely incorrect:

HorizSync 28.0 - 33.0 (should be 30.0 - 81.0)
VertRefresh 43.0 - 72.0 (should be 55.0 - 76.0)

This would probably account for the desktop only occupying three-quarters of the width of the screen.

Since MHWD and/or the NVIDIA proprietary driver creates that file, that would be an upstream issue.

After doing yet another fresh clean install, doing a system update and rebooting the PC, I’ve partially solved the problem.
The first thing I did was this:

sudo nvidia-settings

Made all the necessary changes and clicked the Apply button but nothing changed. Despite that, I saved the new nvidia.conf file and then had a look at it. Here it is:

[code]# nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 355.11 (buildmeister@swio-display-x86-rhel47-07) Wed Aug 26 17:14:39 PDT 2015

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”

Section “Monitor”
# HorizSync source: edid, VertRefresh source: edid
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Acer P193W”
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 75.0
Option “DPMS”

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GT 610”

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “CRT-0”
Option “metamodes” “DVI-I-0: 1440x900_60 +0+0, VGA-0: 1440x900_75 +0+0”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
SubSection “Display”
Depth 24

Note the refresh rates.
Although they’re not exactly what they should be, they’re near enough.

Rebooted the PC again but nothing had changed.
As a last resort, I went into System Settings -> Display and Monitor just to see what the settings were in there. I couldn’t see anything wrong there but I noticed that when I looked at the settings for the secondary monitor, the Apply button was active, so I clicked on it and, would you believe, the primary display changed to the correct resolution/refresh rate.

After doing several reboots, the monitor Auto Config still kicks in just before the login screen appears and the primary monitor is still a mess throughout the boot process but when I finally get to the desktop, everything is as it should be.

So, after something like ten days of messing around, I finally have a usable installation but it looks to me as though something is broken somewhere.