Installer Issues

I installed yesterday Netrunner Rolling on my old Asus Notebook. The installer isn’t able to create a seperate home and installed grub always in mbr and not in partition! Please!

But not accept is, that i must take my Fn key to write P,O, I, U or L … and so on :frowning:

I have any keyboard layout tested, but nothing helps???

bad english i know, but please help me.


Hi, please help me understand the issues you are experiencing.

Which partitioning action did you choose? Manual partitioning, erase disk, resize or replace? Did you select your system partition as target for GRUB installation? Have you received any kind of error message? What was the outcome of your installation?

If I understand correctly you are also experiencing a separate and unrelated issue with keyboard layouts, is this correct? Which keyboard layout did you choose? What happened exactly?

I installed on Partition which is formatted by the installer. No kind of error message. I installed since 2006 Linux. On the HDD are 3 Linux-installation and GRUB was always installed in mbr by another Linux. But there is no way to do anything in the installer.

I have any other keyboard layout tested, but nothing goes.

Netrunner rolling is based on Manjaro/Arch, due to it’s early intel microcode loading will not boot from a grub installation from another system. I’m not going to remove the early Intel microcode loading, otherwise we could have issues booting newer Intel CPU’s.


I’m not sure how you actually did the partitioning or what your exact problem is but every time I’ve used Calamares to do the partitioning, there’s always been a choice of where to install the bootloader. If you look at the bottom left-hand side of the partitioner, you should see a long pull-down menu which, when you click on it, it lists various options such as “System Partition(/)”, “MBR” etc. etc.

As for the keyboard issue it sounds to me like you have num pad activated on your laptop keyboard. Try deactivating it and it should be good to go again.
Check kde systemsettings and input settings there to disable num key on login.

For partitioning in the installer you need to go to manual partitioning to set the mount point of a partition. There you are also able to set a partition as /home partition.
It should give you also a dropdownbox were you can choose the target of the bootloader installation.

Yep as leszek says this is the way I did it also as have a regular mbr and EasyBCD boot menu to boot between windows and linux on 1st disk mbr. And have the installer install grub on sda5 and have my separate home on sda6

Unless something drastically has changed in the installer?

Orbmiser, Netrunner Rolling 2015.06 rc1 is using calamares.
Have you installed and tried out the rc1 yet?
The previous ISO releases before I took over as maintainer used thus as the installer.

PitTux, as has been mentioned already, in calamares only by using manual partitioning is one able to put grub in a different place than the mbr of the first hard drive, the other options are for less experienced users.

Hi All; This isn’t exactly a reply, but more of a question.
I have just installed Netrunner Rolling 15.09, as I tried a live USB copy and was really impressed. The OS recognizes all hardware instantly and is very snappy. Bottom line, “It looked good!”
My question is about the installer… I have my Home directory on a separate drive, but was not (that I could see), offered an option to install Home on a separate drive. Now my entire installation is on an 80GB drive, with a 1.5TB drive sitting separately.
I do not mind reinstalling, is there an option that I didn’t see, that would allow me to install with the OS on the 80GB drive and Home on the 1.5TB drive? Thanks in advance guys. I’ll keep my fingers crossed. Cheers. Jim

You would need to use manual partitioning and select to mount but not format that partition, and also select the mount point.

Hi AJSlye; Thank you for your prompt and courtious reply. I did try the Manual Partitioning the last time, but did not see an option to choose another drive for Home. So I used the Replace OS option to install, hoping I would see the option there. (I didn’t) Calemares is new to me, as I am used to the likes of Linux Mint, Kubuntu and Netrunner 14. However, I can certainly have another look at the install and see If I can discover the option you speak of. Thanks again man… Cheers, Jim

Oh, maybe since it asks for the drive you wish to use before the first partitioning page comes up you can select more than one drive there. If not, then I think you just found an issue that needs to be addressed upstream.

Calamares will eventually become the installer for many distributions including, but not limited to, some of the ones you just mentioned.

Hi AJ; Thanks once again for replying so soon. I did not mention this earlier, because I didn’t want to add to the complication, however… The problem seems to be Calamares’ inability to fully recognize LVM at the time of installation.
To explain; My OS drive is an 80GB 10,000rpm high performance drive, formatted in EXT4. (Which I use for Just the OS. I mount this as root) ( / ). My Home drive is actually two 7200rpm physical drives formatted LVM2. They are a 500GB and a 1TB drive, which give me 1.5TB for my Home partition. Home is formatted EXT4.
This has not been an issue in previous installs, but Calamares sees them as two separate drives, a 500GB and a 1TB. From the live USB, or the istalled version, Netrunner sees the 1.5TB drive properly, but Home has installed on the 80GB OS drive.
Hoping this answers a question ortwo? Cheers old man. Jim

Yes, LVM is not currently supported by Calamares.
Outside of branding you should be able to use thus or the manjaro-livecd-cli-installer from the Manjaro repository to install the system. Upstream is curently working on luks support, lvm support may come later.

Hi AJSlye: I like what you say about using the Manjaro installer. How do I go about doing this? No rush, but when you have time I would be grateful if you could point me in the right direction, as it were. Thanks man, I appreciate your time and ideas. Cheers, Jim

Load the live ISO, connect to the internet, open up octopi or muon discover and search for thus, install thus.
ALT+F2 thus
or look for it in the menu.

Hi again AJ… Well, I loaded the live environment and installed “Thus” as per your advice. All went well and I was ready to give it a go. However when I attempted to run Thus, I reveived an error about a missing module “gi”. Please see copy/paste below.

[netrunner@netrunner ~]$ sudo thus
Traceback (most recent call last):
File “/usr/share/thus/thus/”, line 39, in
import gi/etc/
ImportError: No module named ‘gi’
[netrunner@netrunner ~]$

I’m not sure how to find the “gi” module, or if it is available separately. What are your thoughts on this?
Thanks again AJ. Cheers, Jim

Seems to be a dependency issue then thus should have installed it.
You most probably need to install the package python-gobject aswell as it inclides the gi module for python.

Yes, seems that the dependency list in the thus package must be broken, I’ll notify the Manjaro packager for thus.

Thanks for reporting this issue.

Hey guys, Thanks sincerely for looking into this. I really appreciate it. I’d really like to install the ‘Rolling Release’ of Netrunner, but of course I cannot until the installer issue is corrected. So thanks once again. I await good news.
Cheers, Jim