Iso Image dd written USB stick prompts to remove Audio driver

Hello

When inserting an USB stick that has an ISO image DD writen on it.

sudo dd if=~/Desktop/netrunner.iso of=/dev/sdb

It will prompt to remove your primary audio device.
Has anyone encountered this issue? And if so, is there a solution?

And yes I have tried to tick the remember box and answer no to removing it. But it still does the same thing.

vaikus84

That makes no sense, USB ports and drives have nothing to do with audio devices. The only thing I can think of is your having some sort of hardware issue.

This is a lshw output of my machine:

H/W path Device Class Description

                        system         Latitude E5430 non-vPro (Latitude E5430 non-vPro)

/0 bus 0J24KX
/0/0 memory 64KiB BIOS
/0/55 processor Intel® Core™ i5-3380M CPU @ 2.90GHz
/0/55/45 memory 512KiB L2 cache
/0/55/46 memory 128KiB L1 cache
/0/55/47 memory 3MiB L3 cache
/0/48 memory 16GiB System Memory
/0/48/0 memory 8GiB SODIMM DDR3 Synchronous 1600 MHz (0.6 ns)
/0/48/1 memory 8GiB SODIMM DDR3 Synchronous 1600 MHz (0.6 ns)
/0/100 bridge 3rd Gen Core processor DRAM Controller
/0/100/2 display 3rd Gen Core processor Graphics Controller
/0/100/14 bus 7 Series/C210 Series Chipset Family USB xHCI Host Controller
/0/100/16 communication 7 Series/C210 Series Chipset Family MEI Controller #1
/0/100/1a bus 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2
/0/100/1b multimedia 7 Series/C210 Series Chipset Family High Definition Audio Controller
/0/100/1c bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 1
/0/100/1c.1 bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 2
/0/100/1c.1/0 wlan0 network Centrino Ultimate-N 6300
/0/100/1c.2 bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 3
/0/100/1c.3 bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 4
/0/100/1c.5 bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 6
/0/100/1c.5/0 generic O2 Micro, Inc.
/0/100/1c.6 bridge 7 Series/C210 Series Chipset Family PCI Express Root Port 7
/0/100/1c.6/0 eth0 network NetXtreme BCM5761 Gigabit Ethernet PCIe
/0/100/1d bus 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1
/0/100/1f bridge HM77 Express Chipset LPC Controller
/0/100/1f.2 storage 7 Series Chipset Family 6-port SATA Controller [AHCI mode]
/0/100/1f.3 bus 7 Series/C210 Series Chipset Family SMBus Controller
/0/1 scsi0 storage
/0/1/0.0.0 /dev/sda disk 250GB Samsung SSD 840
/0/1/0.0.0/1 /dev/sda1 volume 28GiB EXT4 volume
/0/1/0.0.0/2 /dev/sda2 volume 204GiB Extended partition
/0/1/0.0.0/2/5 /dev/sda5 volume 189GiB Linux filesystem partition
/0/1/0.0.0/2/6 /dev/sda6 volume 15GiB Linux swap / Solaris partition
/0/2 scsi1 storage
/0/2/0.0.0 /dev/cdrom disk DVD±RW UJ8E1
/0/3 scsi6 storage
/0/3/0.0.0 /dev/sdb disk 1TB SCSI Disk
/0/3/0.0.0/1 /dev/sdb1 volume 931GiB Windows NTFS volume
/1 power DELL NY38W2C
/2 power To Be Filled By O.E.M.

Is some other command output more informative?
[hr]
To AJSlye:

Yes it has nothing to do with it. But yet it does mess with it.
I’m using 64 bit version of Netrunner 14 Kubuntu based.

Visually on the outside the headphone/microphone jack and the USB port I’m using are side by side. But I don’t believe that’s of any relevance?

If they are right next to each other there could be some kind of RF or electrical interference happening, this shouldn’t be the case if it was designed properly, However, I have a Acer netbook that the speakers are too close to the hard drive bay with no insulation (Design flaw), this caused the speakers to pull the heads of the drive and scratch the platters, I had to replace the hard drive with a SSD and add some insulating strips along the drive just to keep from having issues with that system.

The lesson here being never say never, and that defects do happen from time to time. I’m not saying this is the case, I’m just saying don’t rule it out.

Interesting observation to add.
If all other USB ports are in use and then I use the one besides the audio jack it does not conflict with the sound card.
Meaning it does not wan’t do discard the sound card as obsolete ( not needed anymore ).

Should mention that the USB port on the right side of this particular laptop is a so called powered one. Meaning it should let you charge a device when the laptop is sleeping.

With minimum RAM capacity of 3GB you can boot Netrunner 14 into RAM. Add option ‘toram’ to the linux kernel parameters and wait a litttle bit longer. After that the USB port is free and you can pull out the stick. And also the Netrunner live distro works faster and is upgradeable in RAM.

@Ready

vaikus84 never said that they were running from the live media, just that if they had inserted the USB stick with Manjaro ISO dd on to it into that port.

This sound card issue seems to still presist even after I did a complete reinstall from the torrent link ISO I downloaded from your site.

To be fair I added a variable to a config file. But I saw even when opening the config file the first time that a sound card warning came up!!

the variable is “tsched=0”

I added it to:
kdesudo kate /etc/pulse/default.pa

append “tsched=0” to the end:

load-module module-udev-detect tsched=0

I got this tweak here: http://forums.netrunner-os.com/showthread.php?tid=2424&pid=4586#pid4586
It is supposed to help with skype sound crackling.

NB. This warning did not come up with Linux Mint KDE 17 x64. Neither occasions brought it up!
Meaning not when editing the file nor when using the usb on the right side near the audio jack!

Found that this also occurs when opening kate text editor as root the first time.

kdesudo kate < command >

So it is related to the operating system rather than the hardware that’s in use.

After reading what tsched=0 does, using this does have the potential of causing the phonnon issue your having,

The problem with using interrupts on newer hardware is they are not designed to work that way, so the protections and older work around’s that used to be in the bios (like irq sharing, bus master mode, etc.) just are not there or even work the same as they used to. There may be other things causing your issue as well, but that one just stood out.

Will exclude this tsched=0 tweak. Hope Skype wont suffer.
[hr]
It still comes up. Even when not using the tsched=0 tweak.

I’ve never had an issue with Skye working on any of my machines, I’m running version 4.3.0.37-3 from the Manjaro repositories. What version of Skype do you have installed?

Also, I know that Skype version 4.3 for Linux now requires pulse, but I’ve never heard of needing to use tsched=0 before this, what issue causes you to need that line added?

The Skype version I’m using on 64bit Frontier Kubuntu version is 4.3.0.37.

I used this line because of the noise loop bug.

For the noise issue try opening skype like this instead of messing with your pulse setup:

PULSE_LATENCY_MSEC=30 skype

If this fixes the issue and works for you then edit the /usr/share/applications/skype.desktop file like this:

[Desktop Entry] Name=Skype Comment=Skype Internet Telephony Exec=PULSE_LATENCY_MSEC=30 skype %U Icon=skype.png Terminal=false Type=Application Encoding=UTF-8 Categories=Network;Application; MimeType=x-scheme-handler/skype; X-KDE-Protocols=skype

You are defiantly having a strange issue, I only had this happen long ago on KDE 4.3 but that was a bad Creative SoundBlaster card that was acting up.

What other changes have you made that has to do with pulse, phonon or drivers?

Used this command for now:
sudo sed -i ‘s/^Exec=.*/Exec=env PULSE_LATENCY_MSEC=60 skype %U/’ /usr/share/applications/skype.desktop

Hope this solves it with version 4.3

I find this interesting especially about the Ubuntu preinstalled part:
http://www.ubuntu.com/certification/hardware/201202-10548/

Just for the heck of it could you try the Netrunner Rolling Edition in live mode to see if this happens on that as well?

This is what it shows when I do something via root user:

[attachment=420]

Oh, your doing things as root, I must have missed that part.

Well, since on Ubuntu there technically isn’t a root account because it has been disabled by default, when your switching users using sudo, phonon seems to be seeing to the original Alsa driver arrangement and is trying to remove the what it thinks are erroneous devices but are actually what has already been reassigned by pulse in your user account.I’m not sure if I’m making sense to you or not, I also have no Idea why this is happening to you, there must be a permission issue on your system somewhere.

So from what I understand this is a normal phenomenon when using sudo and making little system changes?

I’m not really sure, it shouldn’t, but then again I have never disabled root on any of my systems. All I can do is recommend that since at this point your issue seems to be Ubuntu based, you might just need to wait for leszek’s help.

I apologize that I couldn’t have been more help myself.