Live media "no such file" error

I’m a big fan of NR-Rolling, but upon trying to install it on my new Dell desktop I encountered the following failure.

After selecting install and seeing the spinning circle for a bit, I got this error message:

starting version 227 cat: can't open '/proc/sys/dev/cdrom/info' : No Such file or directory cat: can't open '/proc/sys/dev/cdrom/info' : No Such file or directory

After seeing that for a few minutes, the screen went blank and the computer did not respond to keyboard inputs, so I switched it off. This happened several times, on both legacy BIOS and UEFI boot, and using both free and non-free drivers.

I thought I did everything right: I checked the MD5Sums, used Imagewriter (from my Netrunner Rolling laptop!), and turned off SecureBoot. I’m not a very technical user, so if you need more information to help me fix this, please include clear directions on where to find it. Thanks!

Was this with the latest 2015.11 ISO?
Try burning the ISO to the USB stick again using dd instead.

If that doesn’t help, then I’m thinking this might be a firmware issue.
Besides turning off secure boot, are there any other changes that you made to the UEFI/ BIOS.
Have you checked Dell’s web site for any updates to your Dell desktop’s firmware?

Could you list the exact model Dell desktop you have so I can check for issues?
Please include any differences, if any, your system may have from the base model.

Yes, the latest one. I just tried it using dd per your advice, but it turned out the same. (I’ve also tried different usb drives, so it’s not file corruption. I might add that I tried a Xubuntu 14.4.3 live usb, and it seemed to work just fine. Maybe that’ll give some clue about what might be missing.)

I have not made any changes to the firmware. I just opened it today (Christmas present!), and actually SecureBoot was already turned off by default. I doubt there are any updates to the firmware, as it is quite a new model–they haven’t put anything up on the web page for drivers or manuals yet! It’s this one: http://www.dell.com/us/business/p/optiplex-7040-micro-desktop/pd?oc=s012o7040mffus&model_id=optiplex-7040-micro-desktop. The BIOS revision number on mine is 1.1.1.

As far as I know it’s the base model. They only seem to sell one configuration.

I’ve booted that ISO at least 20 times or more on a few different system, so it can’t be the actual ISO.
There are also quite a few places online that refer to the same error message on many different distributions.
However, the more Arch/Manjaro related posts almost always end up being a firmware issue.
I will look into this more later tonight, right after the Dr. Who Christmas special.

PS. The thread title is a bit misleading since your issue has to do with the Live media booting and nothing to do with the installer (Calamares).

Haha, I will be watching as well. :slight_smile: Thanks, I appreciate it. I guess that’s what I get for buying an untried new model.

And fixed the thread title.

The latest bios version for the optiplex 7040 is 1.2.1.
http://downloads.dell.com/FOLDER03458438M/1/OptiPlex_7040_1.2.1.exe

Fixes:

  • Fixed some BIOS Attributes cannot be set remotely via Dell Command Suite.
  • Fixed system shows ‘Memory Change’ warning after entering BIOS Recovery via USB device.
  • Fixed M.2 NVMe SSD cannot be recognized by ePSA under UEFI mode.
  • Fixed popping error in ePSA: NVME PCI-express Hard drive test.
  • Fixed system cannot recognize NVMe Device with UEFI mode in ePSA.

Enhancement:

  • Supported Windows Update and added Enable UEFI Capsule Firmware Updates in BIOS Setup.
  • Supported TPM (Trusted platform module) 2.0.
  • Updated information of SSD/SSHD in BIOS Setup.
  • Updated CPU Microcode.

Drivers & Downloads page:
http://www.dell.com/support/home/us/en/19/product-support/product/optiplex-7040-desktop/drivers

The real question is why is it reading the USB media as a cdrom drive?

cat: can't open '/proc/sys/dev/cdrom/info' : No Such file or directory

This can be part of the problem, is there a setting to tell the UEFI/BIOS to boot the media as a USB hard drive and not a USB CDROM?

This also concerns me:
The front two USB ports are listed as - USB Charge port
One of the back USB ports is listed as - USB smart power on

Note: Keep in mind that the Xubuntu media is compatible with unetbootin and similar utilities, Netrunner Rolling (Manjaro) is NOT.
This can make for a big difference in the way these boot, they use a different format from each other.

OK, so I flashed the new BIOS, but it makes no difference to our problem, except now it repeats the “cat: can’t open” message 3 times instead of 2.

There’s only one option for usb boot, and it just says “usb storage.” I’ve not been using the power port (it lets me sleep and wake the computer from my wireless keyboard) or the charging ports to boot, if that helps.

From the documentation web pages you found for me, it also looks like Ubuntu 14.04 is a Dell supported OS for this particular box, so it’s not surprising Xubuntu worked. That being the case, if we really can’t find a fix I guess I could switch to Netrunner 17. :frowning:

Does this system have a dvd drive?
If not, then that could be the cause this issue.
Even an empty dvd drive would report something if the UEFI/BIOS reports that it exists.
On my system I get this:

$ cat /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:             sr0
drive speed:            24
drive # of slots:       1
Can close tray:         1
Can open tray:          1
Can lock tray:          1
Can change speed:       1
Can select disk:        0
Can read multisession:  1
Can read MCN:           1
Reports media changed:  1
Can play audio:         1
Can write CD-R:         1
Can write CD-RW:        1
Can read DVD:           1
Can write DVD-R:        1
Can write DVD-RAM:      1
Can read MRW:           1
Can write MRW:          1
Can write RAM:          1

You could try hooking up an external USB dvd drive and see what happens.

It doesn’t have a disk drive of any sort. Its only input is by its 6 USB 3.0 ports. But I don’t actually have an external DVD drive to test with, sorry (my main, 4-year-old laptop has a Blu-Ray drive so I don’t feel a need for any more of that particular fading technology . . .)

Does the live stick boot on the other system?
If so, then I’d say that even though there is no actual drive, the system is showing that one exists.
The only other thing that could cause this is if the system isn’t reading the stick properly, wrong device type.
If not, then you’re either not getting a proper burn of the ISO file, or the ISO is somehow corrupt.

It boots fine, except that at the end there is no desktop–just a black screen with a cursor. But I could bring up kRunner with the keyboard shortcut and from there launch the terminal (which I just used to run poweroff).

Curiouser and curiouser. How could the ISO file be corrupt if the md5 matched and I burned it with dd?

EDIT: I did download via torrent instead of directly like I usually do. Could this have affected anything?

It shouldn’t, but downloading direct couldn’t hurt.
I’ve also seen a few reports of dd not always writing properly as well while invastigating your error
You could also try the Manjaro tool isousb, I would try a new download first though.

If the other machine has a newer Intel GPU, you will need to add a kernel parameter at boot:
i915.preliminary_hw_support=1

Reference: https://wiki.archlinux.org/index.php/Intel_graphics#Configuration

That did the trick! The rest of the install went smoothly, it was pretty easy to add the instruction to the config file in nano, and after another reboot I have a fully-functioning desktop. (The only odd thing is that the clock is wrong, even though I selected my time zone in the GUI installer. No matter.) Thanks again for your help, and I will continue to be a Netrunner advocate. :slight_smile:

PS Since what I was doing was activating some sort of preliminary support, do I need to go back and remove that instruction once the system moves to a newer kernel version?

PPS I apparently spoke too soon, as I am now experiencing some very annoying graphics glitching. Is this due to the fix, or do I need to manually change the drivers?

Did you add i915.preliminary_hw_support=1 to the kernel parameter of etc/default/grub and re-install grub after install?
This would not have been automatically added to the installed system.

sudo nano /etc/default/grub
sudo update-grub

Could you also post a screen shot {prt sc} of the graphical glitches your getting?

PS. The rolling edition is based on Manjaro. In Manjaro your system will not upgrade to a newer kernel series, it will only update withing the same series. In other words, you will only receive updates from say 4.2.1 to 4.2.2 and so on, but never 4.2.x to 4.3.x, etc. You would need to make that change yourself using either the GUI tool (now available from within system settings) or from the command line with mhwd-kernel.
[attachment=825]
https://wiki.manjaro.org/index.php/Manjaro_Kernels

The same goes for graphics and some network drivers.
[attachment=826]
https://wiki.manjaro.org/index.php/Configure_Graphics_Cards

The full MHWD portion of the wiki:
https://wiki.manjaro.org/index.php?title=Manjaro_Hardware_Detection

Yes, I did it how it said on the Arch wiki under kernel parameters for GRUB. It didn’t say to run update-grub, but I ran this instead, which seemed to do the same thing, since it restarted fine afterward:

# grub-mkconfig -o /boot/grub/grub.cfg

The glitches go by too fast to screenshot, I think. It’s mostly tearing and ghosting along the top 1/6 or so of the screen. Flickery, makes your eyes twitch. But come to find out, I’m running kernel 42 and support for Skylake doesn’t really come until 43, so switching kernels is next on my to-do list (I’ve used the GUI for that and the drivers before, and the hardware detector isn’t showing any alternate video drivers to the one I’ve got–although it looks like there are no proprietary Linux drivers for Skylake yet, if I was looking at the right Intel download page just now!)

Intel doesn’t have proprietary drivers, they only have opensource drivers.
These drivers are already provided by the kernel, xorg, mesa, wayland, etc. packages.
Reference: https://01.org/linuxgraphics/community

The 4.2 kernel series is EOL (end of life) and only receiving security updates anyway.
Reference: https://www.kernel.org/

I’d recommend installing the 4.3 driver first, boot into it, and only remove the 4.2 kernel after your sure the 4.3 kernel works better on your setup. Please use the mhwd-kernel command line tool, or mhwd-kernel GUI in system settings for this procedure, these will automatically update the initramfs and grub for you.

After thinking about it, is the flickering happening after grub, but before Plymouth loads?