Lost KDE menu on taskbar (Solved)

While away on business, all of sudden (according to my wife), the KDE menu icon went missing replaced by another icon that looks a lot like the desktop widget which is to the right. See screenshot. Clicking the new icon gives:

Error loading Applet: package inexistent. Could not find requested component: org.kde.plasma.netrunnerkicker

I have since done the 2016-2-9 updates = no errors. And a reboot did not solve.


  • Bill

That looks like the back end is not loaded, have you tried removing the widget from the panel, logging out, then adding the widget back once you’ve logged back in?

I didn’t think of that. It worked and was very easy. Removed the “unknown” widget and added the “application launcher”.
I didn’t need to logout.


No problem, I had the same issue on my vanilla Arch install with the kickoff menu after the Plasma 5.5.4 update.

Note: The Netrunner application launcher should still be installed and available, however besides the launcher button being different, there is no real difference between it and the standard application launcher. This package was originally made as a workaround, prior to the Plasma team adding a way for distributions to change the default settings, and favourites to be used by the default launchers.

The taskbar icon is the same as before (which I removed the word RUN to make it smaller), but I did notice the icons look different inside the launcher itself (and I had to add suspend to the favorite bar). Screenshot FYI.
I didn’t see a “Netrunner application launcher” widget available.

Yea, suspend is not normally on the favourites bar by default.

What I meant by “Netrunner application launcher” is “Netrunner Menu” available from the widgets bar or alternatives menu, this is the same thing as “Application Menu” (kicker). We had made the Netrunner Menu originally because there was no way of changing the default settings or favourites applications on the side bar of the menus globally, now there is.