Muon Software Center - No updates

I don’t know why Muon software center is not receiving any software updates ? i receive security updates only.
Okay maybe my current applications do not have a newer version , but what about an application like firefox its still on version 21 . and i don’t know what should i do.

Did you perform a search in muon for firefox and looked at the versions available ?

yes and there is no update button its remove only and the description is about version 21

Hi dexter…try this… go to Muon Software Center and select Sources.

Verify if you have a duplicate source starting with “LP - http://ppa.launchpad.net/netrunner-os/enigma-1306/ubuntu”.

Delete one of them and you shoul get the information that are 3 updates… after that update you will get Firefox V.23.

It worked for me.

Regards

I have this , what should i do then ?

Hi dexter… try deleting the line “LP-PPA-netrunner-os…” selecting the recycle bin at the end of this line (probably you will be aked to enter your root password, do it, press ok and verify if this line is gone. Wait a moment and the button “Installed” should give the information that have updates to do. Just click on it and update. If everything works fine you should get Firefox version 23.

Good luck

Regards

I am trying to delete it but after typing my password nothing happen , also i tried the command which appears when i select the recycle bin , i typed it in the terminal i got this :

➜ ~ sudo apt-add-repository --remove -y http://ppa.launchpad.net/netrunner-os/enigma-1306/ubuntu [sudo] password for dexter: Traceback (most recent call last): File "/usr/lib/linuxmint/mintSources/mintSources.py", line 1206, in <module> add_ppa_via_cli(ppa_line, codename) File "/usr/lib/linuxmint/mintSources/mintSources.py", line 32, in add_ppa_via_cli user, sep, ppa_name = line.split(":")[1].partition("/") IndexError: list index out of range

then i opened Software sources there is nothing about this ppa in PPA’s section

and i have installed ppa-purge few days ago i tried it also but it didn’t work

➜ ~ sudo ppa-purge http://ppa.launchpad.net/netrunner-os/enigma-1306/ubuntu Updating packages lists PPA to be removed: http://ppa.launchpad.net/netrunner-os/enigma-1306/ubuntu ppa Warning: Could not find package list for PPA: http://ppa.launchpad.net/netrunner-os/enigma-1306/ubuntu ppa