Need instructions to boot back into desktop environment...

I somehow managed to disable my GUI. When I boot now, I start in a command line interface. From there I can execute StartX, but then I’m only presented with a few ugly windows. I’m guessing something is wrong with one of my config files or the nVidia graphics driver, etc. I’m not sure how it happened; I was not doing anything that should have disturbed anything like that in my prior desktop session.

Anyway, I know there are usually ways to repair damage and re-enable the GUI. If anyone could provide step by step instructions to follow from the CLI, I’d very much appreciate it. Thanks!

Try change the default boot environment in grub by selecting advanced. It sounds like you may have already did this once and changed the default.

Just tried that. I only see two options under Advanced in GRUB:

Netrunner kernel 4.4.3-1
Netrunner kernel 4.4.3-1 fallback initramfs

Not sure what the difference is. I tried each one, but they both go to the command line. Is there something else I need to do to change the default boot environment?

Thanks

Is there any way you can get a screen shot, or a video, of what your getting when you run startx?
This would help in determining what is going on.

Could you first make sure your system is up to date:

sudo pacman -Syyu

Yes, system is up to date.

I am attaching a couple of images I took of the screen. One shows the 3 windows I see after running startx. And then some of the error code I see after I exit the X window.

Thanks for any help!

Can you remove from the grub screen this:
acpi=off
and boot without it.
I mean, when GRUB appears, hit “e” - to edit, on the first line, find “acpi=off” and remove it. It should be …rw quiet splash resume=UUID=ab76af55-…
When you are finished, hit F10 to boot with the already modified line.

rw - means system will be mounted also writable
quiet - it will save you seeing the boot messages /these scary letters while booting :slight_smile: /
splash - word for plymouth
resume=UUID=… - the swap device

[quote]I am attaching a couple of images I took of the screen. One shows the 3 windows I see after running startx. And then some of the error code I see after I exit the X window.
[/quote]
startx obviously starts twm and not plasma.
What you could try instead is running xinit -e startkde to start plasma.

Thanks for the replies.

My motherboard (ASUS Rampage IV Extreme) seems to need the ‘acpi=off’ kernel parameter, otherwise Linux freezes randomly on me. I always add this to the GRUB boot line. I also add ‘libata.force=noncq’ because otherwise my SSD does not “play 100% nice” with Linux.

Thanks for the info.

‘xinit -e startkde’ works for me. However, once in the desktop GUI, my theme is gone and the mouse pointer does not respond. :frowning:

What is twm?

It seems there must be some file corruption on my Linux partition. I think I’ll need to do a reinstall…

I’m having the same problem. I logged in today and saw the update and ran it. On rebooting after installing the upgrade it’s asking for a text based login and password. I hit “e” to get to the grub file, but don’t have that acpi=off in the config. How do I get past the login to try your manual command to start plasma?

@Gumpy

It is a very basic window manager. See: https://en.wikipedia.org/wiki/Twm

Thats sounds pretty strange.

@Clyde

Did you try logging in there ?
If its a normal tty login you just need to enter your username hit enter and enter your password.
Password entering by default is hidden so no stars are shown. However after typing in the password and hitting enter it should log you in.

That isn’t there by default. Like Gumpy said he added it there for his machine.

Sound like grub and/or the initramfs didn’t get updated properly.
Log in as root and connect to the internet, if your using wifi use nmtui to connect to your router.
Once connected make sure you received all of the current updates:

sudo pacman -Syyu

then once your sure all of your packages are up to date run the following commands:

mkinitcpio -p linux<version> update-grub
Then reboot.

Note: sometime the local mirrors for your country could be out of date and/or still in the proccess of syncing when you run your update. This is rare, but does sometimes happen and cause issues like this. You can check you local mirrors for Manjaro here: http://repo.manjaro.org/

I did try user ID and password. It doesn’t seem to like it. i.e. I can’t login there. Yes, I know my ID and password - I login every day. Any other workarounds?

You need to log in as root not your user name:
user = root
psswrd = what ever you gave it in the installer, the options were to use the same password as the user (default) or to give root it’s own password (requires checking a box and entering a different password in the fields that appear)

Thanks. I got…

ERROR: Failed to load preset: `/etc/mkinitcpio/linux-4.2.8.4-1-MANJARO.preset’

The system was already up-to-date.

I found the “linux42.preset” and ran it with that. It ran just fine, but didn’t fix the problem. It still boots to the text login.

What did you type in?
It should be:

mkinitcpio -p linux41
mkinitcpio -p linux42
mkinitcpio -p linux44

This would depend on which kernel series you have installed.

Did you update-grub afterwords?

I typed:

mkinitcpio -p linux42

then

update-grub

Try running your updates again.
Log in as root and run:

pacman -Syyu

If you get any prompts about replacing or removing any packages, hit y and let it to what it need to do.

It’s still saying there is nothing to do. Can I force it to do something?

NO, just check the mirror list to see if the ones closest in your country are up-to-date
http://repo.manjaro.org/

I have seen where pacman gives that output but updating the mirror list first gives different results:

pacman -S pacman-mirrorlist
pacman-mirrors -g
pacman -Syyu

You could also try this:

pacman -S manjaro-system