Netflix video problems

Hi everyone, my first post on these forums. I’ve been using Netrunner for about a month.
I am not new to Linux, and boot to 3 different distros, so not new, but not a Linux expert.
I’ve been trying to get Netflix running without sucess, in Netrunner 13.06.
I get the moive selction screen fine, but when I select, a movie, it minimizes and I can hit F11 and get full scrren with sound, just no picture.
I have a Rampage Extreme IV MB, with an i7 3820 and a Nvidia 680GTX.
I wonder, if this is a video problem?
Any help, would be appreciated. I can watch in windeez, mostly, I just like to fix things, that don’t work.

We have a whole thread about netflix problems already. Did you try one of the suggestions there ?

Especially #14.

Thank you, very much.
#14 sounds like a likely canadite. I tried most of the others.
I had it working perfectly in Kubuntu 12.04, then , the updates to silverlight and wine and it stopped working.
I tried rolling back, the Nvidia Driver and, that didn’t help.
I did rename wine-browser in Netrunner and never did get it running, the video part, but #14. would be my best guess.
Thanks, again and if I get it working, I’ll post back.