Netrunner Rolling 2015-06-pre3 now online.

We are proud to present Netrunner Rolling 2015.06 (Pre-Release version 3) for testing.

With this release there has been many changes in where the Netrunner specific modifications are stored and how they are loaded, as well as how these changes are packaged. All wallpapers, icons themes, aurorae themes and desktop themes are now available as separate packages via the repositories. Wallpaper packages are listed according to which ISO they first became available.

Included on this ISO:
Linux Kernel 4.1.3
systemd 222
Plasma Desktop 5.3.2
Plasma Framework 5.12.0
KDE Applications 15.04.3
Samba pre-installed and configured for basic file sharing and access of windows shares.
A new set of 10 wallpapers added (the wallpapers from 2014.09 are also pre-installed on the ISO)
Ksuperkey now enabled out of the box.
The ability to add a default netrunner panel in addition to the Plasma default panel has been added.
gmusicbrowser replaced by gmusicbrowser-netrunner (modified version)
User-Manager added for quick creation and password management of user accounts.

Many other changes under the hood.

Warning: A complete re-install will be required.

I’ve been working hard at making sure that our packaging, and design of the new generation of rolling release ISO’s, won’t in any way effect the default settings, or any user modifications made to already installed systems from one snapshot release to another. However, we also felt that any new artwork, themes, sounds or cursors, etc. should also be made available to existing users. This is the main reason for the overhaul in our packaging, system design and repository. I do apologize for this inconvenience. It was necessary to achieve our goals with this release.

As always, do not install this ISO in a production environment or on a mission critical system, this early preview ISO is intended for testing and feedback purposes ONLY. During this phase of testing many changes can occur that could leave your system broken.

Please leave any feedback you have on this pre-release ISO here in this thread.


Nice work AJ.

I like the theming and icon choice.

First issue I noticed when logging in

Don’t know if it’s normal or if it could be easily fixed?

No, I had the wrong sddm.conf file in the netrunner-rolling-system-settings-2015.06 package, it should have been the same one I had in my manjaro-tools profiles live-overlay, but it wasn’t. I’ll update it in the repository shortly. There are a couple of other issues that I missed when I moved the files out of my overlays into packages, I’m tracking these down and fixing them now. They will be in the pre4 ISO and in the packages online, hopefully there will be no need to re-install this time. However a couple of these changes were in /etc/skel, so you may need to pull them into your home directory yourself after updating the netrunner-rolling-default-settings package.

UPDATE: I added the fixed packages to the repository.
You’ll need to update the netrunner-rolling-default-settings and netrunner-rolling-system-settings packages.

Then copy out of /etc/skel/.config/ kwinrc and plasma-org.kde.plasma.desktop-appletsrc to your {home}.config/ directory overwriting the existing files. Now just log out and back in for the new netrunner desktop default settings to take effect…

thx for the quickfix

No problem.

I tried to install but ran into problems after the partitioner section - format / copy / etc. … three attempts with three different neg results. It just flagged up and it halted. I am sorry I made no notes regarding the popups.

I installed Ozymandias instead with out a hitch.

I will try to Install the rolling when its officially released.

Yes, without the actual errors it’s hard to tell what the issue could be.
Did you use one of the auto partitioning modes or custom partitioning?

We are using Calamares as the installer for new Rolling ISO’s instead of thus, and even though we are using the latest releases of Calamares, it is still under heavy development and you may have just encountered a bug that we haven’t seen yet. If you can check their bug tracker to see if your issue has already been reported, or make a report yourself, it would be greatly beneficial and appreciated.

Quick question. I just installed this on my Stream 11, however is there a way to install the kernel headers during installation? The laptop has Broadcom BCM43142, so I need to install broadcom-wl, and because the kernel isn’t the modern manjaro kernel, I can’t download the headers from the manjaro mirrors anymore, which means I can’t build the broadcom-wl package, which means I can’t get online.

Any way to get those headers if I reinstalled? Or is there a mirror I CAN download them from? While not ideal, I’m perfectly fine with manually installing a few packages needed just to get network up and running (had to do the same when I had Debian on here, but the headers are included in installation media during a netinstall).

There is no need to compile it yourself unless you installed a different kernel than the one shipped.
We use the stock Manjaro kernels and that driver is available in the repository already.
Just open Manjaro Settings Manager > Hardware Detection and put a check in the first box next to network-broadcom-wl.
Alternatively, this can be also installed using the command line:

sudo pacman -S linux41-broadcom-wl

Doesn’t work for me. There are no checkboxes for network-broadcom-wl, and when I try to do sudo pacman -S linux41-broadcom-wl, I get error: target not found: linux41-broadcom-wl

However, since I know the package exists now, just downloaded manually from the mirror, put on a USB, and installed using pacman -U. Rebooting that machine now (yes, I know I could just modprobe) to test.

Doesn’t load. When attempting to load the module manually, modprobe: ERROR: could not insert 'wl': Invalid argument

Also, the linux41-broadcom-wl.conf file doesn’t seem to get read, as several of the modules that it blacklists were loaded…however even after rmmod-ing them, wl still doesn’t load.

After a SECOND reboot, the .conf file seems to be working, all the blacklisted drivers are being blacklisted properly now. Here’s a dmesg with the errors in case anyone has an idea, I’m nowhere near knowledgeable enough to know what to do from here however.

[ 80.858966] wl: disagrees about version of symbol skb_put [ 80.858975] wl: Unknown symbol skb_put (err -22) [ 80.859016] wl: disagrees about version of symbol cfg80211_scan_done [ 80.859019] wl: Unknown symbol cfg80211_scan_done (err -22) [ 80.859022] wl: disagrees about version of symbol consume_skb [ 80.859025] wl: Unknown symbol consume_skb (err -22) [ 80.859035] wl: disagrees about version of symbol unregister_netdev [ 80.859038] wl: Unknown symbol unregister_netdev (err -22) [ 80.859084] wl: disagrees about version of symbol cfg80211_disconnected [ 80.859086] wl: Unknown symbol cfg80211_disconnected (err -22) [ 80.859090] wl: disagrees about version of symbol ether_setup [ 80.859092] wl: Unknown symbol ether_setup (err -22) [ 80.859101] wl: disagrees about version of symbol eth_type_trans [ 80.859103] wl: Unknown symbol eth_type_trans (err -22) [ 80.859107] wl: disagrees about version of symbol alloc_netdev_mqs [ 80.859109] wl: Unknown symbol alloc_netdev_mqs (err -22) [ 80.859129] wl: disagrees about version of symbol wiphy_new_nm [ 80.859131] wl: Unknown symbol wiphy_new_nm (err -22) [ 80.859147] wl: disagrees about version of symbol cfg80211_inform_bss_width_frame [ 80.859149] wl: Unknown symbol cfg80211_inform_bss_width_frame (err -22) [ 80.859169] wl: disagrees about version of symbol wiphy_register [ 80.859172] wl: Unknown symbol wiphy_register (err -22) [ 80.859188] wl: disagrees about version of symbol cfg80211_put_bss [ 80.859190] wl: Unknown symbol cfg80211_put_bss (err -22) [ 80.859204] wl: disagrees about version of symbol cfg80211_roamed [ 80.859206] wl: Unknown symbol cfg80211_roamed (err -22) [ 80.859223] wl: disagrees about version of symbol cfg80211_inform_bss_width [ 80.859226] wl: Unknown symbol cfg80211_inform_bss_width (err -22) [ 80.859256] wl: disagrees about version of symbol cfg80211_ibss_joined [ 80.859258] wl: Unknown symbol cfg80211_ibss_joined (err -22) [ 80.859261] wl: disagrees about version of symbol skb_pull [ 80.859264] wl: Unknown symbol skb_pull (err -22) [ 80.859282] wl: disagrees about version of symbol cfg80211_michael_mic_failure [ 80.859284] wl: Unknown symbol cfg80211_michael_mic_failure (err -22) [ 80.859298] wl: disagrees about version of symbol cfg80211_connect_result [ 80.859300] wl: Unknown symbol cfg80211_connect_result (err -22) [ 80.859303] wl: disagrees about version of symbol skb_push [ 80.859305] wl: Unknown symbol skb_push (err -22) [ 80.859314] wl: disagrees about version of symbol register_netdev [ 80.859316] wl: Unknown symbol register_netdev (err -22) [ 80.859332] wl: disagrees about version of symbol wiphy_unregister [ 80.859334] wl: Unknown symbol wiphy_unregister (err -22) [ 80.859395] wl: disagrees about version of symbol cfg80211_get_bss [ 80.859398] wl: Unknown symbol cfg80211_get_bss (err -22) [ 80.859404] wl: disagrees about version of symbol netif_tx_wake_queue [ 80.859407] wl: Unknown symbol netif_tx_wake_queue (err -22) [ 80.859424] wl: disagrees about version of symbol __ieee80211_get_channel [ 80.859426] wl: Unknown symbol __ieee80211_get_channel (err -22) [ 80.859435] wl: disagrees about version of symbol netif_rx [ 80.859437] wl: Unknown symbol netif_rx (err -22) [ 80.859440] wl: disagrees about version of symbol __netdev_alloc_skb [ 80.859442] wl: Unknown symbol __netdev_alloc_skb (err -22) [ 80.859455] wl: disagrees about version of symbol __dev_kfree_skb_any [ 80.859457] wl: Unknown symbol __dev_kfree_skb_any (err -22) [ 80.859483] wl: disagrees about version of symbol skb_clone [ 80.859486] wl: Unknown symbol skb_clone (err -22) [ 80.859525] wl: disagrees about version of symbol wiphy_free [ 80.859527] wl: Unknown symbol wiphy_free (err -22)

Did some google-foo, and it seems those errors are the drivers are built for the wrong version of the kernel. Downloaded the latest kernel (and headers, just in case), threw on a USB, installed, rebooted, and now i’m cooking with gas… :smiley:

I’m glad to hear that you figured it out. :wink:

Yeah. I’ve had major issues with some distros installing on here (no legacy mode, uefi or nothing, which is why I couldn’t use the released rolling version). So far Debian, Mageia, and Netrunner are the only ones I’ve gotten to install. Obviously, the weakness of having a broadcom wifi and no ethernet makes setting up most a pain (surprisingly, Mageia has the wl driver in the live image, so it was super easy), and performance is…suspect even after getting it set up, but the laptop was $125 w/ a $40 gaming headset, so it’s fun to beat around and just test distro’s with.

I can’t find a working link for the pre-release anywhere. Any tips?

Yes, here you go:
Note that we decided to delay the release to next month due to many core apps like dolphin now being ported to kf5 and released this month.

Thanks for that. Good idea. I tried the rolling a while back, but the constant plasma crashes were annoying me, so I switched to Osmandias (which is awesome, by the way). I assume thy’ll be fixed for release…

Updates to the stable branch of Manjaro are now every Monday, unless there is a major issue in testing.
On the netrunner-rolling-2015.09-pre1-x86_64.iso, mhwd defaults to UXA acceleration for Intel drivers because of a flaw found in Mesa at that time, this has since been fixed and was released last Monday. So if you install the netrunner-rolling-2015.09-pre1-x86_64.iso and run the updater, you can edit the /etc/X11/mhwd.d/intel.conf file back to using the SNA acceleration method if you wish.

Section "Device"
	Identifier  "Device0"
	Driver      "intel"
	BusID       "PCI:0:2:0"
	Option      "AccelMethod" "sna"
	Option      "DRI"    "true"

NOTE: MHWD will be changed back to sna as default in one of the next update-pack.