Netrunner/Windows 8 Dual Install - 'grub-eti-amd-64-signed' package failed to install

Netrunner 14 Frontier edition was attempted to be installed as a dual boot next to Windows 8 on an HP Pavilion G6 (64bit) laptop during a Netrunner live session, and the graphical install proceeded without error until the completion of the install programme, which was immediately followed by an error message:

The ‘grub-eti-amd-64-signed’ package failed to install into /target/. Without the GRUB boot loader, the … system will not [boot?].

(I can’t read my own note properly!) The md5sum had computed fine. The laptop was not connected to the internet. The partition changes that were offered during the ‘guided’ choice of install, if I have recorded this correctly, showed that sda4 shrunk from 442.9gb when only Windows 8 was installed to 278.7gb with Netrunner; sda5 - ntfs - 471.9mb; sda6 - ntfs - 367mb; sda7 26.9gb (=root?), and the screen was perhaps just slightly cut off to the right of that.

Of note perhaps is the only error message that had appeared prior to launching the install program; it had appeared immediately after the live session of Netrunner had completed launching:

…‘desktop.preload’ or ‘preload.desktop … failed to launch’ (or so).

This message didn’t appear at any time during the two prior live sessions that I had conducted. These two live sessions were launched by installing the Netrunner .iso using the Universal USB Installer (UUI) instead of the installation software suggested in your installation webpage for Windows, Win32DiskImager, as it failed to ‘create’(?) a ‘label’ in my case and the install onto the pen drive couldn’t proceed from there. The two first live sessions were flawless until I couldn’t complete a download during the second session because, I suppose, the ‘persistent storage’ facility in UUI may have got full, if I understand this properly. I had had success with the UUI installer when launching those two live sessions of Netrunner, as well as Linux Mint, and success also with live sessions of other distros on my other PC when Unetbootin unfortunately didn’t display my pen drive as a drive option.

To start the third live session, the image was burned onto the pen drive for the second time using UUI again after doing a full (not quick) reformat of the pen drive. I suppose that the failure of Win32DiskImager to ‘create’(?) a ‘label’, as well as the ‘desktop.preload’ error and/or the GRUB error may have occurred due to the fact(s) that:-

(a) maybe I didn’t install (or later run) Win32DiskImager as an administrator, if that has any bearing; or

(b) if I remember correctly, I think that when installing or launching Win32DiskImager there were some error messages about not being able to copy some files or so; or

(c ) my USB ports are sometimes not working up scratch since my laptop was dropped and landed directly onto the plugged-in wireless mouse dongle; Windows 8 message often says: ‘USB device not recognized’ […] ‘Windows does not recognize it’ and some devices sometimes (but rather rarely) don’t get recognized on any of the other two USB ports when in Windows 8, although on the other hand, the USB port that got damaged can often read off my android phone using a USB lead, and pen drives (such as the one I used when installing Netrunner) as well as my wireless mouse with its dongle often appear to function sufficiently well.

When the GRUB error message above appeared, I attempted to shutdown/restart by clicking on the icons, but they didn’t respond - perhaps because Netrunner might be wisely programmed to not shut down when there is the prospect that “Without the GRUB boot loader, the … system will not [boot?]”, but I don’t know. Netrunner is an excellent experience anyway, having distro-hoped quite a bit until I got this Windows 8 laptop (vendors could make a mint by selling PCs that come packed with Linux instead and without some sort of so-called ‘secure boot’, I suppose), and so I look forward to using Netrunner!

I did not have an active internet connection at home at the time of this attempted install (only dialup, but this laptop does not have a dialup modem hardware), so I couldn’t bash an error message to your developers then, and I couldn’t consult with you or with the internet at the time to check how to proceed, so I powered down the laptop. I immediately powered up, but I can’t remember what happened next:-

  • It either booted into a blueish screen that offered the boot manager option or else it booted directly into a boot manager, but I think I had the UUI pen drive still connected, and I ended up in Netrunner’s usual live session’s boot(?) manager which offered to launch Netrunner or to ‘check for errors’, and this facility found 4 errors although no mention of any corrections completed. I rebooted and the same report (4 errors) was given again.

  • Before removing the pen drive, at some point, I tried to run the Netrunner installer wizard again (during a Netrunner session) to see if it could offer a repair or to make a successful single install of Netrunner. It looked at a quick glance to show the partition changes that seemed to have been offered at the first attempted install (see values above). The install wizard, this second time, understandably, offered further changes to the partition, as if to install a second instance of Netrunner, but I cancelled out of this.

  • Otherwise, it booted successfully into Windows 8 (this could have been at the following boot up - I can’t remember). The Windows warmup screen claimed that it too had found errors and was correcting them.

At any rate, when I first accessed a boot manager after the attempted install, it showed that ‘secure boot’ was disabled (just as I had checked before attempting to install), and that ‘legacy’ bootup mode was also disabled.

Thinking that my installation had perhaps failed because legacy support was disabled (I don’t know if that should be the setting - that matter may not be addressed on your installation webpage), I was about to try disabling legacy support, but a warning came up that the system might not be able to boot afterwards so out of concern I did not attempt to disable ‘legacy’ support.

Earlier today, I was able to check the internet through another locale and noted that when setting the computer to disable secure boot, Hewlett Packard advises to “[…] select Legacy Support, then use the left and right arrow keys to change the setting to Enable […]”, according to this webpage:

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c03653226&cc=us&dlc=en&lc=en

Note: I don’t suppose Netrunner has booted from my hard disk (I think Windows 8 won’t allow the laptop from a pen drive unless I access the tiles in the Settings and ask to boot from the pen drive), and the laptop still boots straight into Windows when the pen drive wasn’t in (or perhaps once into the boot manager or bluish screen soon after the attempted install described above), so I could reboot into a Netrunner live session by setting Windows 8 to boot from the pen drive and try to access broadband internet from a public wifi spot during a Netrunner live session in case you advise me to download some application to repair the installation - I was able to access broadband this way (out of the box!) before attempting the install.

I could retry using Win32DiskImager instead of UUI to burn an image of Netrunner that could be more sound, if you so advise, as I think I did try to reinstall Win32DiskImager recently in Windows 8 as an administrator, and no files complained of not being able to be copied over or installed.

My situation is quite a pretty picture, eh? This mess is all my doing, I would think, not Netrunners’, because of a sloppy installation attempt of Win32DiskImager, and using another pendrive installer which worked excellently for other uses but not using the recommended installer in Windows (Win32DiskImager) for this distro, and other errors of mine! I will proceed at my own risk with this, of course, but other than getting my USB port repaired when the two other ports are enough and seem to work well most of the time (the connected HP Laserjet 2200 printer also worked immediately during a Netrunner live session out of the box, so kudos again to Netrunner!), how would you advise me please to fix the GRUB problem so that I can launch Netrunner, or how to reset the Netrunner partitions and attempt a guided dual install again?

Thank you so much!

The only advise I can give you when it comes to this kind of problem is to go through this list of checks.

  1. Check if UEFI secure boot is disabled in bios/uefi
  2. Make sure that the boot mode is set to uefi and not mixed or hybrid mode.
  3. Check if the partitionscheme is a GPT one (use gparted on live system)
  4. Check if the uefi boot partition is there and is marked boot (again use gparted)

(and please use shorter subject titles in the future for threads)

Sorry for the long title earlier on, and thank you for your helpful guidance – I appreciate it! Feedback given below.

  1. UEFI secure boot was disabled in bios/uefi.

  2. Boot mode appears to me to probably be set to UEFI , as the boot manager offers whether ‘Legacy Support’ is to be ‘disabled’ (besides asking about ‘Secure boot’). Comments to the side of the Legacy Support option say in part, “When Legacy Support is disabled, BIOS will boot in
    UEFI mode with CSM [explained as ‘Compatibility Support Mode’] to support newer operating systems such as Windows 8.”

In this respect, please note that my HP laptop differs from the description in the HP webpage quoted above (also quoted in another thread in this forum) because it asks about ‘legacy support’ and resembles more closely that of the HP desktop boot manager shown on that webpage; I suppose my model is a newer one (late 2012).

  1. The partition scheme may be GPT, I suspect, according to the description of the ‘Partition table’ description given in the left-hand box of the screenshots from Gparted (having run a live Ubuntu session disk) after my install attempt:

[attachment=494]

  1. I am not sure if the UEFI boot partition is there, but Windows 8 has been booting since then; the screenshot given in answer no. 3 shows that /dev/sda2 is marked ‘boot’.

Would the four circumstances you suggested have been met, then? Seeing how I didn’t have any knowledge on how to correct the GRUB problem on the dual install nor how to revert the partitions to the original state, I attempted to install Netrunner as the only operating system, My other operating system (mentioned above) was not worth my trouble anymore!

I noticed that some websites report that Windows should have its ‘fast start up’ option ticked off (at least for the distro that they were discussing), so I turned that off when trying to reboot, but no noticeable effect was found.

Having backed up my personal files, I burned the Netrunner .iso image anew onto a USB drive using Rufus as an administrator in Windows. Since first using Disk Image (which I referred to earlier as Win32DiskImager) to attempt the dual install, I tried reinstalling it properly at one point on one of my pen drives while I still had Windows as a ‘dual’ install, but at one point (after burning the Ubuntu image to get Gparted or whatever other operation I was using these pen drives for), one pen drive had reduced in size (c. 1.37 gb) and the other pen drive was no longer recognized as a USB drive, but Windows’ Device Manager called it a UFD Relay device; both those conditions were helpfully corrected thanks to your suggestion on your installation page to use Bootice. I am able to use both pen drives to their full capacity now, thank you; however, despite following the instructions webpage (link on your Installation webpage) for Bootice – one of my USB drives kept asking whether I wanted to format the drive even though Disk Image claimed to have burned the Netrunner image successfully. I was able to use that pen drive successfully when Rufus burned the image instead though.

Just like my original problem for a dual boot installation, immediately after installing Netrunner as a single boot (guided install) at this point, I got the same error message (I think this was probably the wording instead):

 The grub-efi-amd64-signed package failed to install into /target/ 

When attempting to boot after this fresh single install (not like my original attempt at a dual install alongside Windows), and having removed the USB pen drive with the Netrunner image, I got messages of ‘Checking media’ twice in succession with a ‘fail’ (if I remember correctly).

I don’t recall the sequence of all the error messages, but on two occasions when rebooting my laptop, the error message was that there was no operating system on the hard drive. I could, however, access the boot manager (pressing F10), and similar messages appear regardless of whether I chose ‘Secure boot’ or not. I have been able to run live sessions of Netrunner from my pen drive without a problem. I believe that I am currently even running a live session of Netrunner off my DVD, as I had burned an image there also (the DVD sounded very active when booting this session and the pen drive was rarely lighting up).

Gparted for this single install shows as follows (Gparted actually quickly installed on a live netrunner session, I found out):

[attachment=495]

I can’t recall now when I ran the tests once suggested in the Ubuntu Community (https://help.ubuntu.com/community/UEFI) regarding recognizing a secure install - whether it was during the dual install or single install - but the two results were:

EFI boot on HDD

and

Installed in EFI mode

The solution given to someone else who also got that Grubloader message (but for a dual install), according to the comments section of your ‘Download’ webpage, pointed to a webpage that suggested using Boot-Repair-Disk (http://ubuntuforums.org/showthread.php?t=2165051&page=2&p=12752755#post12752755 ).

Boot-Repair-Disk was burned onto a pendrive when running a live session of Netrunner once I installed Unetbootin. However, when rebooting, I did not get a graphical interface as I had expected for Boot-Repair-Disk, but rather something like the following:-

		 GNU GRUB version 2.00 – 13Ubuntu3

Minimal BASH-like editing is supported.  For the first word, TAB lists possible command completions.  Anywhere else, TAB lists possible device or file completions

grub> 

On this single Netrunner install this time, and at my own risk, which of the following would you suggest MIGHT be the best forward please?

(a) Perhaps I could get the expected Boot-Repair-Disk GUI with the recommended boot repair solution if I installed Boot-Repair-Disk using bash instead from a Netrunner (or Ubuntu rather, if it makes any difference here?), as this is an option as shown here:

http://askubuntu.com/questions/226061/how-to-install-the-boot-repair-tool-in-an-ubuntu-live-disc

(b) I see that, recently, another ‘netrunner’ has had trouble getting a GRUB menu on a multiple install (http://forums.netrunner-os.com/showthread.php?tid=16385 ) when using a pen drive, but somehow succeeded when using a 64bit DVD. Should I attempt a reinstall this way?

© Others who have had the same Grub loader error messages have reported having the problem clear up with Linux distros when installing when an internet connection was active instead (no internet connection was made on either of my dual- and single-installs):

http://askubuntu.com/questions/260297/12-04-2-failed-to-install-grub-efi-to-target

(d) On a Linux Mint forum, on the other hand, some have disputed whether an internet connection was required, however, but there has been some approval for the ‘Boot Repair’ instrument and/or a ‘grub-customizer’.

(e) Someone reports a different solution, though for Ubuntu, in that “Ubiquity for some reason isn’t mounting the existing EFI partition automatically” apparently, and he suggests a command line fix as root and other actions:

http://ubuntuforums.org/showthread.php?t=2201332&page=2

(f) Someone claims that there is a ‘rescue’ option (presumably for a Debian release) for an
http://forums.debian.net/viewtopic.php?f=17&t=55686&sid=d6ad71235fdb62f0e13aa2fa3348003a

I would be grateful please for your suggestion(s) of the best way forward here, for this ‘single’ install, instead of a ‘dual install’ attempted earlier. Thank you very much!

[quote]The solution given to someone else who also got that Grubloader message (but for a dual install), according to the comments section of your ‘Download’ webpage, pointed to a webpage that suggested using Boot-Repair-Disk (http://ubuntuforums.org/showthread.php?t...st12752755 ).

Boot-Repair-Disk was burned onto a pendrive when running a live session of Netrunner once I installed Unetbootin. However, when rebooting, I did not get a graphical interface as I had expected for Boot-Repair-Disk, but rather something like the following:-

GNU GRUB version 2.00 – 13Ubuntu3

Minimal BASH-like editing is supported. For the first word, TAB lists possible command completions. Anywhere else, TAB lists possible device or file completions

grub> [/quote]
Looks like it failed booting on your machine.
I might be wrong but I think unetbootin does not support UEFI.
So I would suggest dd’ing the boot repair image to the usb pendrive.

quote Perhaps I could get the expected Boot-Repair-Disk GUI with the recommended boot repair solution if I installed Boot-Repair-Disk using bash instead from a Netrunner (or Ubuntu rather, if it makes any difference here?), as this is an option as shown here:

http://askubuntu.com/questions/226061/ho…-live-disc
[/quote]
Yes that would be possible and a good solution.

quote I see that, recently, another ‘netrunner’ has had trouble getting a GRUB menu on a multiple install (http://forums.netrunner-os.com/showthread.php?tid=16385 ) when using a pen drive, but somehow succeeded when using a 64bit DVD. Should I attempt a reinstall this way?
[/quote]
I hope you used the 64bit version of Netrunner.
32bit does not support UEFI.

As for ( c ) yes please try to connect to the internet before installing Netrunner on the live system. It might pull the latest grub-efi packages from it which can already fix your problem.

Solution (e) if everything else fails might be a good try.
As for (f) I never heard of it.

So my advice first try solution (a) as it does not require reinstallation of Netrunner. Of course only when option (b) is met that you tried installing a 64bit Netrunner onto your system. (which if I understood your initial post correctly is the case).
Trying reinstallation with option ( c ) having an internet connection is then the next solution I would try.
And then you can try the rest as well if above all fails.

Excellent, thank you!

Solution (a) was attempted, and so far so good; 64bit images are always being used, to be clear:

  • Though the website ( http://askubuntu.com/questions/226061/ho…-live-disc ) instructs users to run live session of Ubuntu booting from a DVD and connecting to the internet, after consideration, I figured it might not make much difference if I just ran this repair attempt continuing my live session of Netrunner booted from my pen drive (as Netrunner is roughly speaking built on Kubuntu/Ubuntu and I don’t seem to be able to boot from my internal DVD drive anyway, contrarily to my recent post, even when setting the ‘boot option’ to boot from internal DVD in the boot manager; the DVD as well as my pen drive have 64bit images of Netrunner burned onto them, but the DVD just seems to be busy for some reason when booting from a pen drive if I plug in the pen drive a few seconds late when booting up.)

  • It might be of interest also to note that one of the bash commands on the website for solution (a) specified ‘trusty/saucy’: what if this Netrunner 14 Main Edition was based (so to speak) on a version of Ubuntu that might be either later or earlier than ‘Trusty’ or ‘Saucy’, if there were such a version? Anyway, I decided to risk it, and fortunately I got some results in my case, as follows, and all of the bash commands completed and Boot Repair got installed without any complaint.

A dialog box appeared:

          'Is there RAID on this computer?'

I clicked on ‘No’ after a quick search on the internet gave me the impression that RAID is a way of joining two hard drives to act as one, for example (but there were other explanations and a suggestion on one webpage to just respond as though there were wasn’t any RAID if you were unsure, as in my case I thought there wasn’t any anyway). However, I now recall having chosen a ‘guided’ install of Netrunner on the whole disk with the ‘LVM’ option - only thinking that the more options the better, although I only had a general idea of what LVM was. Perhaps I should have answered ‘Yes’ to whether I had RAID installed therefore?

Soon a dialog box entitled ‘Boot Repair <2>’ appeared that said:

          /boot detected.  Please check the options.

I clicked on the only button shown: ‘OK’. Then I got a dialog box that offered a ‘Recommended repair’ button as well as a button called ‘Create a BootInfo summary (to get help by email or forum)’ as well as other selections: ‘Advanced options’, etc. I had seen some websites that say to simply click on ‘Recommended repair’ so I thought I should go ahead. The answer came back shortly thereafter:

          "GPT detected.  Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag).  This can be performed via tools such as Gparted.  Then try again.  Alternatively, you can retry after activating the [Separate /boot/efi partition:] option."

I clicked on ‘OK’ and then on the ‘Create a BootInfo summary’ button, which reported:

          Please write on a paper the following URL:
          http://paste2.org/g6t4LDHv

          In case you still experience boot problem, indicate this URL to:
          boot.repair@gmail.com or to your favorite support forum.

          No change has been performed on your computer.

To fully exhaust this ‘solution (a)’, described above (installing and launching Boot Repair with bash commands), I could continue with Boot Repair’s recommended fix, but I would be grateful if I could get your impressions on the following guides found on the internet re using Gparted to “create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag)” or the alternate solution given above by Boot Repair:-

(a1) Perhaps I should rerun Boot Repair but answer ‘Yes’ to ‘Is there RAID on this computer?’ because I chose an LVM installation? I have no plan to sequence my laptop with a second hard drive, etc.

(a2) Looking at the URL given for my machine by Boot Repair, the diagnosis mentions Syslinux, which reminds me of System Repair CD and Trinity Rescue Disk, which are excellent repair disks that I had burned onto either that pen drive or the other some while back to repair another PC. I am not sure, however, that it refers to those previous images, and if there could be any vestiges of those images (perhaps this possibility is a non-starter), they would have been overwritten (you will recall that I have used, I think, other distros on that pen drive and ran Bootice). Maybe I need to clean the hard drive or some partition?

(a3) Apply Boot Repair’s first suggested fix by installing GParted during a Netrunner live session and, say, creating a new partition at the beginning (or end?) of another partition, say by resizing dev/sda1 (see second screenshot above), or dev/sda3? ‘Align to’ ‘MiB’ or otherwise as an option? Then make sure that the new partition is set not to be formatted and with the bios_grub flag, all as instructed, by setting the options to have the partition format ‘set to’ ‘cleared’, and removing the ‘boot’ flag when setting the bios_grub’ flag?

(a4) Apply Boot Repair’s second suggested fix, perhaps by resizing dev/sda1 or sda3 and creating a /boot/efi partition? What format should that partition have? Would I then just reboot using a live Netrunner session (and an internet connection for possibly better results)? I will want to be able to have the option of running in EFI modes and ‘secure boot’ disabled modes anyway, ideally.

(a4) Any other way to continue with Boot Repair, an excellent program which gives a lot of interesting information and a lot of ‘Advanced options’? (Note line 445 in the BootInfo URL, which mentions an ‘Unusual EFI’).

From what I see from the log I would retry it not with raid stuff as lvm is not raid but before running the rescue tool activating/mounting the efi boot partition. The fat32 partition on your harddrive

I tried to mount the dev/sda1 Fat32 partition as follows in the Yakuake terminal:

sudo mkdir /mnt/fat32
sudo mount /dev/sda1 /mnt/fat32

I then tried to install Boot Repair using the command instructions given in the solution (a) above, but this time I got the error message “E: Unable to locate package boot-repair”. I found a fairly recent solution (http://askubuntu.com/questions/449818/cant-find-boot-repair-package-for-the-newest-version-of-ubuntu) where the four commands shown there worked for me to install Boot Repair:-

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sh -c “sed -i ‘s/trusty/saucy/g’ /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list”
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

When Boot Repair ran this time, having mounted my EFI partition as above, I again said ‘No’ to ‘Is there RAID?’, and the message came back:

/boot detected. Please check the options.

I clicked on ‘BootInfo’ first this time to get an URL:

http://paste2.org/KGOMctUA

However, I didn’t get the chance then to click on the ‘Recommended Repair’ option (which might have been an important mistake on my part, because I wonder whether Boot Repair my not be return the Recommended Repair solution any more that it had found this second time (though maybe it could, I don’t know). I ran Boot Repair for the third time, and the solution came back as the first time:

GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again.

In case these can help, there are the current screenshots - note that dev/sda2 now appears to be mounted on ‘/mnt/boot-sav/sda2’:

[attachment=501]
[attachment=502]
[attachment=503]

The BootInfo this third time around gave:

http://paste2.org/EfdhWn51

Shall I try solutions (a2) through (a5), at my own risk?

The problem with this tool is this

So it is not detecting the EFI boot partition which is the problem here.
I am not sure why though.
But it also said that secure boot is enabled.
Netruner does not support secure boot. So maybe disabling it and reinstalling helps

Thank you. Secure boot now set as disabled therefore and ‘Legacy Support’ continues disabled.

Installed Netrunner off pen drive live session, initially with internet connection, and the installer crashed with error messages about software not being up to date; I think this was because I immediately noticed that the public internet connection had logged off while the installer was copying files.

Having rebooted, reran installer successfully the second time (guided install without LVM) while I made sure the internet was kept connected. Restarted the laptop as instructed by installer; the GRUB screen appeared, but perhaps that might have been because it was still booting off the pen drive: I think GRUB selection was ‘Try Netrunner’ or so, and when I clicked on the USB icon in taskbar during that session, or when attempting to remove the pen drive, noticed that somehow there was a message next to that icon about some file/files still being in use by an application. I removed the pen drive anyway to try restarting without the pen drive. I accessed boot manager (‘F10’ key repeatedly immediately upon this HP laptop warming up) and set boot sequence to be from hard drive before USB drive. Then, no GRUB menu appeared on rebooting except for a screen similar to one reported earlier, though the GRUB title was different - something like:

GNU GRUB draft[?] version 2.00 […?]

[?]Minimal BASH-like editing is supported. For the first word, TAB lists possible command completions. Anywhere else, TAB lists possible device or file completions

grub>

The screenshot of KDE Partition Manager showed:

[attachment=505]

Boot Repair was first attempted without the added guidance of mounting the FAT32 partition. The following message was received:

EFI detected. Please check the options.

At some point yesterday after I performed the above operations, I also tried rerunning Boot Repair another time but with the FAT32 partition mounted. I am not sure whether the ‘Recommended Repair’ was run on both occasions and whether following BootInfo URL was given before or after running Boot Repair with the FAT32 partition mounted:

http://paste2.org/av4edCPY

During or immediately before launching Boot Repair on one of those two runs, it must also have generated the following message on the terminal immediately:

(gksudo:9398): GConf-CRITICAL **: gconf_value_free: assertion ‘value != NULL’ failed

I’m not sure what the next move could be. I would be grateful for your thoughts. Thank you.

In case this can be of help, the above BootInfo URL gives the following info:

  • “No boot loader is installed in the MBR of /dev/sda.” (line 6)
  • “Syslinux MBR (3.00-3.35) is installed in the MBR of /dev/sdb.” (line 7)
  • “Boot sector info: Syslinux looks at sector 32776 of /dev/sdb1 for its second stage. The integrity check of Syslinux failed.” (lines 35 & 36)
  • “GUID Partition Table detected” perhaps under dev/sda1, which is also identified as an EFI partition? (lines 56 & 59).
  • There is also the following appearing at lines 406, 426 and 585; and also at line 423 but referring to sfdisk instead of fdisk:
    “WARNING: GPT (GUID Partition Table) detected on ‘/dev/sda’! The util fdisk doesn’t support GPT. Use GNU Parted.”
  • There were also “StdErr Messages” at lines 388-393.
  • There is again the “Unusual EFI” flag in this BootInfo (line 487)
  • “BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.” (line 488)
  • “Adding boot menu entry for EFI firmware configuration” (line 8434)
  • “An error occurred during the repair” is a message towards the end of the BootInfo report (line 8437)

At this point, unless the BootInfo above can’t help, pehaps I could consider the following additional option, and I would be grateful for your guidance to get my hard drive to boot into an operating system:

(g) Perhaps when I attempted to install Netrunner the second time, with ‘Secure Boot’ disabled, I should have enabled ‘Legacy Support’ seeing how the HP link given in my first post instructs desktop (Windows 8) users to enable ‘Legacy Support’ when disabling ‘Secure Boot’? You may recall that I had pointed out that my HP laptop had a boot manager screen that resembled the photo of their desktop manager’s boot manager more than the laptop’s which display on their webpage because my boot manager has the ‘Legacy Support’ enable/disable option, just like their desktop, and not like their laptop, which is useful, they say, at least for Windows 8 users when attempting to install from a CD/DVD. I cannot get Netrunner at present to boot when burned onto and set to boot from a DVD. I could try to reinstall Netrunner as a single install and at my own risk installing from a live USB session with ‘Secure boot’ disabled but with ‘Legacy boot’ enabled and a working internet connection if you or anyone who has tried this out thinks this could be a way forward. Thank you.

SUCCESS!

Netrunner is now installed and launching by default from my hard drive!

After the challenges above, I decided to try installing Ubuntu in secure mode, as it looked most promising at that point as it is a signed distro. Ubuntu launched fine on demand from my hard drive as a single install, either in EFI mode or with secure mode disabled (although bit by bit, it needed tweeking in several ways: clicking on Vol+ or Vol- revealed with a ‘blirp’ sound that the desktop was launching, but the screen was black, and the solution is not part of this post; and I also felt that I had to download the ‘fglrx-updates’ alternative graphics accelerator driver for my AMD64 notepad to get Ubuntu to enable hibernation, disabled by default, and this succeeded to get fixed). I installed Ubuntu twice as I later messed up the configurations, and I don’t know whether this has any bearing, but I wonder whether these two initial Ubuntu installations helped to clear out the grub or something (just my humble layman’s opinion so I might be completely wrong, but I record these first steps I took in case it could help anyone who would like to know any steps that someone took to get Ubuntu or Netrunner installed). I note that one helpful YouTube user posts ways on how to boot distros that may be unsigned sometimes by using Ubuntu as an intermediary stage (https://www.youtube.com/user/nehaljw/videos).

More recently, I looked more closely at the ‘InsydeH20 Setup Utility’ (F10 on my Hewlett Packard on boot-up). Under ‘System Configuration’‘Boot Options’, two entries are sometimes greyed-out: ‘Clear All Secure Boot Keys’ and ‘Load HP Factory Default Keys’. Hopefully the following photo of my screen could illustrate this, when I managed to get ‘Clear All Secure Boot Keys’ to be coloured white i.e. ‘toggable’:

[attachment=546]

By experimenting, I noted that each of those two entries could be made accessible (shown by turning white-coloured) by toggling the ‘Legacy Support’ and/or the ‘Secure Boot’ options directly above: most usefully, the ‘Clear All Secure Boot Keys’ option turned white and therefore ‘toggable’ when I played around with the ‘Legacy Support’ and/or the ‘Secure Boot’ options directly above so that they both were ‘Disabled’ at the same time. From earlier attempts, I had learned to accept the warning that pops up about the system possibly not being bootable if these are changed. I have managed to reboot with USB pen drive burned image of Netrunner or a Ubuntu DVD-ROM.

After researching the internet about whether any irreversible damage might occur by clearing the secure keys, however, and finding no significant hazard other than a simmilar warning about the system becoming possibly unbootable when selecting ‘Yes’ to the ‘Clear All Secure Boot keys’ option before committing to it, I decided to clear the keys and made another attempt at installing Netrunner having backed up my personal files. The menu soon prompted me to confirm the choice to clear the keys by having to enter the code displayed on screen. On later boots, selecting the ‘Load HP Factory Default Keys’ option appeared to be the complementary option to ‘Clearing All Secure Boot keys’ though I suppose that this may be evident, I don’t know!

Recently, and I think that this only occurred on the few times when ‘secure’ boot mode was disabled, if I have observed this correctly, I decided to try hitting the ‘Esc’ key on reboot also, having noticed a “Press Esc key for startup menu” message a few times on reboot on this HP notepad at the lower left-hand side of the screen. The ‘Startup Menu’ that appeared gave me several options using some of the keys from F1-F12, as shown on this photo:

[attachment=547]

Since discovering this Startup Menu, the most relevant keys there for me in order to install at least two distros successfully other than Ubuntu (which installed fine too, as noted above) have been:

  • “F10 BIOS setup”, which gave me the InsydeH20 Setup Utility screen if I wanted it again (in the past, as still now, I could have got that utility by hitting F10 immediately on powerup on this HP laptop). Under the F10’System Configuration’‘Boot Options’, of course, one first needs to instruct the PC to boot from wherever the .iso image is burned: either from the USB drive or DVD-ROM.

  • When I selected “F9 Boot Device Options” while Ubuntu was still installed (i.e. before trying again to reinstall Netrunner since the earlier posts), I remember noticing that there were several options given, each on a different line: ‘ubuntu […]’ and ‘Ubuntu […]’ (with a capital ‘U’), each of those lines being followed by ??my hard drive’s technical name perhaps. (There were other options, which I think still show up currently with Netrunner installed - see next photo). I don’t know whether perhaps ‘ubuntu’ and ‘Ubuntu’ stood for ‘Not secure’ and ‘Secure’ boots, by the way.

The first install attempt of Netrunner since my previous posts was done during a USB pen drive live session, having already (a) DISABLED SECURE BOOT; (b) ENABLED LEGACY SUPPORT; and c) HAVING CLEARED THE SECURE KEYS as above; and double-clicking the desktop’s "Install Netrunner’ shortcut, and selecting the guided install on the whole disk option during that facility (with unencrypted home drive, as always until then). This first install did not boot although I had an internet connection for most part of the install but I had to interrupt the connection for an unrelated reason, though Netrunner declared on finishing that it had succeeded the install. However, I wonder if it might have helped again to prepare the system somehow because the following attempt succeeded, so I mention these installation details too for your record in case anyone would want to try to replicate my steps precisely in order to succeed an installation in case they are struggling.

The second install was performed WITHOUT AN INTERNET CONNECTION, again using the whole disk, but selecting to have my HOME FOLDER ENCRYPTED for the first time; this likewise installed without a complaint. (Of note, towards the end of the installation process, and just like during the first attempt, it spent several seconds reporting that it was uninstalling various files including some ‘[…]AMD64’ files). Upon rebooting, I decided to select the ‘Escape’ key, followed by F9 for ‘Boot Device Options’, and this time the boot options only displayed entries for the following, as the next photo demonstrates:

Boot from EFI File
Notebook Hard Drive
Network Adapter (IPv4 Legacy)

[attachment=548]

This surprised me because immediately after having tried the first Netrunner install with the secure boot keys cleared, this F9 screen showed entries for ‘ubuntu …’, ‘Ubuntu …’ as well as ‘Netrunner …’ and ‘Netrunner … EFI’. So (a) ‘Ubuntu’ entries still showed up then even though Netrunner had reported having installed successfully on the whole drive; and (b) as you can see from this screen shot, there are currently no options to launch ‘ubuntu […]’ 'Ubuntu […] or even ‘Netrunner […]’, yet Netrunner launches successfully now. On one occasion, I decided to boot by selecting ‘Boot Manager’ from this F9 menu, as I thought that the ‘EFI …’ option might not succeed. Netrunner launched perfectly. On rebooting, I tried not to even hit the ‘Escape’ or the ‘F9’ key after that, but rather hoped that it would boot into Netrunner on its own, which it did! It has booted successfully on its own on all occasions, and I have been able to make various settings.

Observations on the other two ‘F9’ entries:

  • If I choose “Boot from EFI File”, I currently get a similar-looking screen called ‘File Manager’, but the screen otherwise shows no data. On the few other occasions that I had looked here (since I recently discovered the ‘Startup Menu’ screen by pressing the Esc key when Ubuntu got installed), I think that I got a ‘DOS’-looking report of folder files with a ‘…’ representing the parent folder and a ‘.’ representing something else, plus some other file(s), if I recall correctly.

  • I haven’t tried the “Network Adapter” choice.

  • Even though the ‘Notebook Hard Drive’ option is not first on this ‘F9’/‘Boot Device Options’ list, the system boots into Netrunner when not accessing the F9 menu on reboot. IMHO, I wonder whether this is because ‘Boot from EFI File’ option appears to be blanked, as described above, and/or because the system is not set to boot in ‘secure’ mode anyway.

I took note that the “Software Updates” icon soon reported that I had 9 updates available, which surprised me because I hadn’t yet connected to the internet during this second install attempt of my slightly aging Netrunner .iso image. This could be way off, as I am hardly experienced with Linux, but I wonder whether this might be explained by the fact that the previous recent install attempt after the secure boot keys had been cleared and using an internet connection may have already recorded that those 9 major updates were available, and the second install may have kept note of this finding? The “Software Updates” listed the following as available, among others:

linux-generic
linux-headers-3.13-09
linux-headers-3.13-09-generic
linux-headers-generic
linux-image-3.13-09
linux-image-3.13-09-generic
linux-image-generic

Before installing those, bash commands “uname -r” and “lsb_release” respectively reported:

[Linux kernel] “3.13.0-24-generic”
“No LSB modules are available”

Also, several times (all sequentially I suppose), when the Netrunner splash image came up before getting prompted for a login password there was a message: “Disk drive for dev/mapper/crpytswap1 is not ready yet or present”. Upon investigating this on the internet this appeared to be a swap file issue. The last partition was reported by GParted as being unformatted, and one website for example (http://punygeek.blogspot.ca/2012/10/ubuntu-1204-how-to-solve-disk-drive-for.html) demonstrates how to resolve this error message by setting a partition to become an encrypted swap file. Roughly speaking, though I did some variation on this, I resolved this by basically following the instructions --and partly one of the comments-- at that website though I decided not to execute the last instruction on that list about encrypting the swap file: a warning came up in the terminal reporting that this last instruction would break the hibernation capabilities, which I prefer to preserve as I sought to enable this by installing the ‘fglrx-updates’ alternative graphics accelerator, also used for Ubuntu, as noted above.

I haven’t learned yet how to determine whether the home folder is encrypted to confirm whether this choice selected during install was implemented. After formatting the last partition as swap as just discussed, apparently to me within another partition (i.e. as an extended partition?), GParted shows only one other partition --a boot partition (Ext4 format):

[attachment=549]

I was also surprised to get the following ‘GRUB2’ screen show up when I think I accidentally hit ‘Esc’ key followed, I thought, by the ‘tilde’ key directly below it (or hitting it on its own perhaps) sometime soon after this second install:

[attachment=550]

I have been able to get this ‘GRUB2’ screen again on bootup (and notice the word ‘Ubuntu’ in the title) by hitting ‘Esc’ followed by F10 (to get the InsydeH20 facility), and if I exit InsydeH20 by pressing ‘Esc’ or F10 (to save ‘changes’, as prompted, though none were requested), or some other way of exiting that screen, I obtained that GNU2 screen also.

Don’t GRUB2 screens show up only under secure boot? I’m just an amateur and I am not sure about that, but Netrunner has since been booting with secure boot disabled. With Netrunner installed this second time, and when I tried to choose to ‘Load HP Factory Default Keys’, disable ‘Legacy Mode’ and select ‘Secure Boot’ in the InsydeH20 facility, a black screen appeared reporting ‘Checking media [failed]’, and then another screen declaring ‘Selected boot image did not authenticate. Please hit to continue’.

Currently, some bugs are presented, but I don’t know whether these are due to using this laptop employing a public library’s wifi system without a VPN, for example, despite programming an iptable. For example, although the ‘Software Sources’ GUI would operate well for days, it currently crashes; Synaptic also reports a “Wrong sources.list entry or malformed file” although various other updates do install. I plan to look into these matters, but at any rate, Netrunner is now booting from the hard drive, and I can use it.