Network Manger, USB Wireless - Virtualbox


I have tried to resolve a problem with VirtualBox and despite AJSlye’s help and visiting various forum’s including Virtualbox, the conclusion is that it is related to Netrunner Rolling’s Network Manager. Here is what happens.

I start up, log in and open VB with that has all its required dependencies installed.

I use the up to date Kali 1.09 in VB and plug in my Alfa/Atheros USB wireless adapter. All goes well, until I close down VB.

I then try again to use Kali, but this time VB does not recognise the Alfa and it’s light does not come on.

If I close down VB, I can still use the Alfa and the Network manager icon shows that it is active and it’s
light comes on.

So I try again to use VB and the Alfa has no light and is still not recognised. At this stage if I log out the problem is still there but if I do a reboot the problem clears. I do not have this problem in other distro’s not even Netrunner Frontier or Manjaro itself.

That said I really like Net Rolling because of it’s superior sound output and would like to resove this problem.

Can any one help or is there something I am missing here guy’s… Thanks in advance - Steve

Which flavor of Manjaro did you use to test with?

Each of the Manjaro ISO’s (Official and Community Editions) all have different software pre-installed, and different defaults in their configuration scripts, there might just be something not installed or configured differently that is required for it to work properly.

Hi AJSlye, again… and thanks for your patience on this.

I used Manjaro KDE 0.8.10 about a week ago, before I decided to hop over to Netrunner’s distro’s.

I have even tried sending the wired connection down and then up hoping it would clear any errors!

Is there a way AJSlye of restarting the network manager in Net Rolling, I can’t find a command?

If you have any other suggestions please advise.

Netrunner Rolling like Manjaro uses sytemd:

systemctl restart NetworkManager.service

Unless, did you mean kdeplasma-applets-plasma-nm?

Just tried systemctl restart NetworkManager.service still the same thing AJSlye.

I thought by restarting the Network it would clear any resources if they were still busy.

Shame really… I have to make a choice. Rolling if I dont mind the reboot, or Frontier.

Thanks again - Steve

What you could do is try using an alternative network manager like wicd for example. Though it might be also a limitation of virtualbox here.

Did you install virtualbox-ext-vnc and virtualbox-guest-utils as well as linux314-virtualbox-host-modules and virtualbox?

The easiest way to get the vitualbox extension pack is from the AUR:
yaourt -S virtualbox-ext-oracle

I also found these in the AUR, they could be usefull:
vagrant-vbguest – a plugin which automatically installs the host’s VirtualBox Guest Additions on the guest system.
kdeplasma-runners-vbox – Allows starting VirtualBox virtual machines from Krunner

Hi AJSlye

Thanks again for being on hand and available, and my apologies for not replying earlier.

I have installed and tried all your recommendations but I am still unable to resolve the problem.

I have also tried other forums and they insist that it is a Net Rolling problem, and as you can see by the output below fromVB’s Kali, when I try to use the USB Wireless again, and before a reboot, there is mention of a Network Manger error, which I can not kill.

Found 2 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
2274 dhclient
2399 NetworkManager


I hate to say it, but I just don’t have a need for vitalization. I have never actually used virtual box.

This might be useful:

That’s OK thanks anyway… I mainly use VB and Kali for Pen-Tests.

Nevertheless, and I can say as user of just over 13 years, this distro has a great future and I will go on using this and the Ubuntu version.