New install update issues [solved]

I installed the newest rolling iso. Logged in, updated using octopi, then reset my computer. When I try to login, it just drops me back into a login screen. To get it to get past the login, I have to click on the session and select plasma (which is the only session type) then if I login, it will take me to the desktop. Sometimes when it takes me to the desktop the window decorations disappear and it doesn’t maximize, close, or minimize. I’m using Intel graphics, open drivers. Have not downloaded abyhing extra yet. Can not for the life of me figure out what’s going on…

Try running the update again from the terminal with the following commands:

sudo pacman -Syyuu

Make sure you select Y at any and all prompts.

It says there is nothing to update. Still does same thing.

Make sure you have mhwd-db version 0.5.6-10 installed.
Also check that /etc/X11/mhwd.d/intel.conf has option “DRI” “3” in it.

0.5.6-10 is installed. I do not have an xorg.conf, I have an intel.conf.

Contents of that file are below. I see two sections where it says DRI, but wasn’t 100% sure on what you meant.

Generated by mhwd - Manjaro Hardware Detection

Section “Device”
Identifier “Device0”
Driver “intel”
BusID “PCI:0:2:0”
Option “AccelMethod” “sna”
Option “DRI” “true”

Section “DRI”
Group “video”
Mode 0666

Section “Extensions”
Option “Composite” “Enable”
Option “RENDER” “Enable”

Section “InputClass”
Identifier “Keyboard Defaults”
MatchIsKeyboard “yes”
Option “XkbOptions” “terminate:ctrl_alt_bksp”

After reading your previous post and realizing I can’t follow simple directions :p. Changed the line

Option “DRI” “true”


Option “DRI” “3”

rebooted and it came to desktop without having to select the session. It seems to be working now. Thank you!!

Yes thanks, I meant intel.conf. I fixed my earlier post.
Mhwd was supposed to run on boot and automatically change the DRI setting for you, for some odd reason it didn’t.
Anyway, I’m glad to hear it’s working for you now.

So the issue where it sometimes doesn’t have the windows decoration is still there. Basically it has no top titlebar, and then it starts acting really funky, you can’t close windows or alt+tab to each other, but if you click on the window itself with the mouse it will take the focus. Hopefully you can see what I mean in the picture.

What picture?
Anyway, I can’t reproduce this issue on any of my systems.
May I ask, how did you create the install media, i.e. what application did you use?

K3b. DVD medium. 64bit torrent iso from the Web site. It’s basically like kwin craps out. It does it on like 5% of my boot ups.

You could try playing around with the compositor settings until you find a setting that is more stable with your GPU.
Could you please post the output of the following commands?
mhwd -li

Please use code boxes.