No sound when I plug in headphones and reseting sound volume

Hi

This is actually software/hadrware problem, I didn’t know where to put this post.

I use Netrunner Arch from few weeks. Generally I like the distribution and I don’t have bigger problems with it besides following two:

  1. When system starts, sound volume is set to 50%, no matter what volume level was set when I log out. When I lower it using multimedia buttons on my laptop, and when comes up some KDE notification, the volume level set itself again to 50%.
  2. Although normally sound is available, when I plug in my headphones there is no sound at all.

Some time ago when I was using normal Netrunner based on Kubuntu there was no such problem.
I am aware that this distribution is very young and is in development. Is there any solution to this problem, anyone has the same?

More hardware info would be beneficial, please post output of:
inxi -F

Thanks,
AJSlye

This is the output:

System: Host: rafal-PC Kernel: 3.10.34-1-MANJARO i686 (32 bit) Desktop: KDE 4.12.3 Distro: Netrunner 14.04 Arch Machine: System: Acer product: Aspire 5738 v: 0100 Mobo: Acer model: JV50_MV v: Rev Bios: Phoenix v: V1.34 date: 09/24/2010 CPU: Dual core Intel Core2 Duo CPU T6500 (-MCP-) cache: 2048 KB Clock Speeds: 1: 1200 MHz 2: 1200 MHz Graphics: Card: NVIDIA G98M [GeForce G 105M] Display Server: X.Org 1.14.5 driver: nouveau Resolution: 1366x768@60.00hz GLX Renderer: Gallium 0.4 on NV98 GLX Version: 3.0 Mesa 10.1.0 Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel Sound: Advanced Linux Sound Architecture v:: k3.10.34-1-MANJARO Network: Card-1: Intel WiFi Link 5100 driver: iwlwifi IF: wlp4s0 state: up mac: 00:22:fa:52:8e:c0 Card-2: Broadcom NetLink BCM5784M Gigabit Ethernet PCIe driver: tg3 IF: enp2s0 state: down mac: 00:1f:16:b3:c1:64 Drives: HDD Total Size: 281.5GB (73.6% used) 1: id: /dev/sda model: ST9250315AS size: 250.1GB 2: USB id: /dev/sdb model: DataTraveler_2.0 size: 31.4GB Partition: ID: / size: 19G used: 9.5G (52%) fs: ext4 ID: swap-1 size: 0.32GB used: 0.00GB (0%) fs: swap ID: swap-2 size: 0.32GB used: 0.00GB (0%) fs: swap Sensors: System Temperatures: cpu: 46.0C mobo: 46.0C gpu: 47.0 Fan Speeds (in rpm): cpu: N/A Info: Processes: 169 Uptime: 5:50 Memory: 959.1/3029.3MB Client: Shell (bash) inxi: 2.1.9

This seems to be an issue regarding pulseaudio + vlc phonon backend. You could try changing the phonon backend to gstreamer in systemsettings. (just search for “phonon” there)

Thanks leszek.

In System Settings > Audio > Backend I had installed only GStreamer 4.7.1
So i installed VLC phonon 0.7.1, and I tried using installed music players, and I noticed weid things.

For instance Qmmp played music without headphones very quietly and on headphones normally. Clementine still had no sound with headphones in.
I installed Amarok and it’s the same as with Clementine - sound when headphones out, and no sound when they’re in.

I tried using both phonons, and with both of them there is the same problem.

Hi,
I had same problem using live USB.
First, I’ve found workaround - I’ve opened audio settings and in output device section I’ve chosen headphones.

…but then, after next restart of live stick problem dissapeard (Netrunner Arch).