Odd behaviors

Hi, first Netrunner installation. I’m seeing a bunch of weird behaviors I’ve never seen in KDE before. For instance:

The full context menu does not appear when I right-click on the desktop. The Activities manager and the Leave options are missing.

The lockdown/logout widget doesn’t offer me any leaving options (reboot/shutdown/etc) when clicked. It simply logs me out.

Despite the correct options having been selected in System Settings, auto-login is not working.

When I log in, I am never returned to the desktop I was working on when I rebooted. It takes me to the last activity, but not the last virtual desktop.

Most importantly, stuff is missing from the app menus. Significantly, Konqueror, Virtualbox, and Kontact are all missing. So are all of Kontact’s components.

Overall Netrunner looks nice, but all of the above amount to a seriously broken KDE. What’s going on?

These are modifications made by the Netrunner developers to clean up the system and remove duplicates the same way they did in their Ubuntu based version (consistency between offerings). All of the installed applications can always be accessed with alt+F2, or by going into the menu editor, selecting edit and then choosing restore to system menu. There is also always the possibility to use one of the other menu options other than Homerun Kicker.

Activities are not used or shown by default, you will need to do that yourself:
Click on cashew then Add Widgets and drag Activities to the panel.

Netrunner Rolling uses SDDM not KDM, the KCM (KDE Control Module) for SDDM is currently broken as the developers for it have moved on to QT5/Plasma 5. However the only part not working is themes, the advanced tab still works for setting up autologin: System Settings > Startup and Shutdown > Login Screen (SDDM) > Advanced

This is a bug in KDE 4.14.3, I’m still looking into this one as it is random and only happens to a subset of user configurations.

[quote]Overall Netrunner looks nice, but all of the above amount to a seriously broken KDE. What’s going on?

I answered this one in the first part.

PS. If you don’t like the modifications made by the Netrunner Developers then your going to HATE Plasma 5…

I did switch launchers… I only use Lancelot. It had the same behaviors. That said, the menu restore you suggested worked. I’m still not sure I understand why… is there a reason the devs want apps to not appear?

Can you tell me what’s up with the lock/logout widget? If it doesn’t give me the option to reboot/shutdown it’s useless to me. I almost never want to simply log out.

Why take away desktop activities access? I notice the keyboard shortcuts aren’t working either.

I made the change you suggested to the SDDM modules in System Settings… auto login still doesn’t work.

Regarding your KDE bug… I do have a farily complex use-case. I have a mixture of virtual desktops and activities going on. Is there any info I can give you that will help you zero in on the problem?

Simple answer to the first question these give a cleaner menu system with less duplicated functions and entries.

Second question Less clicks.

Third question is also simple, “statistics” less users like or use activities than those that do. I know I can’t stand them, but I can also see where they would be useful, especially when using plasma active or the Plasma-netbook interface.

SDDM has gone through a lot of changes, you may need to edit the /etc/sddm.conf file as root manually, I never tested autologin as i’m not the only one that uses this computer. I do know that it works on my test rig with the Manjaro plasma 5 development ISO installed though.

As far as the virtual desktop issue as I said prior, sometimes it happens other times it doesn’t. This seems to be a bug in either system Settings > Startup and Shutdown > Session Management or the pager widget itself, however since it’s random I’m having a hard time locking it down.

Regarding less clicks: not feeling it. Sure it’s one click… to take me to the login screen. From there I have hit reboot or shutdown, so it’s just as many clicks. I’d venture to guess that most PCs today are like this one: single-user. On a single-user machine there’s never a reason to even see the login screen. So my question is this: is there an easy way to get the old reboot/shutdown functionality back without going through the menu? My logout/lockdown has been in the same position on my panel since 2006 and I don’t want to have to change the way I do things now.

I checked out /etc/sddm.conf. AutoUser was already set to my username, and I set AutoRelogin to true. Still no autologin. Anything else I can try?

One other bit of weirdness I’ve noticed since the original post. After a reboot there is an icon in my system tray that looks like firefox, opens Firefox when clicked, and when right-clicked is listed as KSysTrayCmd. There’s no entry for it in system tray settings, but I don’t want it and would like to get rid of it. How can I do that?

Well, In my home on out family PC I always have a user account myself, one for the wife and another one with parental controls setup for my son. We also have to think about corporate and business types of deployments where more than on user will be using the computers in the course of the day and the need and ability for the admins to track who is on them, when, and what they we’re doing while logged in. It’s just good practice to not assume a one user environment, not to mention the security issues surrounding such an assumption.

I’m not sure why the autologin isn’t working for you as there are other users in this forum that have it working, for now I will leave it for one of them to help fix your issue, if not soon then I will certainly look into it for you.

I’m sure there is a way to get the logout, shutdown, restart screen to come up instead of the just do it approach currently used. I’ll defiantly look into this one as I like that approach better as well.

You need on top of your /etc/sddm.conf something like this:


Not sure but AutoRelogin=true only affects after logging off an auto login.