optimus problems, no KMS enabled

HI there!

Just installed Netrunner rolling and updated the whole system so it is as fresh an install it can be. Wanted to check that bumblebee works and did a

primusrun glxspheres64

and then get

primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) [drm] KMS not enabled
optirun glxspheres64


[code][ 2620.825665] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) [drm] KMS not enabled

[ 2620.825711] [ERROR]Aborting because fallback start is disabled.[/code]

Any ideas on what could be wrong and how to fix it are highly appreciated.


How did you install bumblebee?
The best way on NetRunner Rolling (Manjaro) is by using the Manjaro Settings Manager > Hardware Detection tool.

For more help please refer to the Manjaro and Arch wiki’s:

Sorry about my previous post. I got a bit short on time and couldn’t write the complete story.

I did go through those instructions. This is my third time I installed netrunner during the weekend after screwing up my previous installations troubleshooting this matter. I somehow ended up with some form of non graphical log in that did not accept my user name/password.

Anyway I did a

[code]sudo pacman -S virtualgl lib32-virtualgl lib32-primus primus
sudo mhwd -f -i pci video-hybrid-intel-nvidia-bumblebee
sudo systemctl enable bumblebeed

sudo reboot

optirun -b none nvidia-settings -c :8[/code]

However the nvidia setting complained about the driver not running or something like that. Another thing was that I had to remove video-hybrid-intel-nouveau-bumblebee before installing the video-hybrid-intel-nvidia-bumblebee above as they were in conflict.
When I did the primusrun glxspheres64 it complained about not being able to initialize the GPU. After reinstalling bumblebee it then said that the driver could not be loaded.

I did was is suggested in the sections
Configure The Resolution/Refresh Rate and Configure X Screen settings (OpenGL Settings, Antialiasing, X Server XVideo) at the Manjaro Wiki.

Also did a

sudo mkinitcpio -p linux310

I don’t know if that was what totally made my system flip out.

I should say that it was running fine of the Netrunner ubuntu based so It should be possible get it to work. I will continue troubleshooting, any suggestions are welcome. Thanks!


I don’t have any problems, but I’m running on linux313. Try:

sudo mhwd-kernel -i linux313 reboot sudo mhwd -f -i pci video-hybrid-intel-nvidia-bumblebee

Worked fine for me!


meehh. don’t use virtualgl, primus is the way to go, much faster :wink:

Also make sure your system is up to date, a lot has changed since the ISO was released including how the system handles 3D. the Fist update should be run from the command line:

sudo pacman -Syy sudo pacman -S manjaro-keyring sudo pacman -Suu

If you have issues with signatures (keys):

Rob McCathies (korrode):

sudo pacman-key -r 5C0102A6 sudo pacman-key --lsign-key 5C0102A6

Joshuas Strots (dcell):

sudo pacman-key -r CB6CDD17 sudo pacman-key --lsign-key CB6CDD17

This has been suggested, but to confirm.
My experience: I’ve had all sorts of problems with bumblebee and kernel 3.10, try upgrading your kernel to 3.11 or later:

$ mhwd-kernel -h // For help
$ mhwd-kernel -l // List available kernels
$ sudo mhwd-kernel -i linux311 // Install kernel 3.11 

Wish you best.

yes, some have reported isues with 3,10 and bumblebee, you should upgrade to either 3.12 (LTS) or 3.14 (Latest). to do this run:
rmc is to remove current ie. 3.10 if you want to leave it just in case you can omit this from the commands I gave.

sudo mhwd-kernel -i linux312 rmc
sudo mhwd-kernel -i linux314 rmc

Thanks to you all for the suggestions, really appreciate it.

Unfortunately the problems continued even on the 3.13 kernel and got errors like

primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

when trying to run primusrun glxspheres64

Even trying to run just glxspheres64 I got:

Polygons in scene: 62464 Xlib: extension "GLX" missing on display ":0". ERROR (603): Could not obtain RGB visual with requested properties

I have now gone to the 3.14 kernel. Uninstalled Nvidia-hybrid driver and installed the nouveau-hybrid instead. Reinstalled a bunch of other intel drivers, as well as primus, bbswitch and bumblebee made a bumblebee group added me as a user and s on. Now it seems to work for most times. There as still times after a boot that I get the GPU not accessible error and though that it might have something to do with bbswitch. According to the buḿblebee/bbswitch wiki one should not need to do anything, as the default is to switch off the GPU on start and switch on when shutdown in the /etc/modprobe.d/mhwd-bbswitch.conf it was

options bbswitch load_state=0 unload_state=0

and changed it to

options bbswitch load_state=0 unload_state=1

Maybe that did the trick, will see after a few reboots.

i still get problems with primusrun though. when I do primusrun glxspheres64 i get

primus: fatal: failed to load any of the libraries: /usr/$LIB/nvidia/libGL.so.1 /usr/$LIB/nvidia/libGL.so.1: cannot open shared object file: No such file or directory

Does primusrun only run with the nvidia drivers?


Yes, primusrun is for the proprietary drivers, optirun is used for the free drivers. What exactly are the Intel & Nvidia chipsets in your laptop?

Thanks for your reply once again.

This is the output of lscpi:

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09) 00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09) 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) 00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04) 00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04) 00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04) 00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04) 00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4) 00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4) 00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4) 00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04) 00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04) 00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04) 00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04) 01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M] (rev a1) 02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09) 03:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4) 04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)

Is that enough? Thanks for having a look at this.
Although since things seem to work with the nouveau driver and the GPU is switched off and can be used with optirun I don’t I don’t really need to get the nvidia driver working.