Plasma 5 apps icons theme

How can I set the icons theme for plasma5 apps? (still on kde4)

I’ve tried kcmshell5 icons:

>kcmshell5 icons Could not find module 'icons'. See kcmshell5 --list for the full list of modules.

Is there a settings file, like kdeglobals for kde4?

KDE SC 4 is being phased out as more and more of the KDE Applications are ported to KF5.

Please read the Configuration setting here and follow it:
https://wiki.archlinux.org/index.php/KDE#Installation

Did you enter the --list command already to see the list of available modules? There you should see the module to change the icons.
If not it might be not installed at all

But this would require me to remove kdebase-workspace, which is a dependency for many of my installed packages.

I’m a bit confused as to how to proceed. The simplest option would be a clean install, but rolling 2015.09 is in pre-release and not suited for a production system. OTOH, upgrading my current installation to plasma 5 seems impossible without breaking the desktop.

kcmshell5 --list The following modules are available: cache - Configure web cache settings cookies - Configure the way cookies work filetypes - Configure file associations kcm_activities - Configure the activities system kcm_cron - Configure and schedule tasks kcm_kaccounts - Configure your internet accounts such as Google, Live, Owncloud kcm_ktp_integration_module - General settings for Instant Messaging and VoIP kcm_printer_manager - Configure your printers kcm_ssl - SSL Versions and Certificates kcmdolphingeneral - Configure general file manager settings kcmdolphinnavigation - Configure file manager navigation kcmdolphinservices - Configure file manager services kcmdolphinviewmodes - Configure file manager view modes kcmtrash - Configure trash settings netpref - Configure generic network preferences, like timeout values oxygendecorationconfig - Modify the appearance of window decorations oxygenstyleconfig - Modify the appearance of widgets proxy - Configure the proxy servers used smb - Use to configure which windows (SMB) filesystems you can browse useragent - Configure the way Konqueror reports itself webshortcuts - Configure web shortcuts

So, no icon settings. In order to get icons option, I have to install plasma-meta package, but:

sudo pacman -S plasma-meta resolving dependencies... looking for conflicting packages... :: kdeplasma-addons and kdebase-workspace are in conflict. Remove kdebase-workspace? [y/N] y error: failed to prepare transaction (could not satisfy dependencies) :: expanding-icons-taskmanager: requires kdebase-workspace :: homerun: requires kdebase-workspace :: kcm-touchpad: requires kdebase-workspace :: kdeartwork-colorschemes-oxygreen: requires kdebase-workspace :: kdebase-plasma: requires kdebase-workspace :: kdeplasma-addons-applets-icontasks: requires kdebase-workspace :: kdeplasma-addons-applets-showdesktop: requires kdebase-workspace :: kdeplasma-addons-applets-systemloadviewer: requires kdebase-workspace :: kdeplasma-applets-plasma-nm: requires kdebase-workspace :: kdeplasma-applets-quickaccess: requires kdebase-workspace :: kdeplasma-applets-veromix-git-blueshell: requires kdebase-workspace :: kmozillahelper: requires kdebase-workspace :: netrunnerarch-default-settings: requires kdebase-workspace

:s

This is why I was trying to just set the icon theme manually, through settings files.

The icons are set in the ~/.kde4/share/config/kdeglobals. Just copy that to ~/.config/ and it should apply those settings for kf5 apps aswell

I already have a copy in ~/.config/ , however it doesn’t seem to see my icon theme:

>dolphin Icon theme "OxyElegantBase" not found. Icon theme "OxyElegantGreen" not found. Icon theme "OxyElegantBronze" not found. Icon theme "OxyElegantSand" not found. Icon theme "OxySpring" not found. Icon theme "OxySummer" not found. Icon theme "OxyAutumn" not found. Icon theme "OxyWinter" not found. Icon theme "OxyXmas" not found. Icon theme "oxygencolors" not found. Icon theme "Breathe" not found.

(I’ve copied the theme folder to ~/.local/share/icons/)

The theme folder should be in ~/.icons or globally in /usr/share/icons/

Linked there also, still won’t see them.

Then I am out of ideas. Make sure the theme folder is really the one containing the index.theme file and not that it is hidden in some subfolder.
Though that should make it not working with kde4libs apps aswell.

Yes, If you read the wiki you need to move ~./kde4/share/config/kdeglobals to ~/.config/kdeglobals and make a symbolic link to in ~./kde4/share/config/kdeglobals

You’ll need to do the same thing for kate / konsole / dolphin / the KDE PIM Suite / etc. here is a list of what applications have been ported to KF5 in KDE Applications 15.08: https://community.kde.org/Applications/15.08_Release_Notes

Well, I’ve moved and symlinked, but still it’s not working properly. Furthermore, saving sessions is quirky with KF5 apps, e.g. dolphin only remembers my latest window, and places it on the wrong desktop… I think I will have to do a clean installation.

What is the actual icon theme name I should use? The one in the index.theme file, under the “Name=” tag?

Yeah exactly. I am not 100% sure though I guess this is used as identifier

Then, is there a command I should run to make the system “aware” of the theme? Obviously, placing it in the .icons folder is not enough, since it is not detected.

Normally placing it there should be enough.