preload.desktop error on startup

Since a couple of weeks I get this error on boot: preload.desktop error on startup
It doesn’t happen all the time. When it happens I do a ctrl + Alt + Backspace to restart the dm.
I suspect something in the autostart holding off the desktop from preloading, or is it the sddm?

in the journal current boot:

Have you run all the updates?

If so have you also upgraded to using the 3.18 kernel as described in my last update-pack notice?

The latest upgrade of grub 2 was patched by Manjaro to load the Intel microcode image at boot, however only certain kernel series will work with this patched version.

Please read my latest upgrade-pack announcement here:

I ran the 2014-12-25 updates. The only ones that are still on the waiting list: chromium-pepper-flash cause of the pacman 4.2 issue and I also set up IgnorePkg = dropbox2 dropbox3 in my /etc/pacman.conf because I didn’t have the QT issue with dropbox.

Now you talk about kernels, I’m going to install 3.18 as you suggested. Wanted to wait a little bit longer to avoid possible issues, but it looks like it’s highly recommended.
Atm I’m on 3.17 and have the 3.14LTS as backup. I’ll drop 3.14 and replace it with 3.18.

The 3.17 kernel should be working with the new microcode patch so that isn’t necessary. I would recommend either just downgrade the LTS kernel to 3.10 or wait for the Manjaro to add 3.14 to the patched version of grub2.

Here is what I did, I Installed the 3.18 kernel as my running kernel and then booted into my my backup kernel and downgraded it from 3.14 to 3.10.

Your issue could also be the same as the octopi-notifier not showing occasionally on start up that was reported on the Manjaro forums, this seems to be caused by a pacman db lock file being present when it tries to load. If you have octopi-notifier installed and are having this issue then it’s possible that when this happens the preload script is timing out.

3.10 is no option for me, cause my wireless module was only working starting from 3.13.
But everything looks good, running 3.18 as main, with 3.17 as backup. Will go forward when other kernels arrive.

Don’t have the octopi-notifier installed because I’m using octopi barely, instead of it I’m using pamac.

You mention timing-out. I compared my new log with the pastebin and I see there

jan 02 10:40:14 laptop systemd[1419]: Time has been changed

Could syncing the time having delayed the preload script?

Yes it is possible, but unlikely. The time syncing is done before the gui is loaded, I would be more looking for something that is loaded during the plasma workspace initialization process, like the dropbox systay icon, etc.

Hmm, i use dropbox and copy as cloud sevices. As you see in the picture the dropbox service didn’t load that time in the systray. Maybe I should consider changing to the dropbox3 package?

Yes, I would try that and see what happens, let me know how it goes.

Something to try is to make sure your desktop manager isn’t booting you into KDE failsafe. I noticed during one or two updates my login manager would default to KDE (failsafe), which would cause issues like preload.desktop failing.

Let me know if this helped.