Problems after upgrading with Muon

Dear Community,
i did the daily upgrade by using muon and it downloaded a lot of new software, mostly due the change in KDE to 4.10
Everything went fine except the fact that now i don’t have a window decorator anymore (and changhing or setting default won’t change) and i have some problems also in the lower menubar like erroneous color and transparency.
Is there a way to fix those annoying problems? (especially the window decorator one!)

hello surfino,

what KDE version are you running now?
Can you post a screenshot of the System Settings - Window Decoration?

Just upgraded and am having the same problem. It looks like kwin isn’t running. I installed OpenBox and got a KDE/OpenBox entry in my LightDM login screen, and that seems to be working fine (i.e., I can post this). If I opened a Konsole or Yakuake window, I couldn’t focus on it, so I couldn’t actually determine if kwin was running (after I post this, I’ll try again).

For now, the workaround seems to be:

  1. At login screen, hit ctrl-alt-f1
  2. Log in with your user ID.
  3. Make sure you’re physically plugged in, so you have network.
  4. sudo apt-get install openbox
  5. sudo reboot
  6. At login screen, choose the KDE/OpenBox session and then log in.
    Okay, scratch what I just said. The problem is a simple one: Muon masked an apt error on the kmahjongg-data package, of all things.

A simple sudo apt-get -f install and then a reboot fixes the problem.

Moral of the story seems to be: if Muon is showing a large KDE upgrade, close it and do the update with apt-get dist-upgrade. :smiley:

yuppp, sudo apt-get -f install and a reboot solved everything, i need to use Muon less and less! thanks bro!

I just did the update and got the Muon error as well and I am running the latest download of this OS.

I also just tried this and everything then went smoothly:

sudo apt-get -f install

EDIT: Except when I re-booted, the laptop battery icon now appeared on the right side of the taskbar and says AC is disconnected. But I am on a desktop! Hmmm…