Radeon 4500 Issues

Here is my story. I have been trying to put Linux on my laptop for years, usually a Ubuntu version, and I always have major issues with my video driver. I am again trying to convert over Linux once again and these new versions are having a harder time. I have tried Netrunner and Kubuntu, 32bit and 64 bit versions. The Live OS boots up and works just fine but once the actual installation runs and I try booting from the hard drive everything looks fine throught loading commands but once it switches to the graphical intergace I get white noise. Does anyone know of any reason I would have such a hard time with a Radeon 4500 graphics card? AMD has drivers for Linux on their website but I don’t know how to install them when I can’t get to the OS. Also I don’t understand why the video drivers seem to work just fine in the live version but fail after it is installed locally. I would really like to convert to Linux. Please help!!

Try booting the failsafe mode. This should use a vesa driver instead of the opensource radeon one.

How do I initiate failsafe? I don’t see any kind of prompt when it launches.

Is there anyway to inject the radeon driver from their website?

I have tried a few other versions of linux, all Ubuntu based, and they all give me similar issues after install, completely distorted graphics.

To get past that noise enter the nomodeset parameter in the grub screen…
On the grub screen below press ‘e’ on the line you want to boot…
http://blog.siliconforks.com/wp-content/uploads/2010/05/ubuntu-out-of-range-grub.png

Next scroll down to line shown below and add ‘nomodeset’. Then press F10 to boot…
http://blog.siliconforks.com/wp-content/uploads/2010/05/ubuntu-out-of-range-grub-nomodeset.png