Radeon R9 Fury Driver Issues

Im at a stump… I have tried all linux bases (debian, arch, red hat) and both super new kernels and super old kernels, but my R9 Fury refuses to work properly.

I have also tried using all the propietry drivers available in the kernel, all the open source and the propietary driver available on AMDs website.

Heres whats happening:

  • It seems that the GPU isnt being used. I get extreme lag, when running top I see that X server is using between 40 - 120 % cpu on idle!

  • When I try installing the AMD driver from their site, X server just refuses to even start DERP

Im kinda at the end of my linux knowlege (serves me right for being a sysadmin and knowing nothing about this GUI thing)

More information is needed:
Is this a Fiji and Tonga based card?
If so, you may need to use the amdgpu drivers instead or the radeon drivers.

If this is a R9 270X based card you may need to add the radeon.dpm=0 kernel parameter to grub until AMD fixes the radeon kernel driver.

These should also be supported by the latest catalyst driver, but I’m not sure on the performance.

Note: Make sure to use mhwd to change GPU drivers or they will NOT work properly: