Recording Online Radio w/ Audacity?

I’m trying to record a live stream from an online radio station and audacity is not picking it up, at all.
The input meter is turned up and set to duplex in volume settings.

I even went as far as to take a Y cord and plug my speakers in to the speaker in jack and the second cord to the line-in jack on the back like I used to do with my old computer. That would then work. But now, with my newer puter, it does not work. At least, I don’t know what is wrong.

What should I do?

Board: MSI 760GM-P23
Processor: AMD FX 4300 BLACK EDITION 3.8 GHZ Quad Core - 8 gig cache
8gigs memory
• Chipset integrated by Realtek® ALC887

  • Flexible 7.1-channel audio with jack sensing
  • Compliant with Azalia 1.0 Spec

This is an rather unusual setup you describe there. Couldn’t you just use a streamripper software or even vlc to save the radio stream output ?
Streamtuner is a software I used a few years ago. I am not sure if it is still available though.
But it should with vlc aswell if you use the Convert/Stream option in the menu.

Well, I know audacity works and wanted to use that as I also play bass guitar and want to play along with a stream and Audacity works with my direct-in box.

I ran a Live edition of Mint Mate 64bit just for the heck of it and installed a copy of Audacity and this worked out of the box!

That is definitely strange as we basically ship the same pulseaudio & audacity version as Mint.
Is audacity set to pulseaudio or the pulse device for recording ?
Is the device, when you record via the Y cable, set to record from line in in pavucontrol ?

It just says Pulse and nothing more.



You could try installing and using pavucontrol to select the Pulse audio input device or I think you can also use veromix to switch input and output devices on the fly via Pulse. I’m not 100% sure on the second option I gave though.

I installed pavucontrol and nothing much changed. Here is a pic of my recording drop-down. I had to snap a pic from my cellphone and upload it as the screenshot program does not capture drop down menus.

I did have it streaming yesterday for a bit and then it just stopped and haven’t been able to get it to work again.
Also, Audacity keeps crashing. That drop down menu in the pic I uploaded??.. well, after Audacity crashed and I reloaded it, the menu went back to default and now only has 5 options listed. How I feel about this all?? Just see my avatar for a quick explanation!

Have you tried selecting pulse from that drop down as the input device?

Yes… 8/

OK then I have no idea. :slight_smile:

I don’t record such things myself.