sddm.conf changes

The update to SDDM 0.9.0+git20141003.ef14018-2 has some file placement changes that needed to be reflected in the sddm.conf file.

SDDM no longer stores it’s files under /usr/share/apps/sddm/ but they are now stored in /usr/share/sddm/.

There are also some new configuration options in SDDM that add functionality that was missing in the original version that shipped in Netrunner Rolling 2014.09.1 and 2014.04.

I would suggest making a backup of your current sddm.conf file and overwriting it with the sddm.conf.pacnew file, next delete the /usr/share/apps/sddm/ directory, and finally log out and back in.

PS, you won’t believe how much better and faster it works after making this very tiny fix.

Call me dense but not seeing any sddm.conf or sddm.cof.pacnew file.
In usr/share/sddm or usr/share/apps/sddm.

Is that a result of me switching to KDM? Or something else?

Sorry being so dense. But learning as I go.

I can’t believe I left that part out, I have to quit assuming everyone knows these things, I do apologize,

The sddm.conf and sddm.conf.pacnew files are located in the /etc folder. Everything else was moved from /usr/share/apps/sddm to /usr/share/sddm.

Okey Dokey and thanks for the info. Guess I will wait after the update when?
And swap from KDM back to SDDM.

And words on when they will add more themes or the ability to download and install themes?

Thanks as your info is always helpful.

It comes with 4 themes by default and Manjaro has one of their own in the repository.

Pre-installed: Circles, Elarun, Maldives and Maui

Manjaro community repository: sddm-manjaro-theme

AUR: sddm-archlinux-theme-git and sddm-futuristic-theme

A few more here:

Hmmmm strange as was running KDM so I changed back

sudo systemctl disable kdm.service -f
sudo systemctl enable sddm.service -f

Which created a symlink To re-enable SDDM? And went into System Settings and no Themes showing.

And even tho I have auto-login enabled it still boots up to SDDM Logon screen lower res then my desktop?
Or maybe just the resolution of Maui? which isn’t even listed in themes.

So not sure if it’s me?
So appears has to do with the default ssdm.conf vs. sddm.conf.pacnew.
So going to follow your advice and replace default with the pacnew version.


Update auto-logon did not happen. After renaming ssdm.conf.pacnew to ssdm.conf
So took a look.

First 2 lines were blank. Even after a re-boot.


Even tho had auto-logon enabled. So filled them in myself.But still no themes listed in Sddm settings. Even tho the path for themes looks right. Also there seems no cursor theme set tho I selected black for cursor theme.


Only added the two entries at the beginning Autologin section. Otherwise is the .pacnew renamed to sddm.conf



HaltCommand=/usr/bin/systemctl poweroff
RebootCommand=/usr/bin/systemctl reboot




Tho manually changing maui to elarun works if you do a reboot. So manually can change themes. Tho still not showing in Startup and Shutdown>Sddm>Themes.

Also installed sddm-manjaro-theme from Octopi. But appears it gets installed into usr/share/apps/sddm. Which may be problematic during the default path changes in transition.


Yes, This is a known issue kcm-sddm-git from the blueshell repository is compiled from a discontinued branch and is not compatible with SDDM 0.9.0. There is a newer version of sddm-kcm is in the community repository but I haven’t been able to get it to work yet, I will keep you posted, but for now manually editing the sddm.conf file is the only option.

Thanks for the heads up on sddm-manjaro-theme needing to be updated, I’ll let Philip know. For now you can move them manually, just remember to delete them later once the package gets updated or it will fail to install.

Does it really make a difference if I delete /usr/share/apps/sddm/ ? I mean, I have already overwritten sddm.conf with the pacnew version, so /usr/share/apps/sddm/ is not even searched (if I understand correctly).


That would be up to you, since you already made the change to use the sddm.conf file that point’s to the right place then that directory and the files contained within it are just taking up space.

note: Technically you could just delete the sddm.conf file as it is no longer required by SDDM to function, it’s currently only used as fallback if xsession, XAUTHORITY, etc. are not setup properly or at all, SDDM can now also use journald and pam as long as they are installed on the system

The latest release version (0.10.0) of the SDDM package that will be coming in the next update-pack is going to remove the sddm.conf file anyway and leave a pacsave file in it’s place.

Keep in mind that SDDM is under active development, besides reading the changelog, you can also read the issues and pull requests from here:

Hi guys.

I’ve followed the instructions and checked that the sddm.conf file (copied over by the info in the sddm.con.pacnew file) is pointing to the correct file folders, but I still can’t seem to enable my previous login theme (the maldives theme)… There must be something obvious I’m not doing :s

You can change the theme in the sddm.conf file under [theme] > current=xxx, but for now a reboot is required for it take effect, just logging out isn’t going to do it.

Ah, I thought the file changes would show up in the “Login Screen SDDM” settings, (there are currently no themes shown in the dialogue/settings box). Changing the theme name in the settings file worked perfectly though. Thanks AJSlye. :slight_smile:

Yes, this is a known problem.

The installed kcm-sddm-git package was originally intended for use with sddm version 0.1.0, sddm has since been updated to version 0.9.0. There is a newer sddm-kcm package, however this version only seems to work under KF5/Plasma 5.

Please, keep in mind also that SDDM is still under heavy development and is continually improving.

Here is a link to the change log:

I’d also like to mention that SDDM version 0.11.0-1 is currently in the the Manjaro testing branch.