[solved] After installing, boot option is unavailable in BIOS

I followed the installation instructions properly, except for the part where I was to select the “Install Netrunner side-by-side” which wasn’t there so I did manual. When I did, I gave 10 GB of Linux Swap, and 90GB to Netrunner.

Did I do something wrong?

I don’t think you did anything wrong. Though 10 GB Swap is a lot. I don’t think you will ever be able to fill it.

Do you have UEFI or bios compatibility mode or plain old bios?
If you have uefi you need to make sure to have an efi fat32 boot partition.
If you have bios it seems like the bootloader was not installed. Can you boot the live system again and double check with the partition manager if your root partition (the one you installed netrunner onto) is marked bootable

And how would I check if a partition is bootable

The partition manager should show you flags of every partition. If the particular partition has no flag boot set please try setting it.

I set the Netrunner partition flag to boot but it still doesn’t show in BIOS

Then please reinstall Netrunner and see under advanced options if grub is installed to mbr

Where is the advanced options?


The advanced partitioning or manuall partitioning in the installer

OK that’s what’s currently in the screenshot but how do I check if grub is being installed to mbr. Sorry for all the questions, I’m new to these sorts of problems.

Ah I missed the Screenshot (somehow the forum seems still to be broken in that regard). Yeah /dev/sda is the mbr of the first hard disk. So it is correct.
But what I noticed is that you have an awfully lot of partitions and no extended partition. So it must be a gpt partition scheme you are using. This is usually only used with UEFI.
So do you have uefi now enabled?
I see several ntfs partitions. Do you have Windows still installed? Is it bootable or does nothing boot at all from that harddrive?

From the Live-USB, I selected the non-UEFI option. (Not sure if this is what you meant…) Yes, I do have Windows installed which is bootable.

I fixed it, I had to install it in UEFI mode (Insecure mode). I had CSM enabled, and for some reason, it wouldn’t install in EFI mode but it worked in UEFI mode!