[SOLVED] Baloo using too many resources

Is there any way to shut off this horrible file indexer? It runs for too long, uses 40% of my cpu, and uses battery like crazy.

There are various hacks on different forums, but nothing that works so far with my system. My Netrunner Rolling is updated to the newest KDE, and is up-to-date.



When you say the newest KDE I assume you mean KDE SC 4.14.6 as that is the officially supported release, or do you mean that you used my guide to update to Plasma 5 (which is not to be called KDE anymore) from KDE SC 4?

If you mean the latter then baloo will settle down once it is done indexing, then it takes very little resources. On my system it takes up no more than 20 K of memory and 30 K of shared memory at any given time. However, if you really want to disable it look under System Settings > Search, you will know what to do from there.

Thank you. Yes, I updated to Plasma 5 per your instructions weeks ago, but didn’t notice this Baloo thing until tonight for some reason. Sorry about the “KDE,” I didn’t realize that term wasn’t used.

Thanks again for the quick reply.