[SOLVED] Bash update

New update of bash ended with errors, and now I cannot use konsole, kdesu or octopi. Help please

I got the same error. First update of a brand new install.
No bash, no updatey.

That’s strange, the update went smooth on all five of my machines. What was the error you got when it was updating?

Which version 32bit or 64bit?

Mine was a 64bit version. After 2nd or 3rd reinstall the bash update wasn’t there anymore which is very strange but then I got some problem with plymouth process taking up to 1.5GB of RAM after some time…unfortunately it looks like I don’t have luck with netrunner :frowning:

I just reinstalled and it happened to me again. When I go into Octopi, there is one update listed - bash. When I hit the green check and enter my password, a message in the Output tab says that there is a database error - duplicate entry for bash. It goes through the motions, then finishes with errors. After that, my system is hosed because I can’t do anything without bash, unless there is another shell installed I can work with.
[hr]
And now, for some reason, I can go into Yakuake and have a working terminal…

There was another bash update tonight, everything fine here.
It sounds like your having a pacman database issue.

Try this before you do anything else:

sudo pacman -Scc
sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman -Su

The solution to that particular problem is here: http://forums.netrunner-os.com/showthread.php?tid=16393&pid=22487#pid22487

Hi AJ Could you please tell me how I can use pacman to update the latest bash fix without having to update the complete Rolling Netrunner OS which takes at least 90 minutes. I already have Linux 3.10.54-1-MANJARO and the first bash fix.

I tested my system for the latest threats and my bash fails this and I have seen this fix already posted (43-027).

You could just install it this way

sudo pacman -Sy bash
This should also update to the newest version.

Hey Leszek Thanks very much. Pasted your pacman command and it worked well and quick.

I tested the bash with this code that my system had failed with before

$ foo=’() { echo not patched; }’ bash -c foo
result
bash: foo: command not found

So, my bash looks clean with this new fix.

That’s all fine and dandy, just don’t wait to long before updating your system, otherwise issues like this will happen. Manjaro Linux in which Netrunner Rolling is based pushes out update packs every two to three weeks on average, If you get too far behind the updates can and will fail.

Thanks again. And to guide me to the right place for the info and time when these system updates are ready to download, should I be looking at the forum pages for Rolling or the security updates or the general Netrunner website or even the Manjaro website or forum.

Please do not take this as any criticism because you have been very supportive in terms of response time and info, but sometimes it is not so easy to find a clear punctual action to remedy a situation. All the info you and Leszek have provided have worked first time with no loading or operating problems on my system. All very impressive, guys.

Thanks TrevorK, I’m glad you have been helped!
We have also updated the info in the Readme Section, which every new installation has linked right on the desktop:
http://www.netrunner-os.com/readme-1408/
So hopefully, this bash situation will have been resolved by now without further updates.

There are still some security concerns with bash but most have been taken care of, as patches come out bash will continue to get updated.

Keeping your system up to date on a rolling release is very important, not only for security reasons but also stability and features. The ability to keep up with the update-packs is a very easy thing to do, they come out approximately every two to three weeks on average, and I usually make a post here in the forums when they are rolled out. If you would rather be notified on your desktop when updates are made available, octopi-notifier is a nice addition to octopi that will give you a tray notification when updates are available, sometimes even before I have a chance to announce them.

sudo pacman -S octopi-notifier

Thanks AJ. pacman installed octopi notifier correctly.