[SOLVED] bluetooth headset issue

Hi all,

I want to use a bluetoth headset for audio and voip on enigma. The device was paired and I can choose it in the pulse volume control but I still cannot get sound of it. The device doesn’t appear in KMix.

Any ideas?

Thanks in advance.

If you have pulseaudio installed and pavucontrol please check the volume levels and if it is not muted.
Otherwise also alsamixer in a terminal might help you. You can press F6 here to choose the soundcard.

Nothing is muted. alsamixer doesn’t save my set up and I am pretty confused with alsamixer, KMix and Pulse. After enigma inntallation I ve managed to get sound out of my usb logitech boxes. The bluetooth headset didn’t work at all and now none of them is working. I remember from other distros, pulse was the right way for my usb boxes. How should I configure the audio settings? Which packages I need?

You mean that alsamixers volume changes aren’t saved ?
Does the bluetooth device appear in alsamixers F6 menu ?

Do you have set the bluetooth device as default in the sound application you use (music player or voip application) ?

  • I mean the “sound card” is’t saved.

  • Yes it appears.

  • Yes I have set the bluetooth device as default.

Now I have bought 2 other headsets, one with cable and another one wireless (2,4 GHz). Again none of them is working.

Another thing is that bothers me are the apps for setting sound. So there is phonon, alsamixer, pulse, KMix. Do I need them and must I configure all of them?

Pulse normally isn’t there in a fresh enigma (13.06) install. Phonon is only relevant for KDE apps.
If you have Pulseaudio installed is it possible to choose the bluetooth headset in Kmix when you left click the tray and then right click the playbackstream of your app?

I ve established a bluetooth connection and I was able to see it in all apps but still no sound. Besides that, some icons in my taskbar have vanished including bluetooth (attachement).

I have tested my 2,4 GHz headset on another machine with kde mint 15 and it’s working fine (at least the headphones). So the issue has nothing to do with my settings.

You forgot the attachement.

How come you know that the issue has nothing todo with settings ? If it is working in Mint and its not working with Netrunner it is most probably a settings issue.

Did you try setting the sound output in kmix like I described it ?

Website don’t like .png files?

Thanks for your quick responds.

As I said before I have tried what you ve mentioned before I lost my bluetooth icon.

How can I bring the icons from the taskbar back?

Ah now I get it. You accidently deleted the tray widget. You need to add it again by clicking on the far right icon (it turns yellow if you hover over it) and then add widgets. There you need to search for a system tray widget. You can add it by double clicking or dragging it to the panel.

I don’t guess rightclicking on the little kmix mixer popup did delete it for you. Could you please try that again. KMix should show you the playback stream with a left click and right clicking on that playback stream should give you a menu were you can choose the sound output. So in your case your bluetooth headset.

The tray is workin again normally. Thanks.

I ve reinstalled pulseaudio and now my usb speekers and one headset are working too.

I ve tried the bloototh headset but I think now it’s not an issue any more.

So thanks again.