[Solved]: Desktop Appearance selection causes System Settings crash

After the most recent update, where there were theme and artwork changes, I tried System Settings -> Desktop Appearance. The moment I select Desktop Appearance, the System Settings window literally crumbles away and disappears. I hope this behaviour will not persist.

I tested these packages thoroughly on a fresh install of 2015.09, a fresh internal 2015.11 RC2 install, and an updated system before uploading the packages to our main repository, It shouldn’t be doing that.

Could you open up system settings from the terminal and post here any errors in the output when this happens.


Also did you update your system with Muon updater, Octopi, or the command line?
The reason I ask is it appears there is still an issue with Muon not installing / updating packages with the replaces field in them.
If this is the case please use the command line to update:

sudo pacman -Syyu

I had originally upgraded from the terminal using

sudo pacman -Syu

The results from running


from a terminal are:

[code]Error loading plugin “kcm_lookandfeel” “The shared library was not found.”

Plugin search paths are ("/usr/lib/qt/plugins", “/usr/bin”, “/usr/lib/kde4/plugins”)
The environment variable QT_PLUGIN_PATH might be not correctly set
Segmentation fault (core dumped)[/code]

In case it helps, I do not know if this is an echo from something residual in $HOME from my previous Kubuntu installation. On installing NRR1509, I took pains to:

[]copy the .config directory: cp /etc/skel/.config $HOME/.config
]renamed my old $HOME/.kde and $HOME/.kde4 directories to $HOME/.kde_old and $HOME/.kde4_old.
Finally, please clarify the difference between sudo pacman -Syu and sudo pacman -Syyu and when to use each.


Those are the correct plugin paths, I’m not sure what the issue on your system.

The second y tells pacman to resync the local database regardless of reported state of the mirrors.

These might be helpful:

You may have only recieved a partial update.
Try this:

sudo pacman -S netrunner-rolling-default-settings bluex-lnf-theme netrunner-lnf-theme netrunner-rolling-system-settings

I have tried the above with no change in results.


gives me


Would explicitly setting it solve the problem?

Explicitly setting


did not help.


pacman -Qo kcm_lookandfeel


error: failed to find 'kcm_lookandfeel' in PATH: No such file or directory

Kindly suggest what else could be done to iron out this problem.

System Settings is otherwise working except for Desktop Appearance as far as I can tell.

Your issue has to have something to do with keeping your home directory. You probably should have also renamed .config and .local in the same way as .kde and .kde4 since this are where Plasma 5 now keeps it’s config files.

Run the following command:

kcmshell5 lookandfeel

If the look and feel module loads then something else is wrong.

Also pacman -Qo kcm_lookandfeel wouldn’t report anything since this wouldn’t normally be in the path, it’s a .desktop file and not a lib.

Try creating a new user, and see if that one has the same issue.

Could you also please run the following command and post the resulting txt file:

pacman -Q > package.txt

The lookandfeel module did not load without an error message.

It is indeed a legacy home directory issue.

I renamed the existing .config and .local directories and copied the /etc/skel/.config and the /etc/skel.local directories to $HOME. I renamed the .kde4 directory just in case.

On rebooting and logging in, I have got the equivalent of a new user in terms of look and feel.

The reported problem does not arise any more.

Do you need me to give you the remaining diagnostics, or can I mark the issue solved?

Thank you kindly.

Well, you should also copy /etc/skel/.kde4 over to your home directory as well, there are some config files and symlinks in there that are needed for certain applications and settings to work as intended, especially since you renamed this folder essentially removing it. However, for the most part I’d say this is now solved.

Thank you for that last reply. I needed to do that as well because the problem re-surfaced but went away (hopefully finally) after I did that.

Just for the record, and to help those who are migrating from Kubuntu and hoping to preserve their home directory contents, here is what needs to be done:

cd $HOME mv .kde4 .kde4_old mv .config .config_old mv .local .local_old cp -a /etc/skel/.kde4 $HOME cp -a /etc/skel/.config $HOME cp -a /etc/skel/.local $HOME

Reboot and login.

The disadvantage is that some favourite system or application settings will be gone and need to be set again. The advantage is that one starts off with a pristine account without losing the other data in one’s home directory.

OK, but I believe in Kubuntu it would be .kde not .kde4.
Actually you should do this part in your home partition before installing Rolling:

mv .kde .kde_old
mv .config .config_old
mv .local .local_old

Hopefully, you did NOT install this over an existing system with only a single partition, and that your home directory was on a separate partition from /. If not you have more serious issues than the home directory.

Touche. Yes, my home directory is in another partition, and ideally, I should have done the above while running the NRR Live CD.

Strangely, there was a .kde4 in my Kubuntu setup, but that might have been from some other distro that I had tried out in the past.

I now realize that preserving the old configurations might be more trouble than it is worth: a fresh setup avoids puzzling and uncommon behaviour downstream.